Hdmi grabber?

    • Official Post

    Short instructions:

    WebUI is located on http://localhost:8090

  • I used hypercon to install hyperion, I will do this command when I get home.. i will keep you posted and thanks allot for helping me out.

  • How did you install the official branch of hyperion.ng?
    Which device and which os do you use?

    I have hyperion installed on my pi this is the OS i'm running....

    pi@raspberrypi:~ $ lsb_release -a
    No LSB modules are available.
    Distributor ID: Raspbian
    Description: Raspbian GNU/Linux 8.0 (jessie)
    Release: 8.0
    Codename: jessie

    When I try to run the command "cd hyperion" I get this

    pi@raspberrypi:~ $ cd hyperion
    -bash: cd: hyperion: No such file or directory

    sorry not sure what to do.

  • did you execute this command before that?

    "git clone --recursive https://github.com/Paulchen-Panther/hyperion.ng.git hyperion"

    Your right i missed that line.... i now get this error..

    pi@raspberrypi:~/hyperion/build $ cmake -DCMAKE_BUILD_TYPE=Debug ..
    -- PLATFORM is not defined, evaluated platform: rpi
    -- PLATFORM: rpi
    -- ENABLE_FB = ON
    -- ENABLE_V4L2 = ON
    -- ENABLE_WS281XPWM = ON
    -- ENABLE_X11 = OFF
    -- ENABLE_QT = ON
    -- validate json files
    checked files: 76 success: 76 errors: 0
    -- validate json effect files
    checked effect files: 36 success: 36 errors: 0
    -- validate json file
    -- Current Version: MJPEG (GitHub-d3a0fd0/b1b5bc4-1551636880) Git Remote: https://github.com/Paulchen-Panther/hyperion.ng.git
    -- Found Qt Version: 5.3.2
    CMake Error at CMakeLists.txt:262 (message):
    Your Qt version is to old! Minimum required 5.5.0

    -- Configuring incomplete, errors occurred!
    See also "/home/pi/hyperion/build/CMakeFiles/CMakeOutput.log".

    then i get this when i try the next command

    pi@raspberrypi:~/hyperion/build $ make -j $(nproc)
    make: *** No targets specified and no makefile found. Stop.

    sorry if im not that crazy advanced at linux stuff

    *** I figured it out.. I updated my distro to the newest one now just waiting for building to complete***

    Edited 2 times, last by pigbait ().

  • ok so the build is complete, what a run the last command ./hyperiond -d i get this and i dont think i can use hypercon anymore?

    [hyperiond V4L2:auto] <ERROR> Frame too small: 42236 != 4147200
    [hyperiond V4L2:auto] <ERROR> Frame too small: 42236 != 4147200
    [hyperiond V4L2:auto] <ERROR> Frame too small: 42236 != 4147200
    [hyperiond V4L2:auto] <ERROR> Frame too small: 42236 != 4147200

    I see i need to use the webGUI now ..but how do i setup hyperion to auto start

    Edited 2 times, last by pigbait ().

    • Official Post

    ok so the build is complete, what a run the last command ./hyperiond -d i get this

    OK. I think I have the frame size calculated incorrectly. I will fix it as soon as possible.

    but how do i setup hyperion to auto start

    autostart scripts can be found in the directory /bin/service

  • So last night i did a fresh install, Hyperion will work when I run the command ./hyperiond -d in my Putty terminal... but the minute i close the terminal it kills hyperion? anyone have an idea what i did wrong?

  • You did nothing wrong. When you start hyperion with ./hyperion -d it will start in your shell. If you close the shell, you close the program which is running in it.

    So you'll have to run it at a service. You can take the service which @Paulchen-Panther mentioned in his post und install it to the system. You have to copy the build files which were created by compiling in your build/bin directory to the directory which is used in the service. (/usr/bin)
    You can either use the normal initd script or the systemd script. Please check google how to handle with services and init.d scripts and how to install.
    If you have specific questions to that I am willing to help.

  • Hello.

    I was unlucky and got grabber with only supported mjpeg pixel format.
    Is there any updates to adding support of mjpeg to hyperion?

    Right now I'm using workaround, created virtual device via v4l2loopback and converting mjpeg to uyvy, but it eats 15-20% of cpu.

  • I compiled branch and tried to get screenshot:

    Seems I missed some additional parameters for mjpeg, but for uyvy I got screenshot without any additional parameters.

    Then I launched hyperion, enabled usb capture and live video began working without problems:

    But if I will make some changes to USB capturing configuration I'm getting alot of errors in output until restart of hyperion (in this case I just changed /dev/video0 to auto. Live video still working).

    [hyperiond V4L2:auto] <ERROR> Throws error nr: VIDIOC_DQBUF error code 16, Device or resource busy

    Also if I will change Video standard to something different than auto, I'm getting black screen in live video, regardless what setting I chose and what video standard is set on grabber.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!