How to setup Hyperion with a Yeelight solution

  • Hello everyone,

    I want to embark on the Hyperion adventure, but ... not like everyone else.
    Indeed, I have in my possession:
    - 2 Yeelight Bulb
    - 1 Yeelight Lightstrip

    I saw here that it was possible to connect his Yeelight system to Hyperion:…-udp-server-solution.529/

    But, I don't really understand what to do.
    There isn't much tutoriel on Internet for such a configuration (Yeelight + Hyperion). In addition, these tutorials all refer to the link above.

    Can you help me ?

    For information: I have a raspberry Pi 3 B +. I want to install Hyperion on my raspberry, and run my Kodi on a Xiaomi Mi Box.

    Thanks ☺

  • Hello, I'm trying to do the same. I saw that it's possible but I haven't got.
    I have a Raspberry Pi 3, with OSMC, and the last Hyperion. I can enter to the web config in port 8090, and it find my two yeelight bulbs but they don't light.

    • Official Post

    @Iam Tobe I still need to do some documentation on Yeelight.
    Nevertheless, after using the Wizard the Yeelights should work. Sometime you first need to restart hyperion...(for that we have an issue already logged).

    As it looks like that the configuration did not work at your end automatically.
    Would you mind activating the debug log mode (in the UI System->Log),
    plus then start the yeelight wizard and do the config again?

    Does the "Identify Light" button works for you? i.e. the respective Yeelight blinks red/blue?

    Please share a screenshot of the wizard (see sample below) and the log-output with me, please.
    I would like to explore, if it is a coding or documentation issue.

    Thanks for your support!

  • Thanks for your support. I have activated the debug mode. When I enter in the Yeelight Wizard, this is the appearing window:

    The Identify button don't produce any effect, and both light and ambilight don't work. When I put the bulb IP in 'Network devicename', it does work without problem. Though the majority of movies are continously blinking (losing the HDMI source). Then, I change this parameter in 'Platform Capture':
    Height: 64
    Width: 64
    Capture frequency: 30

    And it work with all the movies.

    I paste the debug output:

    Thanks again!


    • Official Post

    Thanks for coming back with the details.
    It looks like that the routine resolves the hostname for the bulb as "192", but when using the name, it does not resolve into a proper IP-Address.

    In the 2nd case where the "identify" worked, do you have a screenshot there too.
    Is in that case the value in brackets, e.g. (192) different?

    If you do a (replace 192.XXX.XX.XXX with the lights IP)

    arp -a 192.XXX.XX.XXX


    ping -a 192.XXX.XX.XXX

    What name does it resolve in?

  • I am trying to run again the wizard but it keep in this window:

    This previously happened sometimes, but now I have tried multiples times and it doesn't pass this window.

    Just now, I have removed the LAN permission for the bulb from the xiaomi app, and I have got this:

    It is strange because the name that is automatically assigned to the strip (the only one bulb with LAN permission just now) is 'conf_leds_layout_cl_entire'. But yesterday, in my router, it has the name 'yeelink-light-strip2_miap7fe2'.

    I will repeat the wizard later until the both bulbs were found.

    This is the ping output for the two bulbs:

    • Official Post

    But yesterday, in my router, it has the name 'yeelink-light-strip2_miap7fe2'.

    Yes, this is what I expected to get back in the UI. If you see my screenshot, it exactly follows the same logic of the prefix.
    Sometime it helps,if the lights are longer in the network...I still have not figured out the logic....
    I might need to fall back to configure IP-addresses, which I currently avoided. In case an IP-address change, users complain that lights are not working...
    And not everybody is able to configure fixed IPs in their routers.

    In addition, could you do me a ping with "-a" that the name is resolved during the ping, please?
    I am not interested into the ping-time, but how the name is resolved.

  • ping -a gives an error:

    And arp -a gives only the IP and the MAC address of the device.

  • For what it's worth :

    I have a Yeelight bulb in my room, so I've created a new instance and launched the Wizard.
    It has found my bulb instantly, and with the same name as defined in my router.
    I've set up its position, saved settings and ambilight has started instantly on the bulb.
    It won't help you debugging, I'm aware of this, but it shows that sometimes it can work flawlessly ^^
    PS: my bulb has a static IP address on my network.

    • Official Post

    @iam960 I guess I know the issue.

    I try splitting the domain from hostname.
    If the Hostname is an IP-Address, then it looks like I am splitting wrongly...
    I will have a further look into the scenario.

    • Official Post

    @iam960 I fixed the issue. You could try the fix downloading the version build as part of the following PR:

  • I tested this and it's working great on my *nix box. However I'd like to run it from a docker container so I can use it on Windows. Screengrabber -> Hyperion -> WLED.
    Is it possible to configure this to advertise a different IP? The problem on docker on Mac and Windows is you can't do host networking, so when it turns on music mode it gives the Yeelights a private docker network IP in the 172.x range :(

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!