dmanum 10 PiZeroW - Color Wheel turns white then off/on

  • I am having difficulty calibrating HyperCon with my setup:


    RGB LED WS2812B connected to 5V-15A power supply and Data In connected to Pi Zero W pin 19.
    Pi Zero W is connected to USB On the Go cable to Video Grabber UTV007.
    Video Grabber is connected to RCA cables to RCA/AV -> HDMI box which is connected to the HDMI Splitter.
    HDMI Splitter Input is connected to PS4, one Output to TV, the second to the RCA/AV -> HDMI box.


    The LEDs are powered by the power supply from both ends (at first just one end of the strip, then tried both start and finish sections of the strip).


    The Pi Zero W was first powered through the Mini USB -> standard 5V 1.8A phone charger.
    Then I tried powering the Pi's 5V and Ground pins with the LED strip's 5V and Ground.
    Then I tried powering the Pi's 5V and Ground pins into the power supply.


    All my efforts have led to the same result:


    Once the Hyperion color-wheel starts, it immediately turns white for 5 seconds then begins power cycling.


    I have selected the WS281X-SPI driver Type with GRB Byte Order, LED Bottom Right Clockwise with 85, 45, 47 LEDs on the horizontal, left & right.
    Blackborder detection is Enabled.
    Linear Smoothing is enabled with Update Frequency at 30Hz.
    Video Grabber is set to NTSC on HyperCon, and the RCA->HDMI device is set to NTSC.


    I tried editing the hyperion.config.json to add the dmanum=10 line under the device block, but it still reacted the same way.


    Is this a power issue?



    Not sure if this log helps:

  • I was messing around with the set up today and accidentally crossed the LED's 5V and Ground wires.


    Now every time I start Hyperion, the LEDs turn white (the color wheel start up is gone) and the power cycle is still intermittent (every 10 seconds or so).


    Before I could select a color on the SSH - Colorpicker and it would briefly show the color then off then turn white within a second.
    However, when I select a color on the Colorpicker now, it turns off then turns back on to white (no more color change).


    Did I short the LED circuit? :(


  • Nope, I just had the Luminance set at 0.04 for prior testing and forgot to reset it. When I put it back to 1, the Hyperion startup color wheel reappeared!


    Now back to my initial problem solving! :D

  • Do I need a resistor?


    My LEDs have 3 connections/pins: 5V, Data In, and Ground. The Data In has three wires soldered to it (came that way): red, green, and white.


    I've tried connecting green only, green and white + red to power supply etc, but same results.


    Are the LEDs turning white because of a high power signal?

  • OMG I did it!


    I have no idea, but I copy pasted the dmanum block instead of the two lines and got it working.


    If anyone needs help with this exact set up, please let me know and I will offer assistance to the best of my ability!


    Woooohooooo :D


    Config:

  • Nevermind, I unplugged the set up and when I came back to plug it in, it repeated the same issue (color wheel then white lights).


    It'll grab the signal and display the LEDs for a few seconds, but then revert to white (repeats this over and over).

  • I was reading on another thread from this site that I need to keep the SPI core clock stable (too low would give white lights and too high would give black), and that under-voltage would cause issues.


    I'm not using a level shifter by the way, but I ordered some.


    Any idea how I can control the SPI clock?


    Would the level shifter correct the under-voltage (3.3v) from the Pi 0?

  • I have my pi zero 5V pin, LED start 5V pin and LED end 5V pin all sharing the same DC Jack 5V terminal (along with their ground terminals in the same DC Jack Ground terminal).


    Just want to make sure that this is a safe way to power everything as the DC Jack seemed fairly warm after two hours.


    I'm gonna mess around with the core clock config settings today. I'm also receiving the logical level converters today to try out. Will update soon.

  • I figured it out finally!
    Just had to set gpio to 19 in the header of the hyperion.config.json