Unresponsive LEDs with LibreELEC on HTPC

  • Greetings to the community and thank you for all your amazing work.
    I decided to dive into the DIY Ambilight project, got a 5m ws2812b strip, a 5V20A power adapter to run the strip and an Arduino Uno. My current setup consists of a custom made Intel based HTPC running LibreELEC.
    So i hook the Arduino up on my PC, download the Adalight and FastLED libraries and upload the sketch that i read is mostly used:


    The LEDs go blink and so far so good.
    I then install Hyperion through LibreELEC's repository and connect Arduino to my HTPC via USB. I run Hypercon on my pc, connect through SSH and follow instructions to eventually upload this:


    And that's about it. No rainbow effect on my strip, no single colour when trying the colorpicker through SSH, nothing.
    Wanted to use an external grabber as well but i imagine i'm pretty far off until that's happening.
    Couldn't find people using an HTPC while running the Hyperion Ambilight, most use Rpi's so i couldn't find much help in the forums.
    Any assistance would be deeply appreciated. Many thanks in advance for your time and effort!

  • Thank you for your swift response. So you suggest i try different ports on my HTPC, correct? i actually tried a second one while i was messing around, but still nothing happened. I will give it a go and try them all and let you know.
    Thanks again!

  • ok so when i run the command through putty, i get two result while the Arduino is hooked. i get /dev/ttyACM0 and /dev/ttyACM1
    if i unplug it and run the command again, i just get /dev/tty/ACM0.
    i switched the hyperion config file to this:

    meaning i just typed ACM1 in the hypercon hardware output tab. now when i press start on hypercon to start hyperion all of my leds (300 while only 200 are specified) flash white two times and then nothing more.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!