Hyperion crashes during startup

  • Hi all,


    unfortunately I have a problem with the Hyperion startup. My system is a Raspberry Pi Zero with a WS2812b at GPIO18 which works fine when I run the following python code for example:

    Code
    import board
    import neopixel
    pixels = neopixel.NeoPixel(board.D18, 299)
    pixels.fill((40, 15, 0))


    When I try to run Hyperion it gives me the following log output:


    I both installed Hyperion via Hypercon and via command line without luck. I changed the HDMI and audio settings in the boot config.txt but still without success. Now I'm running out of ideas and thus I need your help and advice.


    Thanks in advance and best regards!

  • Unfortunately Hyperion still doesn't work although I built the rpi_ws281x library with "scons deb". Its test program is working fine again. But no luck with Hyperion. What am I missing?

  • Yes I changed the DMA to 10, but still the same problem/crash. Do I have to build the rpi_ws281x library in another way instead of "scons deb"? What and where is the built output? Where do I have to copy it? How does Hyperion know to use it?

  • What else have you tried from that page?


    Do I have to build the rpi_ws281x library in another way instead of "scons deb"?


    No need to build the library. Hyperion has it built in.


    What and where is the built output? Where do I have to copy it? How does Hyperion know to use it?

    Again its built in. No need to bother.


    The important part on that page is in this section ( https://github.com/jgarff/rpi_ws281x#limitations )
    Try the suggestions in that section.


    Try these steps, as it uses the SPI portion of the driver instead of the PWM portion. https://hyperion-project.org/t…rom-host.3187/#post-12230

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!