hyperion NG installation

  • yes on osmc


    but as always: .ng is not final, so you have to do it on your own, if you know how to do it...


    I have OSMC kodi 17.6 up and running.
    Then I used your Hyperion.NG kompilieren und installieren auf einem Raspberry Pi youtube tutorial (I skipped raspbian part).
    I did include
    sudo apt-get install rbp-userland-dev-osmc ( it seemed important since it mentioned OSMC)


    From the looks of it,hyperion ng got installed. I can access configuration menu of hyperion,select controller type etc. But the lights are not responding.
    When I putty hyperiond it says :
    [hyperiond LEDDEVICE] <ERROR> Failed to open device (/dev/spidev0.0). Error message: No such file or directory
    and it keeps repeating :
    "No carrier"
    "No carrier"
    "No carrier"


    Could it be I was on the right track? What else do I need to do?


  • Do you enabled the SPI Interface with raspi-config?

  • Do you enabled the SPI Interface with raspi-config?


    No but, I have made several attempts.
    I used code:
    sudo raspi-config
    which works on raspbian,hoping it would let me in Raspberry Pi Configuration,but it didnt.
    I then tried with:
    # file in /boot/config.txt, need reboot
    and
    dtparam=spi=on
    which i fount at [MEDIA=gist]moux2003/10bba6c8ccd908e35182[/MEDIA] , those 2 lines went pretty much ignored.
    At last I turned on the tv and looked through OSMC setting but havent found anything related to SPI.
    That's when I ran out of ideas.

  • Osmc has a utility within the kodi interface to edit the "config.txt" file and add the needed line.
    I haven't ran a osmc Rpi in a wile, but if I remember correctly edited by hand it reverts back, need to use the utility.
    the utility was within the "Myosmc" tab, if I remember correctly.


    Hope its of help.

  • Osmc has a utility within the kodi interface to edit the "config.txt" file and add the needed line.
    I haven't ran a osmc Rpi in a wile, but if I remember correctly edited by hand it reverts back, need to use the utility.
    the utility was within the "Myosmc" tab, if I remember correctly.


    Hope its of help.


    Wonderful,I have found it! I have enabled SPI support but I get the same error on putty.
    However, there are more options,such as gpio_out_pin (17) and gpio_in_pin (18). My raspberry connects to led strip on pins 19 and 23. Is this something I should alter as well?
    And you were right about config.txt editor. It is there. But what is the needed line? The one that I mentioned in my previous reply?

  • there are more options,such as gpio_out_pin (17) and gpio_in_pin (18)


    Are for infrared in/out. Don't need to bother with it as you are not using a infrared receiver of transmitter.


    But what is the needed line? The one that I mentioned in my previous reply?


    Correct,

    Code
    dtparam=spi=on


    Hope its of help.


    Edit: this is a old thread with good tip to try:
    https://hyperion-project.org/t…-with-osmc-kodi-16-1.370/

  • Osmc has a utility within the kodi interface to edit the "config.txt" file and add the needed line.
    I haven't ran a osmc Rpi in a wile, but if I remember correctly edited by hand it reverts back, need to use the utility.
    the utility was within the "Myosmc" tab, if I remember correctly.


    Hope its of help.


    It definitely is of help. Thank you very much.
    I did manage to write the code to the config.txt. So the lights are working now! Amazing:omg:! But only after I activate hyperion from my pc. Is there a way to have hyperion start automatically with OSMC?
    I did encounter an issue when playing movies with black bar. The tv would be flickering,switching randomly from raspberry's HDMI to "no signal" screen. Activating or deactivating blackbar detection from hyperion setting changes nothing. Selecting "zoom" as a view mode on kodi kind of fixes the issue,but then again limits to only watching zoomed in movies.


    Best regards,

  • Is there a way to have hyperion start automatically with OSMC?


    Yes. It's requires a bit of work however.


    There is a default service file to start Hyperion.NG located here:
    https://github.com/hyperion-pr…/service/hyperion.systemd


    And to make use of that file I can only point you to some reading on how to use that file on a linux system.
    https://discourse.osmc.tv/t/ho…e-a-service-on-osmc/21873


    https://www.devdungeon.com/con…ing-systemd-service-files


    The tv would be flickering,switching randomly from raspberry's HDMI to "no signal" screen.


    Sorry I've not encountered that before. Is the RPI power supply >= 2.5 amp's ? if not maybe low current on the Rpi.


    Hope it of help.

  • If I wnat to start the service, I get the error:


  • The error is clear. "Invalid user/group name or numeric ID:"


    You need to change the "user" and "group" in hyperion.service to your user name.


    Can you log in via ssh?


    If yes then use that log in name for hyperion.service file's "user" and "group" line.


    Hope it's of help.

  • Okay, now I get a different message:


    Code
    Hyperion ambient light systemd service  for user
       Loaded: loaded (/etc/systemd/system/hyperion.service; enabled; vendor preset: en   Active: activating (auto-restart) (Result: exit-code) since Wed 2019-10-23 07:15  Process: 690 ExecStart=/usr/bin/hyperiond (code=exited, status=200/CHDIR)
    Main PID: 690 (code=exited, status=200/CHDIR)
  • I just wanted to update hyperion ng, but I get the error:




    What can I do?

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!