Is my Easycap the problem?

  • Ok I've got a Pi3 running OSMC, and a WS281b strip connected to a Aurdino Pro Mini and a USB-to-TTL. I'm using a bunch of parts from an earlier Hyperion setup for this new one.


    I can change the LEDs with hypercon or the app on my phone.


    I can not get the LEDs to mimic what is on screen, except when I take a screenshot in Hypercon. A screenshot in hypercon results in all blue LEDs.


    I'm thinking that the Pi3 can't grab internally, so I have to use a HDMI spliter and USB video capture. That's ok I want to do that anyway for my other inputs. But I think my Easycap USB video capture is not supported. It's new I did not use video capture on my old Hyperion setup. When I enable GrabberVL42 in hypercon I get the following upon loading config


    ssh in: Jan 26 13:20:21 IansPi1Media hyperiond[10662]: terminate called after throwing an instance of 'std::runtime_error'
    ssh in: Jan 26 13:20:21 IansPi1Media hyperiond[10662]: what(): VIDIOC_S_STD ERROR 25, Inappropriate ioctl for device
    ssh in: Jan 26 13:20:21 IansPi1Media systemd[1]: hyperion.service: main process exited, code=killed, status=6/ABRT
    ssh in: Jan 26 13:20:21 IansPi1Media systemd[1]: Unit hyperion.service entered failed state.


    dmesg shows this when the Easycap USB capture is plugged in.


    [27490.519593] usb 1-1.4: new high-speed USB device number 7 using dwc_otg
    [27490.621306] usb 1-1.4: New USB device found, idVendor=534d, idProduct=0021
    [27490.621327] usb 1-1.4: New USB device strings: Mfr=1, Product=0, SerialNumber=0
    [27490.621341] usb 1-1.4: Manufacturer: MACROSIL
    [27490.623439] uvcvideo: Found UVC 1.00 device <unnamed> (534d:0021)
    [27490.624546] uvcvideo: UVC non compliance - GET_DEF(PROBE) not supported. Enabling workaround.


    And finally lsusb shows the following when the USB capture is connected.
    Bus 001 Device 007: ID 534d:0021



    I've not been able to ID the chipset on the Easycap the chip says ob-mba22n on it.


    I really appreciate any assistance.

  • I thought I read the pi3's hardware wasn't compatible with internal grabbing. Thanks I'll look into it again.


    Yeah right now I want to grab the video from my OSMC, additionally I want to grab a cable box and console.


    I may have an issue with my Arduino. I think it's resetting shortly after starting. I have another full arduino loaned out, I'll try with it shortly. Also I don't think the screengrab I talked about in the first post was working, now that I try again.


    I fell the fact I can control the LEDs from hypercon and mobile app means I'm missing something dumb.

  • I've had success with Hyperion.NG using previously unsupported USB capture hardware (534d:0021) Hyperion.old failed to use my unsupported hardware and crashed during startup when attempting the USB capture.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!