Faulty LED Stripe? Please help.

  • Hi all,

    So yesterday i thought i'd put together my first ambilight setup but i encountered strange issues which leads me to believe that the Led stripes i bought are probably faulty but the issues are really weird so i am hoping someone with more experience can maybe diagnose what is happening here.

    Hardware: Bougth 4x1m of APA102 Led stripes (30 leds/m) on ebay from a German seller. For power supply i bought a Mean Well RS-50-5 (5V 10A 50W).

    I put everything together on my tv and then i hooked it up to the power source and turned the power on.

    First time nothing happened. Then i fiddled a bit with the cables where the Led stripe gets its power and then the first led lit up but nothing else.

    Ok i thought maybe the power cable is not connecting correctly or is maybe broken somewhere so to test it i fidled with it more. Srangly as i fiddled sequentially more leds would lite up and then go out again. Some leds would remain on while one or two previos ones would turn otf leaving gaps in the leds. This occurance kept happening strangly depending if i fiddled with the power cable of the led stripe or even strange if i tilted the led stripe a bit or touched it here and there.
    Also random leds would change color and maybe turn all the way back to white.

    I then thought okay maybe the connection of the power cable of the led is faulty so i cut off the presoldered connectors and applied a no solder cable attachment. That unfortunately did nothing either. What i noticed is that when i applied pressure to the no solder connector sometimes further leds would lite up but then again certain leds in the beginning of the stripe would go out or change color again.

    Strangly after applying pressure the leds would continue to light up further and further along the chain then stopped then i did the same thing on the corner connector joints and again the leds would keep lighting up somewhat further. When i let go of the strip the leds remained on.

    Naturally i thought after this surely it must be that there are contact issues with the joints maybe as well that is causing this so i picked up my multimeter and started to do some readings.

    Unfortunately this also did not give conclusive results. I measured sufficient voltage before a led that was lit and then measured 99.9% the same voltage before a led that was not lit and wouldn't light up. So it seems that its deffinately not an issue of contact as the led stripe shows that it is carrying the same current for places where no leds light up (but sometimes do with the trick of me fiddling with the cables) and where they do light up.

    I also measured the current on the PSU to see if it is providing the correct ammount and sure enough its outputing 5V at the source.

    So in conclusion i have no idea what to make of this led stripe other then its not working as intended and there seems to be a very strange issue with it.

    Does anyone know what could cause this and if i am right with my conclusion that these stripes are indeed faulty?


  • I would highly recommend using a level shifter wile using apa102. it's pretty much a guaranteed way to eliminate cross talk / noise / low signal levels. examples:

    I would also attach a ground wire to to AC power supply from the wall socket. Just for safety sake. And it Might cut down on noise from the power supply.

    Hope it helps.

  • Hi,

    Thanks for the advice but i don't really have any level shifters around and not sure how that would affect the above problem. Additionally from the several guides on how to build your own ambilight setup that i read/watched none of them have used level shifters to make it work. So altough again i appriciate the advice to me it seems that this should not be the root of this problem.

  • Reading the data sheet, te specs say the input voltage needs to be 0.7xVCC.
    At 5.00v this means 3.50v

    The Rpi gpio pins out 3,3v so should need a level shifter.

    It's close - so for some people it works without. I've had both success and failure without.

    Whether it works depends on lots of things - actual psu voltage, quality of wires and connectors, batch variations and so forth

    My preferred level shifter is some 74HCT logic chips.
    The cheap mosfet level shifters are not fast enough for the leds

  • Not sure how the Rpi gpio pins out 3.3v comes into question here as in my tests above described the LED stripe was not yet connected to the RPI gpio. It was only connected to the 5V output PSU. I have also connected a smaller leftover stripe from this APA102 directly to the psu to see if it would lite all the way up normally and it did the same thing as the tv setup namely that first it did not power up at all and after some literally massaging the leds went on.

    This cannot be normal behaviour as i have seen numerous tutorials where once powered up all leds would lite up normally. Here it never does that.

  • Huh ? You have no data and clock lines connected ?
    I wouldn't expect the leds to do anything sane with just power and ground connected.

    The inputs are quite high impedance so will easily pick up RF interference and do some random stuff.
    The act of putting your hand near it will be enough to couple more of this RF interference

  • Well originally they were connected to the GPIO but since nothing happened i wanted to start eliminating any and all potential causes that might make the leds misbehave. So the rational thought (for me at least) was that i should be able to see if the leds are working (light up) just by simply connecting it to the power and ground of the 5v PSU and see if they light all up properly. I mean i still don't understand why this thought may be wrong. Its just like a lightbulb. You ad proper ammount of electricity it should light up. I understand that they are more complex because all are individually controlable and can change color etc but on a bare minimum if you supply the correct voltage to the strip all leds that receive that voltage should light up.

    Of course i may be wrong because i am not an electricity expert.

  • Thanks for the clarification. Well then it makes even less sense for me why some leds do light up at all and completly at random depending on if i touch the led strip in a certain way.

  • Thanks for the clarification. Well then it makes even less sense for me why some leds do light up at all and completly at random depending on if i touch the led strip in a certain way.

    He told you why in post 6 and that's why you need to make sure everything is grounded properly.

  • Ok. But what exactly do i need to do now? Is it enought to buy one such level shifter and ad it to the whole chain as in post 2? Or do i need multiple ones etc? Also i still do not understand why in none of the numerous tutorials on the net (youtube and other places) where they show you to build your own ambilight with APA102 or WS2801 type leds there is never a mention of the need to use level shifters. I am not trying to be a nitpicking asshole here i just don't get why my case is suddenly special with regards to requirements :/

  • I had the clock and data lines connected initially to my RPI Zero via the appropriate GPIO ports. However since nothing happened after i turned on the PSU and issued the appropriate command via HyperCon app i started checking the wiring etc to see what was the issue.

    Then i noticed that only by accident the first led lit up and after some fiddling others started lighting up irregularily. I took voltage measurements and they showed sufficient current. So then i thought i'd eliminate possible issues and disconnected the RPI Zero cables and only focused on checking if having the ground and 5v connected i can get a reaction out of the leds which is what i started to explain in my first post.

    So based on these the leds don't seem to work properly with the Data and Clock lines connected nor without. So i guess the only solution that could maybe help is your level shifter advice. I just don't understand why for most people this very same setup works without such additional hardware needed... :(

    I was not prepared for this and i am not really a soldering expert so having to add now a level shifter which may or may not be the solution kinda bums me out...

  • Anyway i now ordered 2 of the above mentioned level shifter chips and a breadboard to connect the whole thing when it arrives. Really unsure if this is in the end the solution to this problem but i will give it a try.

  • If you don't think your soldering is up to much is that possibly where your problems lie?

    Most people who need a level shifter have done so because it's not behaving properly rather than not working at all which is your issue.

    I actually put a level shifter on my apa102s but they worked fine without, it was more a belt and braces thing as it only cost a few pence and I like making things :)

  • I try to avoid soldering as much as possible. I manage if i really have to but i usually have fugly solder points. Thats why for this setup i used 99% no solder connections.

    Also you also partially prove my point that it should not be necessary to have the level shifter setup as it worked also for you without.... so thats why i am a bit frustrated because ideally i would like to avoid adding tons of components when the same setup i have works for most other people just fine...

  • So a little update. There is deffinately something funky going on with the whole Data In connection. I played again somewhat with the setup. I connected everything to the RPI gpio and try to initialize via Hypercon but i get nothing. However if i touch only the exposed Data in cable with my fingers all of the leds light up in sequence.

    The voltage drops considerably by the end of the chain so i am thinking of adding another 5V line somewhere in the middle of the chain just to keep the current relatively constant. However the RPI still does nothing to control the leds through hypercon.

    Date in is connected to pin 19 on the gpio and clock in is connected to pin 23.

    I have ordered two level shifters as mentioned previously so i will add those to the system once they arrive but in the mean time any idea why the GPIO is not able to control the LEDs behaviour correctly through the RPI Zero and Hypercon?

  • You've got very long data wires which may not help and I assume those joints aren't just twisted together?

    Confused why you have power to the pi from both the power supply and a usb port on the TV. It's unlikely the TV supplies enough power over usb to run the pi reliably and I believe by doing that there's a chance the strip may try to pull power from the pi which will fry it.

    If your pi is setup and working correctly, my money is on the state of your wiring.

  • Yes you are correct the Data and Clock lines are atm only twisted together because as i am just trying out things i did not want to do any more permanent joins.

    Well i originally wanted to power the pi via USB from the TV (works fine btw) but then i saw in one of the tutorials that you can also power it via the GPIO pin. Btw in all the pics the USB power is not on since the TV is not connected to any socket atm.

    Well the PI should be setup correctly but then again i have no idea. I posted a seperate thread now in the Software forum because i also suspect that something may be wrong with the hyperion / hypercon setup as well. The log shows that its trying to change the color of the leds however in reallity nothing happens on the stripes.


    So if it is indeed the cabeling to the led stripe that is causing this what would be a good fix? I mean i can shorten then length of course and again as mentioned the twist together stuff is only temporary for testing and i plan to use normal joins once i see that it is finally working correctly.

  • So just an update. Yesterday i received the level shifter so i integrated it into the system. Also redid some of the wiring and also added another 5V line towards the mid point of the led strip to get better current flow and voltage towards the end of the strip.

    Seems now everythinig is working however i may have some more calibration to do but that isn't a led stripe problem anymore.

    Thanks all for your help!

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!