NEWBIE HERE, please help

  • Well, I am a newbie. Thanks for taking the time to help me.


    I'm on windows 7, running Kodi addon and "hyperion screen capture".
    I have hyperion running on a pi2. I was trying to try this, with a WS2813:
    https://hyperion-project.org/t…-ws2801-ws2812b-apa102.8/
    (pi->arduino->led).


    To try step by step, I first followed this:
    http://www.makeuseof.com/tag/make-ambilight-60/
    (connecting arduino to pc, trying to get Colorswirl.pde to work). Got that.


    I have hyperion installed on my pi and "hyperion screen capture" says "enabled", Kodi addons gives no error so I think they (windows pc and hyperion on pi) are indeed connected.
    BUT when IN HYPERCON, tab ssh, I press connect, I get an error (see attachment):


    I'm not sure what to enter in Target ip (think it should be the ip of the pi or maybe the port to which the arduino is connected).
    I DID get it working once, but I have changed to much I can't remember. I wanted to uninstall and reinstall hyperion but for that I also need a ssh-connection in hypercon.


    So, I'm stuck here, Any help appreciated.


    Wim

  • Yes the target IP is the IP of your RPi. You can find your IP of the Rpi wile logged in to the Pi (via keboard and monitor) with the ifconfig command on a console prompt on the Rpi. Biggles is correct, default SSH port for Raspbian is port 22, that is assuming that you have enabled SSH via raspi-config utility during the OS install of Raspbian. The default username of a Raspbian install is usually "Pi". And the default Raspbian password is "raspberry".


    Hope it's of help.

  • Okay, got that. I tried the ip of the pi before, but didn't know I should use port 22.
    Thanks!


    And in the pi, should I run hypercon again to make hyperion.config.json? What should target ip be than? The same?
    This file is created in /etc and in /etc/hyperion, is that correct?


    MAybe anyone has a good json file for a ws2813 for me?


    Wim

  • Okay, now that ssh is working, I saw that I can push the settings to hyperion on the pi. And I can see the logs. Changed a bit, stopped and started hyperion again and now I get:


    initialised
    ssh in: jul 13 07:50:09 raspberrypi hyperiond[25942]: INFO: Boot sequence 'Rainbow swirl fast' EFFECTENGINE INFO: run effect Rainbow swirl fast on channel 0
    ssh in: jul 13 07:50:09 raspberrypi hyperiond[25942]: BLACKBORDER INFO: threshold set to 0 (0)
    ssh in: jul 13 07:50:09 raspberrypi hyperiond[25942]: BLACKBORDER INFO: mode:default
    ssh in: jul 13 07:50:09 raspberrypi hyperiond[25942]: started
    ssh in: jul 13 07:50:09 raspberrypi hyperiond[25942]: INFO: Kodi checker created and started
    ssh in: jul 13 07:50:09 raspberrypi hyperiond[25942]: INFO: Json server created and started on port 19444
    ssh in: jul 13 07:50:09 raspberrypi hyperiond[25942]: PROTOCONNECTION INFO: Connecting to Hyperion: 192.168.2.1:19447
    ssh in: jul 13 07:50:09 raspberrypi hyperiond[25942]: INFO: Proto server created and started on port 19445
    ssh in: jul 13 07:50:09 raspberrypi hyperiond[25942]: DISPMANXGRABBER INFO: Display opened with resolution: 1600x1200
    ssh in: jul 13 07:50:09 raspberrypi hyperiond[25942]: BLACKBORDER INFO: threshold set to 0 (0)
    ssh in: jul 13 07:50:09 raspberrypi hyperiond[25942]: BLACKBORDER INFO: mode:default
    ssh in: jul 13 07:50:09 raspberrypi hyperiond[25942]: INFO: Frame grabber created and started
    ssh in: jul 13 07:50:09 raspberrypi hyperiond[25942]: BORDER SWITCH REQUIRED!!
    ssh in: jul 13 07:50:09 raspberrypi hyperiond[25942]: CURRENT BORDER TYPE: unknown=0 hor.size=0 vert.size=0
    ssh in: jul 13 07:50:12 raspberrypi hyperiond[25942]: PROTOSERVER INFO: New connection
    ssh in: jul 13 07:50:12 raspberrypi hyperiond[25942]: BLACKBORDER INFO: threshold set to 0 (0)
    ssh in: jul 13 07:50:12 raspberrypi hyperiond[25942]: BLACKBORDER INFO: mode:default
    ssh in: jul 13 07:50:12 raspberrypi hyperiond[25942]: EFFECTENGINE INFO: effect finished


    Done??? In windows hypercon, should I see the captured video? (am I right that I don't have to run hypercon in the pi?, only in windows?)
    The logs don't give more info, while hyperion screen capture is enabled AND kodi addon is functional. I thought I should see info about the connection now.
    (btw arduino not connected at the moment)


    Wim
    EDIT What do I have to do for the border type??

  • Yes, only run Hypercon, in your case on the windows pc. You should really create the .json file yourself, there lots of info that others will be guessing on. basically for your .json the "Type" well be "adalight", the "Output" well LIKELY be "/dev/ttyUSB0" and the "Eternal" tab setting will have the Kodi checker enabled and the IP set to the Kodi PC's IP.


    Have you programed your arduino with the developers preferred arduino sketch from (https://github.com/hyperion-pr…firmware/arduino/adalight )? It has lots of comments in the sketch for proper configuration. And there is always the [WIKI]HyperCon Guide[/WIKI].


    Hope it's helpful.

  • I got really far I think, but I thought I should restart from scratch and now I can't get it back to work:


    ssh in: jul 13 16:36:22 raspberrypi systemd[1]: Started Hyperion Systemd service.
    ssh in: jul 13 16:36:22 raspberrypi hyperiond[1965]: Hyperion Ambilight Deamon (1965)
    ssh in: jul 13 16:36:22 raspberrypi hyperiond[1965]: Version : V1.03.3 (brindosch-2fbbcff/2f01dfa-1495880388
    ssh in: jul 13 16:36:22 raspberrypi hyperiond[1965]: Build Time: Jun 3 2017 02:06:37
    ssh in: jul 13 16:36:22 raspberrypi hyperiond[1965]: ERROR: No valid config found
    ssh in: jul 13 16:36:22 raspberrypi systemd[1]: hyperion.service: main process exited, code=exited, status=1/FAILURE
    ssh in: jul 13 16:36:22 raspberrypi systemd[1]: Unit hyperion.service entered failed state.


    I think Hypercon can't save the json file to the pi so I did manually. Perhaps the wrong file location?


    I installed hyperion on my pi from directory
    /home/wim/Downloads by executing sudo sh ./install_hyperion.sh
    and I copied json file from windows to /etc


    If I were to start from scratch, what do I do? Remove hyperion from hypercon is enough? But I'll probably get the same problem....


    Any ideas?


    Wim

  • I couldn't get it working so I started from scratch. Deinstalled hyperion screen capture, put a backup image back on my pi.
    Installed hyperion from hypercon, see logs:


    SSH Traffic:
    ssh connected
    ssh out: cd /tmp && wget -nv -N https://raw.github.com/hyperio…r/bin/install_hyperion.sh && chmod +x install_hyperion.sh && sudo sh ./install_hyperion.sh HyperConInstall ; rm install_hyperion.sh
    ssh out: 'Last-modified'-kopregel ontbreekt -- tijdsstempels worden uitgeschakeld.
    ssh out: 2017-07-14 10:31:19 URL:https://raw.githubusercontent.…r/bin/install_hyperion.sh [14539/14539] -> "install_hyperion.sh" [1]
    ssh in: *******************************************************************************
    ssh in: This script will install/update Hyperion Ambient Light
    ssh in: Created by brindosch - hyperion-project.org - the official Hyperion source.
    ssh in: *******************************************************************************
    ssh in: ---> Stop Hyperion, if necessary
    ssh in: ---> Install/Update Hyperion dependencies (This may take a while)
    ssh in: ---> Downloading the appropriate Hyperion release
    ssh out: 2017-07-14 10:32:11 URL:https://netcologne.dl.sourcefo…ease/hyperion_rpi2.tar.gz [1639953/1639953] -> "-" [1]
    ssh in: ---> Installing systemd script
    ssh in: ---> Starting Hyperion
    ssh in: *******************************************************************************
    ssh in: Hyperion Installation/Update finished!
    ssh in: Please download the latest HyperCon version to benefit from new features!
    ssh in: To create a config, follow the HyperCon Guide at our Wiki (EN/DE)!
    ssh in: Wiki: wiki.hyperion-project.org Webpage: www.hyperion-project.org
    ssh in: *******************************************************************************


    and send config file (hyperion.config.json) in hypercon via ssh to pi:
    sftp Send Hyperion Config - Sourcepath: , Targetpath: /etc/hyperion/, Filename: hyperion.config.json


    BUT: I checked and there was NO file in that folder!
    I manually copied the file in.


    There was nothing added in config.txt, so I added manually:
    dtparam=spi=on


    Maybe there's a permissions problem?

    On my windows pc running Kodi, this is my config for Hyperion ambilight addon


    (192.168.2.9 is Raspberry pi)


    I get an error about addon Hyperion ambilight, Kodi logs::


    0:44:48.830 T:6736 WARNING: CAddonMgr: 'script.module.protobuf' required by 'script.service.hyperion' is missing. Add-on may not function correctly
    10:44:49.064 T:6360 ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
    - NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
    Error Type: <type 'exceptions.ImportError'>
    Error Contents: No module named google.protobuf
    Traceback (most recent call last):
    File "D:\Prive\Kodi\Kodi 17\addons\hyperion.kodi-master\addon.py", line 36, in <module>
    from state import DisconnectedState
    File "D:\Prive\Kodi\Kodi 17\addons\hyperion.kodi-master\resources\lib\state.py", line 5, in <module>
    from hyperion.Hyperion import Hyperion
    File "D:\Prive\Kodi\Kodi 17\addons\hyperion.kodi-master\resources\lib\hyperion\Hyperion.py", line 28, in <module>
    from message_pb2 import HyperionRequest
    File "D:\Prive\Kodi\Kodi 17\addons\hyperion.kodi-master\resources\lib\hyperion\message_pb2.py", line 6, in <module>
    from google.protobuf import descriptor as _descriptor
    ImportError: No module named google.protobuf
    -->End of Python script error report<--


    Found this:
    https://hyperion-project.org/t…-enabling-the-add-on.819/


    I probably should do this on windows, but tried anyway on my pi:
    sudo apt-get install python-protobuf


    Stopped an restarted addon. Same problem.


    Kodi addon still error. Logs:
    10:58:58.210 T:728 WARNING: JSONRPC: Could not parse type "Setting.Details.SettingList"
    10:58:58.322 T:728 NOTICE: initialize done
    10:58:58.322 T:728 NOTICE: Running the application...
    10:58:58.325 T:728 NOTICE: CWebServer[8080]: Started
    10:58:58.325 T:728 NOTICE: starting upnp client
    10:58:58.366 T:6296 NOTICE: ES: Starting UDP Event server on port 9777
    10:58:58.366 T:6296 NOTICE: UDP: Listening on port 9777 (ipv6 : false)
    10:58:58.478 T:8304 ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
    - NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
    Error Type: <type 'exceptions.ImportError'>
    Error Contents: No module named google.protobuf
    Traceback (most recent call last):
    File "D:\Prive\Kodi\Kodi 17\addons\hyperion.kodi-master\addon.py", line 36, in <module>
    from state import DisconnectedState
    File "D:\Prive\Kodi\Kodi 17\addons\hyperion.kodi-master\resources\lib\state.py", line 5, in <module>
    from hyperion.Hyperion import Hyperion
    File "D:\Prive\Kodi\Kodi 17\addons\hyperion.kodi-master\resources\lib\hyperion\Hyperion.py", line 28, in <module>
    from message_pb2 import HyperionRequest
    File "D:\Prive\Kodi\Kodi 17\addons\hyperion.kodi-master\resources\lib\hyperion\message_pb2.py", line 6, in <module>
    from google.protobuf import descriptor as _descriptor
    ImportError: No module named google.protobuf
    -->End of Python script error report<--
    10:58:59.825 T:8732 NOTICE: EPG::CEpgContainer::Start - EPG thread started
    10:59:05.433 T:8732 ERROR: XFILE::CDirectory::GetDirectory - Error getting


    Have to try to get this protobuf on windows.....NO CLUE here. HELP.......

    Will try further with hyperionscreencap instead of Kodi addon. Installed the program.
    Changed setup:

    Get this error:



    Checked if hyperion is running:

    It isn't.


    Started hyperion service manually:
    sudo service hyperion start

    Seems okay, but "BORDER SWITCH REQUIRED!!". No idea what to do about it.


    AND look at the port settings. Do they match my hypercon settings (protoconnection 19447, proto server 19445)?



    I'm lost now. Help appreciated very much.


    Wim





    ps I'm running Jessie on my Pi, maybe somethings changed?


  • Read the first 2 replies again.


    First post:
    What's up with the port number? It's usually a whole number like 22


    Second post:
    Yes the target IP is the IP of your RPi. You can find your IP of the Rpi wile logged in to the Pi (via keboard and monitor) with the ifconfig command on a console prompt on the Rpi. Biggles is correct, default SSH port for Raspbian is port 22, that is assuming that you have enabled SSH via raspi-config utility during the OS install of Raspbian. The default username of a Raspbian install is usually "Pi". And the default Raspbian password is "raspberry".



    I've got is setup like this:


    Or do I misunderstand you here?
    It's port 22 and username for pi is wim, password ********


    Last part of the log:
    ssh in: jul 14 11:27:54 raspberrypi systemd[1]: Starting Hyperion Systemd service...
    ssh in: jul 14 11:27:54 raspberrypi systemd[1]: Started Hyperion Systemd service.
    ssh in: jul 14 11:27:54 raspberrypi hyperiond[14292]: Hyperion Ambilight Deamon (14292)
    ssh in: jul 14 11:27:54 raspberrypi hyperiond[14292]: Version : V1.03.3 (brindosch-2fbbcff/2f01dfa-1495880388
    ssh in: jul 14 11:27:54 raspberrypi hyperiond[14292]: Build Time: Jun 3 2017 02:06:37
    ssh in: jul 14 11:27:54 raspberrypi hyperiond[14292]: INFO: Selected configuration file: /etc/hyperion/hyperion.config.json
    ssh in: jul 14 11:27:54 raspberrypi hyperiond[14292]: HYPERION INFO: ColorTransform 'default' => [0; 45]
    ssh in: jul 14 11:27:54 raspberrypi hyperiond[14292]: HYPERION INFO: ColorCorrection 'default' => [0; 45]
    ssh in: jul 14 11:27:54 raspberrypi hyperiond[14292]: HYPERION INFO: ColorAdjustment 'default' => [0; 45]
    ssh in: jul 14 11:27:54 raspberrypi hyperiond[14292]: LEDDEVICE INFO: configuration:
    ssh in: jul 14 11:27:54 raspberrypi hyperiond[14292]: {
    ssh in: jul 14 11:27:54 raspberrypi hyperiond[14292]: "colorOrder" : "rgb",
    ssh in: jul 14 11:27:54 raspberrypi hyperiond[14292]: "delayAfterConnect" : 0,
    ssh in: jul 14 11:27:54 raspberrypi hyperiond[14292]: "name" : "MyHyperionConfig",
    ssh in: jul 14 11:27:54 raspberrypi hyperiond[14292]: "output" : "/dev/ttyUSB0",
    ssh in: jul 14 11:27:54 raspberrypi hyperiond[14292]: "rate" : 100000,
    ssh in: jul 14 11:27:54 raspberrypi hyperiond[14292]: "type" : "adalight"
    ssh in: jul 14 11:27:54 raspberrypi hyperiond[14292]: }
    ssh in: jul 14 11:27:54 raspberrypi hyperiond[14292]: Opening UART: /dev/ttyUSB0
    ssh in: jul 14 11:27:54 raspberrypi hyperiond[14292]: HYPERION INFO: Json forward to 192.168.2.1:19446
    ssh in: jul 14 11:27:54 raspberrypi hyperiond[14292]: HYPERION INFO: Proto forward to 192.168.2.1:19447
    ssh in: jul 14 11:27:54 raspberrypi hyperiond[14292]: INFO: Creating linear smoothing
    ssh in: jul 14 11:27:54 raspberrypi hyperiond[14292]: HYPERION (CS) INFO: Created linear-smoothing(interval_ms=50;settlingTime_ms=200;updateDelay=0
    ssh in: jul 14 11:27:54 raspberrypi hyperiond[14292]: EFFECTENGINE INFO: 27 effects loaded from directory /usr/share/hyperion/effects
    ssh in: jul 14 11:27:54 raspberrypi hyperiond[14292]: EFFECTENGINE INFO: Initializing Python interpreter
    ssh in: jul 14 11:27:54 raspberrypi hyperiond[14292]: INFO: Hyperion started and initialised
    ssh in: jul 14 11:27:54 raspberrypi hyperiond[14292]: INFO: Boot sequence 'Rainbow swirl fast' EFFECTENGINE INFO: run effect Rainbow swirl fast on channel 0
    ssh in: jul 14 11:27:54 raspberrypi hyperiond[14292]: BLACKBORDER INFO: threshold set to 0 (0)
    ssh in: jul 14 11:27:54 raspberrypi hyperiond[14292]: BLACKBORDER INFO: mode:default
    ssh in: jul 14 11:27:54 raspberrypi hyperiond[14292]: started
    ssh in: jul 14 11:27:54 raspberrypi hyperiond[14292]: INFO: Kodi checker created and started
    ssh in: jul 14 11:27:54 raspberrypi hyperiond[14292]: INFO: Json server created and started on port 19444
    ssh in: jul 14 11:27:54 raspberrypi hyperiond[14292]: PROTOCONNECTION INFO: Connecting to Hyperion: 192.168.2.1:19447
    ssh in: jul 14 11:27:54 raspberrypi hyperiond[14292]: INFO: Proto server created and started on port 19445
    ssh in: jul 14 11:27:54 raspberrypi hyperiond[14292]: DISPMANXGRABBER INFO: Display opened with resolution: 1600x1200
    ssh in: jul 14 11:27:54 raspberrypi hyperiond[14292]: BLACKBORDER INFO: threshold set to 0 (0)
    ssh in: jul 14 11:27:54 raspberrypi hyperiond[14292]: BLACKBORDER INFO: mode:default
    ssh in: jul 14 11:27:54 raspberrypi hyperiond[14292]: INFO: Frame grabber created and started


    So maybe that's working correct now?


    But I still have this


    in windows with hyperion screen capture.


    And kodi-addons is also still giving me issue:
    13:53:44.226 T:4820 WARNING: JSONRPC: Could not parse type "Setting.Details.SettingList"
    13:53:44.418 T:4820 NOTICE: initialize done
    13:53:44.418 T:4820 NOTICE: Running the application...
    13:53:44.433 T:4820 NOTICE: CWebServer[8080]: Started
    13:53:44.433 T:4820 NOTICE: starting upnp client
    13:53:44.455 T:8484 NOTICE: ES: Starting UDP Event server on port 9777
    13:53:44.456 T:8484 NOTICE: UDP: Listening on port 9777 (ipv6 : false)
    13:53:45.321 T:8152 ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
    - NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
    Error Type: <type 'exceptions.ImportError'>
    Error Contents: No module named google.protobuf
    Traceback (most recent call last):
    File "D:\Prive\Kodi\Kodi 17\addons\hyperion.kodi-master\addon.py", line 36, in <module>
    from state import DisconnectedState
    File "D:\Prive\Kodi\Kodi 17\addons\hyperion.kodi-master\resources\lib\state.py", line 5, in <module>
    from hyperion.Hyperion import Hyperion
    File "D:\Prive\Kodi\Kodi 17\addons\hyperion.kodi-master\resources\lib\hyperion\Hyperion.py", line 28, in <module>
    from message_pb2 import HyperionRequest
    File "D:\Prive\Kodi\Kodi 17\addons\hyperion.kodi-master\resources\lib\hyperion\message_pb2.py", line 6, in <module>
    from google.protobuf import descriptor as _descriptor
    ImportError: No module named google.protobuf
    -->End of Python script error report<--


    I'm lost here. Really. I'm sorry.


    Wim

  • Your port numbers don't appear to be whole numbers ie 19.444 and 19.445, they should be 19,444 and 19,445, as in nineteen thousand, four hundred... rather than nineteen point four...


    In the Netherlands, it's exactly the other way round. So "19.445" is ninety thousand, four hundred and forty four.

  • STARTING ALL OVER AGAIN


    Just to be clear. I'm running Raspbian Jessie.



    Just found out that ttyUSB0 is being used.
    But I don't know how to find the port the arduino uses.


    I can't do this, probably because I'm not running openelec,

    So I get:


    Before plugging in arduino:


    After plugging in arduino:


    So arduino is device 006. But which port?



    Only finds USB0.


    I found this:
    "/dev/ttyACM0 is a USB communication device (CDC) of sub-type "abstract control model" (ACM). That is what the Arduino is."


    Tried that before indeed!
    ls /dev/ttyACM* gives me ttyACM0. So I'm going to try that.


    Starting windows hypercon:



    Installing like this:
    ssh out: cd /tmp && wget -nv -N https://raw.github.com/hyperio…r/bin/install_hyperion.sh && chmod +x install_hyperion.sh && sudo sh ./install_hyperion.sh HyperConInstall ; rm install_hyperion.sh
    ssh out: 'Last-modified'-kopregel ontbreekt -- tijdsstempels worden uitgeschakeld.
    ssh out: 2017-07-15 14:10:47 URL:https://raw.githubusercontent.…r/bin/install_hyperion.sh [14539/14539] -> "install_hyperion.sh" [1]
    ssh out: sudo: geen terminal aanwezig en geen wachtwoordvraag(askpass)-programma opgegeven


    Think this has to do with visudo, saw that in hyperion webapp guide. Did the steps there, also:
    *Required if you are running Raspbian / Debian:*


    Update the visudo list:
    ```
    pkexec visudo
    ```


    In the section "# Cmnd alias specification" add:
    ```
    Cmnd_Alias WEBDAEMONS = /etc/init.d/hyperion
    ```


    In the section "#includedir /etc/sudoers.d" add:
    ```
    www-data ALL = (root) NOPASSWD: WEBDAEMONS
    ```
    BUT I DON'T HAVE THIS FILE: /home/pi/www/conf/Configuration.php. So don't know what to do with these line:
    Open the configuration file:
    ```
    sudo nano /home/pi/www/conf/Configuration.php
    ```
    Don't know
    Update the configuration for "serverController"
    ```
    'serverController' => 'sudo /etc/init.d',
    ```


    I read: "Please consider adding local content in /etc/sudoers.d/ instead of directly modifying this file.".
    Did that. Seems I made some changes regarding user pi here in the past. I have to check my notes about this.


    This makes a lot of difference!!!!
    Hyperion screen capture: no errors.
    Webinterface: no errors.


    However, when I start webinterface hyperion screen capture gives errors.


    Android apps: no errors.


    Logs seems responsive, to for example start and stops.


    Now, the led's don't seem to response like they should.
    So, next chapter here.


    BUT, when I detach the ledstrip, I get:
    ssh in: jul 15 14:58:37 raspberrypi hyperiond[26819]: Opening UART: /dev/ttyACM0
    ssh in: jul 15 14:58:37 raspberrypi hyperiond[26819]: Unable to open RS232 device (IO Exception (2): No such file or directory, file /home/sascha/hyperion/dependencies/build/serial/src/impl/unix.cc, line 100.)
    ssh in: jul 15 14:58:37 raspberrypi hyperiond[26819]: Device blocked for 3000 ms
    ssh in: jul 15 14:58:37 raspberrypi hyperiond[26819]: JSONSERVER INFO: New connection
    ssh in: jul 15 14:58:37 raspberrypi hyperiond[26819]: BLACKBORDER INFO: threshold set to 0.01 (3)


    While I don't have /home/sascha . Maybe some program leftover/incorrect?



    First, back to arduino.

  • Edited and uploaded this sketch to the arduino.


    Have you programed your arduino with the developers preferred arduino sketch from (https://github.com/hyperion-pr…firmware/arduino/adalight )?


    About increasing buffer size (from: https://hyperion-project.org/t…-ws2801-ws2812b-apa102.8/)
    instructed here:
    http://www.hobbytronics.co.uk/arduino-serial-buffer-size
    I don't know how, because it's different with me:
    hardwareserial.cpp and usbapi.h don't have
    "#define SERIAL_BUFFER_SIZE 64", so I can't change it. I attached these 2 files (renamed to txt, otherwise I couldn't upload).


    Than I had to "do a few steps to make sure the baud rate is high enough to accommodate the data being send from the Raspberry Pi to your Arduino".

    Seems to be in /boot/cmdline.txt
    rather than /flash/config.txt

    standard is 115200
    It seems tricky for me to do, reading some websites. Hoping it's not necessary at all.

  • Changed json like this
    "name" : "MyPi",
    "type" : "adalight",
    "output" : "/dev/ttyACM0",
    "rate" : 460800,
    "colorOrder" : "grb"


    and I should be ready to go.
    Fingers crossed.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!