Posts by Jens Masla

    Hier noch die letzte ausgabe
    login as: root
    root@192.168.178.27's password:
    ##############################################
    # LibreELEC #
    # https://libreelec.tv #
    ##############################################


    LibreELEC (official): 9.2.4 (RPi2.arm)
    LibreELEC:~ # /root/.hyperion/hyperion-v4l2-ctl.conf#!/bin/bash -e
    -sh: /root/.hyperion/hyperion-v4l2-ctl.conf#!/bin/bash: not found
    LibreELEC:~ #
    LibreELEC:~ # v4l2-ctl -v pixelformat=YUYV
    LibreELEC:~ # ### Macrosilicon Default Values
    LibreELEC:~ # v4l2-ctl -c saturation=180
    LibreELEC:~ # v4l2-ctl -c brightness=-11
    LibreELEC:~ # v4l2-ctl -c contrast=148
    LibreELEC:~ # v4l2-ctl -c hue=0
    LibreELEC:~ # v4l2-ctl -d /dev/video0 --set-fmt-video=width=720,height=480 -p 30
    Frame rate set to 30.000 fps
    LibreELEC:~ # #v4l2-ctl -d /dev/video0 --set-fmt-video=width=640,height=480 -p 30
    LibreELEC:~ # hyperion-v4l2 service ExecStartPre=/root/.hyperion/hyperion-v4l2-ctl.conf
    hyperion-v4l2:
    version : fb413cd7e8825ffc26925013f57ac93a774f12bc
    build time: Feb 3 2020 17:29:53
    V4L2GRABBER INFO: width=720 height=480
    V4L2GRABBER INFO: pixel format=YUYV
    V4L2GRABBER INFO: signal threshold set to: {0,0,0}
    PROTOCONNECTION INFO: Connecting to Hyperion: 127.0.0.1:19445
    V4L2GRABBER INFO: started
    PROTOCONNECTION INFO: Connected to Hyperion: 127.0.0.1:19445

    login as: root
    root@192.168.178.27's password:
    ##############################################
    # LibreELEC #
    # https://libreelec.tv #
    ##############################################


    LibreELEC (official): 9.2.4 (RPi2.arm)
    LibreELEC:~ # hyperion-v4l2 service
    hyperion-v4l2:
    version : fb413cd7e8825ffc26925013f57ac93a774f12bc
    build time: Feb 3 2020 17:29:53
    V4L2GRABBER INFO: width=1920 height=1080
    V4L2GRABBER ERROR: Only pixel formats UYVY, YUYV, and RGB32 are supported ERROR
    LibreELEC:~ # ExecStartPre=/root/.hyperion/hyperion-v4l2-ctl.conf
    LibreELEC:~ #


    login as: root
    root@192.168.178.27's password:
    ##############################################
    # LibreELEC #
    # https://libreelec.tv #
    ##############################################


    LibreELEC (official): 9.2.4 (RPi2.arm)
    LibreELEC:~ # hyperion-v4l2 --help
    hyperion-v4l2:
    version : fb413cd7e8825ffc26925013f57ac93a774f12bc
    build time: Feb 3 2020 17:29:53
    V4L capture application for Hyperion
    Build time: Feb 3 2020 17:29:18


    Usage: hyperion-v4l2 [OPTIONS]


    Parameters:
    -d, --device <arg> The device to use [default: /dev/video0]
    -v, --video-standard <arg> The used video standard. Valid values are PAL
    or NTSC (optional)
    --pixel-format <arg> The use pixel format. Valid values are YUYV,
    UYVY, and RGB32 (optional)
    --input <arg> Input channel (optional)
    --width <arg> Try to set the width of the video input
    (optional)
    --height <arg> Try to set the height of the video input
    (optional)
    --crop-width <arg> Number of pixels to crop from the left and
    right sides of the picture before decimation
    [default: 0]
    --crop-height <arg> Number of pixels to crop from the top and the
    bottom of the picture before decimation
    [default: 0]
    --crop-left <arg> Number of pixels to crop from the left of the
    picture before decimation (overrides
    --crop-width)
    --crop-right <arg> Number of pixels to crop from the right of the
    picture before decimation (overrides
    --crop-width)
    --crop-top <arg> Number of pixels to crop from the top of the
    picture before decimation (overrides
    --crop-height)
    --crop-bottom <arg> Number of pixels to crop from the bottom of the
    picture before decimation (overrides
    --crop-height)
    -s, --size-decimator <arg> Decimation factor for the output size
    [default=1]
    -f, --frame-decimator <arg> Decimation factor for the video frames
    [default=1]
    --screenshot Take a single screenshot, save it to file and
    quit
    -t, --signal-threshold <arg> The signal threshold for detecting the presence
    of a signal. Value should be between 0.0 and
    1.0.
    --red-threshold <arg> The red signal threshold. Value should be
    between 0.0 and 1.0. (overrides
    --signal-threshold)
    --green-threshold <arg> The green signal threshold. Value should be
    between 0.0 and 1.0. (overrides
    --signal-threshold)
    --blue-threshold <arg> The blue signal threshold. Value should be
    between 0.0 and 1.0. (overrides
    --signal-threshold)
    --3DSBS Interpret the incoming video stream as 3D
    side-by-side
    --3DTAB Interpret the incoming video stream as 3D
    top-and-bottom
    -a, --address <arg> Set the address of the hyperion server
    [default: 127.0.0.1:19445]
    -p, --priority <arg> Use the provided priority channel (the lower
    the number, the higher the priority) [default:
    800]
    --skip-reply Do not receive and check reply messages from
    Hyperion
    -h, --help Show this help message and exit
    LibreELEC:~ #

    Hier noch meine alte config.
    "grabber-v4l2" :
    {
    "device" : "/dev/video0",
    "input" : 0,
    "standard" : "no-change",
    "width" : -1,
    "height" : -1,
    "frameDecimation" : 2,
    "sizeDecimation" : 3,
    "priority" : 900,
    "mode" : "2D",
    "cropLeft" : 0,
    "cropRight" : 0,
    "cropTop" : 0,
    "cropBottom" : 0,
    "redSignalThreshold" : 0.0,
    "greenSignalThreshold" : 0.0,
    "blueSignalThreshold" : 0.0

    :biggrin::D:D:D:DDankeschön, muss erstmal morgen mal eine komplette neue Hypercon config erstellen mal sehen ob er dann erkannt wird wenn ich ihn so bearbeite wie du es mir beschreiben hast . So einfach in der config reinschreiben geht wohl nicht oder?

    Recht herzlichen Dank für deine schnelle Antwort. Ich probiere es mal, wenn ich das dann noch nicht schaffe kann ich dann wieder auf deine Hilfe hoffen . Und das muss ich dann auch mit putty machen ? Sorry die Frage . Und dann wie abspeichern kenne mich damit noch nicht so richtig aus

    Hallo zusammen, ich Hyperion Classic auf dem Raspi 3 am laufen und das sehr gut . Nun habe ich mir auch einen HDMI Grabber gekauft und zwar den auch pclin hat . Habe auch das gemacht wie pclin es beschrieben hat aber es kommt dann immer eine Fehlermeldung sowas wie mit Devise :(.Auf Hyperion NG läuft er, aber das mit den Farben gefällt mir nicht.
    Ich habe das YUYV mit butty versucht aber nach den Neustart bekomme ich die gleiche Fehlermeldung. Was ich komisch finde das in der Config dann nicht APA 102 steht sondern WS mit noch was . Sorry meine LED sind die Apa 102 mit 276 LEDs. Würde mich sehr freuen wenn jemand mir da helfen könnte. Euch allen ein schönen 2 Advent.