1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

penfold42's Recent Activity

  1. penfold42 replied to the thread RPi + OpenELEC Wire/cable thickness.

    Personally I don't like powering a Pi from the led strip. Yes it works - I've done it for testing but if you screw up the connection...

    29 March 2017 at 23:01
  2. penfold42 replied to the thread RPi + OpenELEC Wire/cable thickness.

    https://github.com/hyperion-project/hyperion.ng/issues/426

    29 March 2017 at 12:50
  3. penfold42 replied to the thread RPi + OpenELEC Wire/cable thickness.

    On a related note - has anyone measured the resistance of the led strips ?

    29 March 2017 at 12:46
  4. penfold42 replied to the thread RPi + OpenELEC Wire/cable thickness.

    Yep definitely a good FAQ Even better would be a link to it from the Hyperion.ng web interface that prepopulates some fields. 5v, dc,...

    29 March 2017 at 12:45
  5. penfold42 replied to the thread RPi + OpenELEC Wire/cable thickness.

    Nice calculator - good to see my maths aren't wrong too !

    29 March 2017 at 11:24
  6. penfold42 replied to the thread RPi + OpenELEC Wire/cable thickness.

    It depends on the length, current and the allowed voltage drop. 2m length 16 amps 0.5v voltage drop (at a guess) should be ok R = V /...

    28 March 2017 at 23:50
  7. penfold42 replied to the thread SOLVED Maximum number of pixels supported.

    Looks like the default SPI transfer size is 4096: https://www.raspberrypi.org/forums/viewtopic.php?f=44&t=124472

    27 March 2017 at 11:17
  8. penfold42 replied to the thread SOLVED Maximum number of pixels supported.

    FOUND IT ! Well, I think i have... I forgot that the apa102s need 4 bytes per led. 1008 leds needs: 4 start bytes 4032 bytes of led...

    27 March 2017 at 09:38
  9. penfold42 replied to the thread SOLVED Maximum number of pixels supported.

    What baud rate are you using? Try doubling or halving it to see if there is any change Also try running the binary from the command...

    27 March 2017 at 09:28
  10. penfold42 replied to the thread SOLVED Advise please, getting this error ('/dev/video0' does not support streaming i/o ERROR).

    You need to use the v4l utils to tell it which input to capture from. It won't return data if it doesn't see a valid input signal

    27 March 2017 at 03:02
  11. penfold42 replied to the thread SOLVED Advise please, getting this error ('/dev/video0' does not support streaming i/o ERROR).

    I don't think these will work - they only seem capable of giving you an mpeg4 stream rather than a simple screenshot. The fixes you...

    26 March 2017 at 23:23
  12. penfold42 replied to the thread Beta Sk6812 rgbw support.

    I haven't looked at this again as I only have a few of these leds. happy to help someone integrate some smarter algorithms from elsewhere

    26 March 2017 at 23:15
  13. penfold42 replied to the thread Other Powersupply APA102 ledstrip.

    That's the sketch we provide and recommend at...

    26 March 2017 at 14:17
  14. penfold42 replied to the thread Other Powersupply APA102 ledstrip.

    You're likely to get buffer over runs with an atmega328. Which sketch are you using ? You need 1428 bytes to store 1 complete frame of...

    26 March 2017 at 12:32
  15. penfold42 replied to the thread SOLVED Maximum number of pixels supported.

    This might be relevant https://cpldcpu.com/2016/12/13/sk9822-a-clone-of-the-apa102/ We send 0xff for the end frame right now

    25 March 2017 at 04:21