1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SOLVED ambient blijft op een wit en groen licht

Discussion in 'Dutch Talk' started by the1one, 12 January 2021.

  1. the1one

    the1one Member

    Messages:
    47
    hoi allemaal,

    ik ben al heel wat dagen bezig om mijn ambientlight klaar te krijgen maar het lukt me niet.
    het heeft gewerkt maar toe deed het niets als flikkeren nu heb ik een nieuwe pi nieuwe kaart "fresh install"
    en nu werkt het helemaal niet meer ik krijg een wit en een groen licht.
    hyperion geeft heel de tijd aan LED device offline.
    kan iemand mij aub helpen? bedankt!
     
  2. jeroen warmerdam

    jeroen warmerdam Raspberry 3B / APA102 / Hyperion.NG relaisbox

    Messages:
    578
    Hardware:
    RPi3
    heb je specs van je hardware en software? zo wordt het heel moeilijk :)

    wat is je type van setup etc etc.
    helpen kunnen we altijd natuurlijk.

    eerst eens kijken wat je precies hebt en wat het allemaal wel of juist niet doet, want zo heb ik geen idee
     
  3. the1one

    the1one Member

    Messages:
    47
    bedankt voor de reply!!
    ok ik ben hier een serieuze noob in maar ga alles proberen door te geven.
    raspberry pi 4
    led's wsb2812B 30
    de standaard lite versie van raspberry
    hyperion 2.0 alpha 9

    hopelijk zo voldoende?
     
  4. the1one

    the1one Member

    Messages:
    47
    deze heb ik ook nog.
    Mini Usb Video Capture Card Hdmi Naar Usb 2.0 4K 1080P Video-opname
     
  5. jeroen warmerdam

    jeroen warmerdam Raspberry 3B / APA102 / Hyperion.NG relaisbox

    Messages:
    578
    Hardware:
    RPi3

    je hebt de Debian buster lite? en de laatste Hyperion.

    wat werkte er wel vanaf het begin wat ineens nu niet meer werkt dan
    wat was je eerste installatie setup en nu je tweede?
     
    Last edited: 13 January 2021
  6. jeroen warmerdam

    jeroen warmerdam Raspberry 3B / APA102 / Hyperion.NG relaisbox

    Messages:
    578
    Hardware:
    RPi3
    heb je hier een link van?
     
  7. the1one

    the1one Member

    Messages:
    47
  8. jeroen warmerdam

    jeroen warmerdam Raspberry 3B / APA102 / Hyperion.NG relaisbox

    Messages:
    578
    Hardware:
    RPi3
    ik ga je straks proberen te helpen. en een heleboel vragen stellen
     
  9. the1one

    the1one Member

    Messages:
    47
    ik heb eigenlijk altijd hetzelfde gedaan maar omdat ik het flikkeren had heb ik een nieuwe kaart nieuwe pi en volledig opnieuw begonnen.
    het rare is dat als ik nu alles installeer en zonder aansluiten van leds er in hyperion op het dashbord het bolletje bij led device grijs blijft .
    ik denk dus dat het daar al begint. tis precies of mijn leds staan in standby of zoiets.
     
  10. the1one

    the1one Member

    Messages:
    47
    Top! bedankt al he!!
     
  11. jeroen warmerdam

    jeroen warmerdam Raspberry 3B / APA102 / Hyperion.NG relaisbox

    Messages:
    578
    Hardware:
    RPi3

    Hoe heb jij de Hyperion.NG 2.09 alpha geinstalleerd op Debian lite/

    • via een .deb file > gedownload en geinstalleerd of Hyperion download code gebruikt met .git en alles min of meer auto laten installeren/
    • waar heb je de ledstrip op aangesloten ( GPIO18) als het goed is?
    • Wat voor voeding gebruik je voor de ledstrip/PI en heb je de voltage gemeten mag niet meer zijn dan 5 volt ..
    • post hier je config.txt file met settings
    • ga naar Debug als Hyperion draait en post hier het debuglog >> kan je vinden links onderin de webGUI

    het flikkeren zal waarschijnlijk een powerprobleem zijn, het kan ook zijn dat op je oude installatie de GPIO pin niet in rust komt en je daarvoor een weerstand nodig hebt, meestal 150 ohm of zoiets.
    Het flikkeren kan ook komen door je grabber.

    heb je al getest met de dispmanx en USB grabber uitgeschakeld?
    ik zou gewoon basic beginnen en eerst gaan we kijken of de connecties goed zijn.
    daarna pakken we de software aan, maar omdat je software al draait en je in de webUI kan komen van Hyperion zal daar waarschijnlijk niets mee zijn.

    soms moet je bepaalde rechten aan zetten voor de GPIO pins maar volgensmij is dat alleen op Hyperbian en niet op een OS wat je los hebt geinstalleerd, maar daar kan ik natuurlijk naast zitten.

    kortom kom maar op met die gegevens :)
     
  12. the1one

    the1one Member

    Messages:
    47
    ik heb dit filmpje gevolgd.

     
  13. the1one

    the1one Member

    Messages:
    47
    ik heb het eerst aangesloten zonder achter de tv te hangen met korte kabel. toen uiteindelijk werkte het prima. (zat enkel wat vertraging op)
    dan heb ik de leds achter de tv gehangen in eerste instantie werkte de leds maar kwam er geen beeld binnen op hyperion enkel ruis.
    nadien (na een paar reboots) werkte het plots wel maar gaf het flikkering.
    dus ik dacht begin opnieuw met nieuwe pi en sd kaart en dan gaat het wel lukken.
    in eerste instantie bleven de led's branden had wel de fout gemaakt van ze direct aan te sluiten samen met de pi zonder installatie.
    na ik de installatie wel helemaal juist gedaan heb zonder aansluiten van de led's bleven enkel de eerste en 2de led branden eerste wit 2de groen.
     
  14. the1one

    the1one Member

    Messages:
    47
    euhm wat bedoel je ..... weet je nog noob :):);)
     
  15. the1one

    the1one Member

    Messages:
    47
    ik gebruik inderdaad gpio 18
    wat ik vooral raar vind nu is dat het bolletje bij led device grijs blijft of is dit normaal?
     
  16. the1one

    the1one Member

    Messages:
    47
    zodra ik mijn zoon afgezet heb op de voetbal installeer ik alles terug en bezorg ik je de debuglog en txt file.
     
  17. the1one

    the1one Member

    Messages:
    47
    hier kan je zien wat ik bedoel moet led device
     

    Attached Files:

  18. the1one

    the1one Member

    Messages:
    47
    2021-01-12T18:53:10.199Z [hyperiond LEDDEVICE] (ERROR) Device disabled, device 'ws281x' signals error: 'Failed to open. Error message: Hardware revision is not supported' 2021-01-13T17:03:44.509Z [hyperiond WEBSOCKET] (DEBUG) (JsonAPI.cpp:1054:handleLoggingCommand()) log streaming activated for client ::ffff:192.168.1.58 2021-01-13T17:03:44.509Z [hyperiond WEBSOCKET] (DEBUG) (JsonAPI.cpp:1054:handleLoggingCommand()) log streaming activated for client ::ffff:192.168.1.58 2021-01-13T17:03:44.509Z [hyperiond WEBSOCKET] (DEBUG) (JsonAPI.cpp:1054:handleLoggingCommand()) log streaming activated for client ::ffff:192.168.1.58
     
  19. the1one

    the1one Member

    Messages:
    47
    alles is terug aangesloten. misschien nog een opmerking telkens als ik reboot het wit lampje op de leds blijft gewoon branden
     
  20. the1one

    the1one Member

    Messages:
    47
    2021-01-13T17:17:56.521Z [hyperiond DAEMON] (INFO) CEC handler created
    2021-01-13T17:17:56.537Z [hyperiond EFFECTFILES] (INFO) 39 effects loaded from directory :/effects/
    2021-01-13T17:17:56.543Z [hyperiond EFFECTFILES] (INFO) 22 effect schemas loaded from directory :/effects/schema/
    2021-01-13T17:17:56.544Z [hyperiond EFFECTFILES] (INFO) 0 effects loaded from directory /.hyperion/custom-effects
    2021-01-13T17:17:56.571Z [hyperiond SETTINGSMGR] (DEBUG) (SettingsManager.cpp:109:SettingsManager()) Settings database initialized
    2021-01-13T17:17:56.573Z [hyperiond BLACKBORDER] (DEBUG) (BlackBorderProcessor.cpp:64:handleSettingsUpdate()) Set mode to: default
    2021-01-13T17:17:56.573Z [hyperiond COMPONENTREG] (DEBUG) (ComponentRegister.cpp:36:setNewComponentState()) Blackborder detector: enabled
    2021-01-13T17:17:56.611Z [hyperiond DAEMON] (INFO) set screen capture device to 'dispmanx'
    2021-01-13T17:17:56.612Z [hyperiond DISPMANXGRABBER] (DEBUG) (Grabber.cpp:30:setVideoMode()) Set videomode to 0
    2021-01-13T17:17:56.613Z [hyperiond DISPMANXGRABBER] (INFO) Display opened with resolution: 4x1053343732
    2021-01-13T17:17:56.613Z [hyperiond DISPMANXGRABBER] (DEBUG) (Grabber.cpp:90:setWidthHeight()) Set new width: 80, height: 45 for capture
    2021-01-13T17:17:56.614Z [hyperiond DAEMON] (INFO) DISPMANX frame grabber created
    2021-01-13T17:17:56.614Z [hyperiond V4L2:/DEV/VIDEO0] (DEBUG) (Grabber.cpp:30:setVideoMode()) Set videomode to 0
    2021-01-13T17:17:56.616Z [hyperiond V4L2:/DEV/VIDEO0] (DEBUG) (Grabber.cpp:90:setWidthHeight()) Set new width: 640, height: 480 for capture
    2021-01-13T17:17:56.616Z [hyperiond V4L2:/DEV/VIDEO0] (INFO) Signal threshold set to: {12, 12, 12}
    2021-01-13T17:17:56.616Z [hyperiond V4L2:/DEV/VIDEO0] (INFO) CEC detection is now disabled
    2021-01-13T17:17:56.616Z [hyperiond V4L2:/DEV/VIDEO0] (INFO) Signal detection is now disabled
    2021-01-13T17:17:56.616Z [hyperiond V4L2:/DEV/VIDEO0] (INFO) Signal detection area set to: 0.250000,0.250000 x 0.750000,0.750000
    2021-01-13T17:17:56.616Z [hyperiond DAEMON] (DEBUG) (hyperiond.cpp:630:handleSettingsUpdate()) V4L2 grabber created
    2021-01-13T17:17:56.622Z [hyperiond JSONSERVER] (DEBUG) (JsonServer.cpp:28:JsonServer()) Created instance
    2021-01-13T17:17:56.629Z [hyperiond JSONSERVER] (INFO) Started on port 19444
    2021-01-13T17:17:56.615Z [hyperiond LEDDEVICE] (INFO) Start LedDevice 'ws281x'.
    2021-01-13T17:17:56.615Z [hyperiond COMPONENTREG] (DEBUG) (ComponentRegister.cpp:36:setNewComponentState()) Smoothing: enabled
    2021-01-13T17:17:56.615Z [hyperiond LEDDEVICE] (DEBUG) (LedDevice.cpp:148:init()) deviceConfig: [{"colorOrder":"rgb","currentLedCount":130,"dma":5,"gpio":18,"hardwareLedCount":130,"invert":false,"latchTime":0,"leds":256,"pwmchannel":0,"rewriteTime":1000,"rgbw":false,"type":"ws281x","whiteAlgorithm":"subtract_minimum"}]
    2021-01-13T17:17:56.616Z [hyperiond SMOOTHING] (DEBUG) (LinearColorSmoothing.cpp:701:selectConfig()) cfg [0]: Type: linear - Time: 200 ms, outputRate 25.000000 Hz, interpolationRate: 25.000000 Hz, timer: 40 ms, Dithering: 0, Decay: 1.000000 -> HalfTime: 100.000000 ms
    2021-01-13T17:17:56.616Z [hyperiond LEDDEVICE] (DEBUG) (LedDevice.cpp:407:setLatchTime()) LatchTime updated to 0ms
    2021-01-13T17:17:56.617Z [hyperiond LEDDEVICE] (DEBUG) (LedDevice.cpp:428:setRewriteTime()) Refresh interval = 1000ms
    2021-01-13T17:17:56.617Z [hyperiond LEDDEVICE] (DEBUG) (LedDevice.cpp:434:setRewriteTime()) RewriteTime updated to 1000ms
    2021-01-13T17:17:56.617Z [hyperiond LEDDEVICE] (DEBUG) (LedDeviceWS281x.cpp:59:init()) ws281x strip type : 1050624
    2021-01-13T17:17:56.617Z [hyperiond LEDDEVICE] (ERROR) Device disabled, device 'ws281x' signals error: 'Failed to open. Error message: Hardware revision is not supported'
    2021-01-13T17:17:56.622Z [hyperiond SMOOTHING] (DEBUG) (LinearColorSmoothing.cpp:701:selectConfig()) Previous line repeats 1 times
    2021-01-13T17:17:56.622Z [hyperiond FLATBUFCONN] (INFO) Connecting to Hyperion: 127.0.0.1:19401
    2021-01-13T17:17:56.630Z [hyperiond EFFECTENGINE] (INFO) Run effect "Rainbow swirl fast" on channel 0
    2021-01-13T17:17:56.636Z [hyperiond FLATBUFSERVER] (INFO) Started on port 19400
    2021-01-13T17:17:56.637Z [hyperiond PROTOSERVER] (INFO) Started on port 19445
    2021-01-13T17:17:56.638Z [hyperiond WEBSERVER] (DEBUG) (WebServer.cpp:33:initServer()) Initialize Webserver
    2021-01-13T17:17:56.638Z [hyperiond WEBSERVER] (DEBUG) (WebServer.cpp:33:initServer()) Initialize Webserver
    2021-01-13T17:17:56.682Z [hyperiond EFFECTENGINE] (DEBUG) (EffectEngine.cpp:183:runEffectScript()) Start the effect: name [Rainbow swirl fast], smoothCfg [2]
    2021-01-13T17:17:56.682Z [hyperiond HYPERION] (DEBUG) (PriorityMuxer.cpp:161:registerInput()) Register new input 'System/EFFECT' with priority 0 as inactive
    2021-01-13T17:17:56.682Z [hyperiond HYPERION] (INFO) Initial foreground effect 'Rainbow swirl fast' started
    2021-01-13T17:17:56.683Z [hyperiond HYPERION] (DEBUG) (PriorityMuxer.cpp:161:registerInput()) Register new input 'System/V4L' with priority 240 as inactive
    2021-01-13T17:17:56.683Z [hyperiond COMPONENTREG] (DEBUG) (ComponentRegister.cpp:36:setNewComponentState()) V4L capture device: enabled
    2021-01-13T17:17:56.685Z [hyperiond V4L2:/DEV/VIDEO0] (INFO) configured v4l device: /dev/video0
    2021-01-13T17:17:56.685Z [hyperiond V4L2:/DEV/VIDEO0] (ERROR) Throws error nr: Cannot identify '/dev/video0' error code 2, No such file or directory
    2021-01-13T17:17:56.684Z [hyperiond BOBLIGHT] (DEBUG) (BoblightServer.cpp:28:BoblightServer()) Instance created
    2021-01-13T17:17:56.686Z [hyperiond HYPERION] (INFO) Hyperion instance 'GPIO-18' has been started
    2021-01-13T17:17:56.729Z [hyperiond WEBSERVER] (DEBUG) (WebServer.cpp:91:handleSettingsUpdate()) Apply Webserver settings
    2021-01-13T17:17:56.730Z [hyperiond WEBSERVER] (DEBUG) (WebServer.cpp:109:handleSettingsUpdate()) Set document root to: :/webconfig
    2021-01-13T17:17:56.730Z [hyperiond WEBSERVER] (DEBUG) (WebServer.cpp:91:handleSettingsUpdate()) Apply Webserver settings
    2021-01-13T17:17:56.730Z [hyperiond WEBSERVER] (DEBUG) (WebServer.cpp:109:handleSettingsUpdate()) Set document root to: :/webconfig
    2021-01-13T17:17:56.731Z [hyperiond WEBSERVER] (INFO) Started on port 8090 name 'Hyperion Webserver'
    2021-01-13T17:17:56.742Z [hyperiond WEBSERVER] (DEBUG) (WebServer.cpp:175:handleSettingsUpdate()) Setup SSL certificate
    2021-01-13T17:17:56.743Z [hyperiond WEBSERVER] (DEBUG) (WebServer.cpp:191:handleSettingsUpdate()) Setup private SSL key
    2021-01-13T17:17:56.744Z [hyperiond WEBSERVER] (INFO) Started on port 8092 name 'Hyperion Webserver'
    2021-01-13T17:17:56.779Z [hyperiond HYPERION] (DEBUG) (PriorityMuxer.cpp:251:setInputImage()) Priority 0 is now active
    2021-01-13T17:17:56.780Z [hyperiond HYPERION] (DEBUG) (PriorityMuxer.cpp:351:setCurrentTime()) Set visible priority to 0
    2021-01-13T17:17:56.780Z [hyperiond HYPERION] (DEBUG) (Hyperion.cpp:559:handlePriorityChangedLedDevice()) priority[0], previousPriority[255]
    2021-01-13T17:17:56.780Z [hyperiond HYPERION] (DEBUG) (Hyperion.cpp:569:handlePriorityChangedLedDevice()) new source available -> switch LED-Device on
    2021-01-13T17:17:59.768Z [hyperiond HYPERION] (DEBUG) (PriorityMuxer.cpp:315:setCurrentTime()) Timeout clear for priority 0
    2021-01-13T17:17:59.768Z [hyperiond HYPERION] (DEBUG) (PriorityMuxer.cpp:351:setCurrentTime()) Set visible priority to 0
    2021-01-13T17:17:59.768Z [hyperiond HYPERION] (DEBUG) (Hyperion.cpp:559:handlePriorityChangedLedDevice()) priority[0], previousPriority[0]
    2021-01-13T17:18:00.019Z [hyperiond HYPERION] (DEBUG) (PriorityMuxer.cpp:351:setCurrentTime()) Set visible priority to 255
    2021-01-13T17:18:00.019Z [hyperiond HYPERION] (DEBUG) (Hyperion.cpp:559:handlePriorityChangedLedDevice()) priority[255], previousPriority[0]
    2021-01-13T17:18:00.019Z [hyperiond HYPERION] (DEBUG) (Hyperion.cpp:562:handlePriorityChangedLedDevice()) No source left -> switch LED-Device off
    2021-01-13T17:18:09.722Z [hyperiond WEBSOCKET] (DEBUG) (WebSocketClient.cpp:30:WebSocketClient()) New connection from ::ffff:192.168.1.58
    2021-01-13T17:18:09.723Z [hyperiond WEBSOCKET] (DEBUG) (JsonAPI.cpp:81:handleInstanceSwitch()) Client '::ffff:192.168.1.58' switch to Hyperion instance 0
    2021-01-13T17:23:10.080Z [hyperiond WEBSOCKET] (DEBUG) (JsonAPI.cpp:1054:handleLoggingCommand()) log streaming activated for client ::ffff:192.168.1.58
    2021-01-13T17:23:10.096Z [hyperiond WEBSOCKET] (DEBUG) (JsonAPI.cpp:1063:handleLoggingCommand()) log streaming deactivated for client ::ffff:192.168.1.58
    2021-01-13T17:23:55.891Z [hyperiond WEBSOCKET] (DEBUG) (WebSocketClient.cpp:204:sendClose()) send close: 1000
    2021-01-13T17:23:56.395Z [hyperiond WEBSOCKET] (DEBUG) (WebSocketClient.cpp:30:WebSocketClient()) New connection from ::ffff:192.168.1.58
    2021-01-13T17:23:56.395Z [hyperiond WEBSOCKET] (DEBUG) (JsonAPI.cpp:81:handleInstanceSwitch()) Client '::ffff:192.168.1.58' switch to Hyperion instance 0
    2021-01-13T17:24:14.906Z [hyperiond WEBSOCKET] (DEBUG) (JsonAPI.cpp:1054:handleLoggingCommand()) log streaming activated for client ::ffff:192.168.1.58