1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

RPi + OpenELEC Autostart.sh skript

Discussion in 'Software Support' started by Quarkwolke, 5 January 2020.

Tags:
  1. Quarkwolke

    Quarkwolke New Member

    Messages:
    6
    Hardware:
    RPi3, 32/64bit, +Arduino
    Hallo ich wollte in mein autostart noch folgendes dazu schreiben.

    /storage/hyperion/bin/hyperiond.sh /storage/.config/hyperion.config.json > /storage/logfiles/hyperion.log 2>&1
    sleep3
    /storage/hyperion/bin/hyperion-remote.sh --color black &

    damit nicht direkt der externe grabber losgeht . Kann mir jemand erkären warum das nicht funktioniert ? Ich kenn mich noch nicht so gut mit skript schreiben aus.
     
  2. TPmodding

    TPmodding Administrator Staff Member Administrator

    Messages:
    1,430
    Hardware:
    RPi1/Zero, RPi2, RPi3, +Arduino, +nodeMCU/ESP8266
    welcher fehler kommt den?
     
  3. Quarkwolke

    Quarkwolke New Member

    Messages:
    6
    Hardware:
    RPi3, 32/64bit, +Arduino
    Naja wenn ich den Befehl /storage/hyperion/bin/hyperion-remote.sh --color black so per ssh an den rpi schicke wird das ambilight auf schwarz gestellt. Aber wenn ich es so ins Skript rein schreiben funktioniert es net.
     
  4. TPmodding

    TPmodding Administrator Staff Member Administrator

    Messages:
    1,430
    Hardware:
    RPi1/Zero, RPi2, RPi3, +Arduino, +nodeMCU/ESP8266
    hast du sleep3 oder sleep 3 (also mit oder ohne leerzeichen?)
    und probier mal längere sekunden anzahl