1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Dietpi w/ Hyperion

Discussion in 'Hyperion General' started by nicedevil007, 26 September 2019.

  1. nicedevil007

    nicedevil007 New Member

    Messages:
    9
    Hardware:
    RPi3, +nodeMCU/ESP8266
    Hey guys,

    I can't get hyperion running on my dietpi on raspberry pi 4. It is installed ofc with arm32v7.

    I installed hyperion on my Pi with the "buttons" inside hypercon.
    If I look for any error I can find this:

    Code:
    [email protected]:~# systemctl status hyperion.service
    ● hyperion.service - Hyperion Systemd service
       Loaded: loaded (/etc/systemd/system/hyperion.service; enabled; vendor preset: enabled)
       Active: active (running) since Thu 2019-09-26 19:31:51 CEST; 22min ago
    Main PID: 281 (hyperiond)
        Tasks: 5 (limit: 4915)
       Memory: 20.3M
       CGroup: /system.slice/hyperion.service
               └─281 /usr/bin/hyperiond /etc/hyperion/hyperion.config.json
    
    Sep 26 19:54:30 DietPi hyperiond[281]: DISPMANXGRABBER ERROR: Snapshot failed: -1
    Sep 26 19:54:30 DietPi hyperiond[281]: DISPMANXGRABBER ERROR: Snapshot failed: -1
    Sep 26 19:54:30 DietPi hyperiond[281]: DISPMANXGRABBER ERROR: Snapshot failed: -1
    Sep 26 19:54:30 DietPi hyperiond[281]: DISPMANXGRABBER ERROR: Snapshot failed: -1
    Sep 26 19:54:30 DietPi hyperiond[281]: DISPMANXGRABBER ERROR: Snapshot failed: -1
    Sep 26 19:54:30 DietPi hyperiond[281]: DISPMANXGRABBER ERROR: Snapshot failed: -1
    Sep 26 19:54:30 DietPi hyperiond[281]: DISPMANXGRABBER ERROR: Snapshot failed: -1
    Sep 26 19:54:31 DietPi hyperiond[281]: DISPMANXGRABBER ERROR: Snapshot failed: -1
    Sep 26 19:54:31 DietPi hyperiond[281]: DISPMANXGRABBER ERROR: Snapshot failed: -1
    Sep 26 19:54:31 DietPi hyperiond[281]: DISPMANXGRABBER ERROR: Snapshot failed: -1
    
    the service is installed with the "pi" user.

    Because it is "active" and running (I can connect with my phone to hyperion) I thought the error msg could be ignored?
    But not 1 LED is lighting up.

    I'm using APA102 with 60 LED/m and they are mounted on my 65" TV (power connections in each corner) and DI is connected to Pin 19 and CI is connected to Pin 21. Ground from the power supply is also connected to the pi (same ground that is going to the LEDs ofc).

    Is there anything missing for "Dietpi"? Maybe something that is removed by the devs for Dietpi (because it is a raspian on diet :p)?

    upload_2019-9-26_20-5-11.png
     
    Last edited: 26 September 2019
  2. Akriss

    Akriss Active Member

    Messages:
    561
    Hardware:
    RPi1/Zero, RPi2, RPi3, 32/64bit, +Arduino, +nodeMCU/ESP8266
    I was seeing that error when I used the docker build scripts.

    When I did the compile from a regular command prompt (No docker) on ether a Rpi0 or Rpi2 it compiles fine and runs fine.

    Not sure why it works that way for me. Try it may work for you.

    Hope its of help.