1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Hilfe: Ambilight bei TV Programm

Discussion in 'German Talk' started by Jigga, 31 October 2020.

  1. Jigga

    Jigga New Member

    Messages:
    22
    Hardware:
    RPi3, 32/64bit, +nodeMCU/ESP8266
    Morgen die Herren,

    Ich hab den Samsung UE55NU8009. An dem hängen Blueray Player, Soundbar, Nintendo Switch und ein Raspberry Pi 4B.

    Nun hab ich mir die SK6812 RGBNW geholt und die am einen ESP8266 angeschlossen, auf dem WLED läuft. Auf dem Pi läuft Hyperion.

    Was ich gerne hätte ist, dass wenn ich über den RasPi Filme gucke, oder das normale TV Programm, das Ambilight funktioniert. HDR, 4K usw benötige ich nicht.

    Was fehlt mir bei meinem Setup, sodass es funktioniert?
    Ich verstehe, dass die Dreambox das absolute Optimum darstellt, die ist aber viel zu teuer.
    Mich würde die günstigste Variante, aber auch die einfachste Variante interessieren. Und eine mit möglichst wenig Kabeln xD

    Danke für eure Hilfe!
     
  2. pclin

    pclin Active Member

    Messages:
    395
    Hardware:
    +nodeMCU/ESP8266
    Da du alles am TV angeschlossen hast wird das wohl nicht gehen.
    Der Samsung hat keinen internen Grabber der dir Daten für Hyperion liefert, und auch keinen HDMI Ausgang.

    In deiner Auflistung ist ein Switch, ist das ein HDMI Switch an dem die externen Geräte hängen?

    Wenn das ein HDMI Switch ist benötigst du noch einen Splitter, externen HDMI Grabber und einen Receiver für TV Bild.

    gruß pclin
     
    Last edited: 31 October 2020
  3. Bub4

    Bub4 Member

    Messages:
    91
    Hardware:
    RPi1/Zero, RPi3, +Arduino, +nodeMCU/ESP8266
  4. Jigga

    Jigga New Member

    Messages:
    22
    Hardware:
    RPi3, 32/64bit, +nodeMCU/ESP8266
    @pclin
    Was ist eine Nintendo Switch, also eine Konsole.

    @Bub4
    Auf dem ResPi läuft LibreELEC.
    Hab das Vodafone Giga irgendwas (1Gb Leitung). Aber nur mit dem Standard Router...
     
  5. pclin

    pclin Active Member

    Messages:
    395
    Hardware:
    +nodeMCU/ESP8266
    Dachte ich mir schon.
    Meine Antwort gilt dann noch.
    Du benötigst einen HDMI Switch für die externen Geräte, Splitter, Grabber.
    Nur mit dem Samsung wird das nicht funktionieren.

    gruß pclin
     
  6. Jigga

    Jigga New Member

    Messages:
    22
    Hardware:
    RPi3, 32/64bit, +nodeMCU/ESP8266
    Sprich mit meinem Fernseher wird das nicht funktionieren?
     
  7. Mike72

    Mike72 Member

    Messages:
    135
    Hardware:
    RPi3
    Über den RPi bzw. Kodi geht das über Hyperion und den internen Grabber. Beim "normalen TV Programm" über deinen Samsung-TV Tuner nur, wenn er über einen
    AV-Out verfügt. Aber selbst dann werden normalerweise darüber keine verschlüsselten Sender, bzw. Smart-TV Apps wie Netflix, Amazon Prime usw. ausgegeben.
    Das geht nur über externe Zuspielquellen.

    Für einen BlueRay-Player und eine Nintendo-Switch reicht ein 2 In 1 Out HDMI-Switch, ein HDMI-Splitter und einen externen Grabber, am besten so einen digitalen HDMI2USB.
     
  8. Jigga

    Jigga New Member

    Messages:
    22
    Hardware:
    RPi3, 32/64bit, +nodeMCU/ESP8266
    Danke an alle für die Hilfestellungen :)

    Leider hab ich weitere Fragen :|

    Im ersten Bild sieht man meine zwei Instanzen. Wobei die erste (RasPi_Hyperion) die ist, die schon da war, nur umbenannt.
    Ich habe eine weitere angelegt (ESP8266_WLED).
    Bild 2 zeigt die LED Controller Einstellung für RasPi_Hyperion, die vorausgefüllt war. Muss ich da etwas ändern?
    Bild 3 zeigt die LED Controller Einstellung für ESP8266_WLED. Muss ich bei "Target IP" die IP vom WLED eintragen?

    Muss das LED Layout bei beiden gleich sein?

    Danke euch schonmal im Voraus!
     

    Attached Files:

    • f1.jpg
      f1.jpg
      File size:
      67.2 KB
      Views:
      18
    • f2.jpg
      f2.jpg
      File size:
      66.1 KB
      Views:
      18
    • f3.jpg
      f3.jpg
      File size:
      76.8 KB
      Views:
      20
  9. pclin

    pclin Active Member

    Messages:
    395
    Hardware:
    +nodeMCU/ESP8266
    Frage hast du überhaupt Stripes für 2 Instanzen?
    Wenn ja dann
    Bild 2:
    Controller Typ: file und Output path: /dev/null must du ändern.
    Da must du natürlich eintragen was du für diese Instanz verwendest.
    Bild 3:
    Target IP/Hostname IP oder Hostname des WLED eintragen.
    Wenn nein dann must du nur die erste Instanz für WLED konfigurieren, die zweite kannst du dann löschen.

    gruß pclin
     
  10. Bub4

    Bub4 Member

    Messages:
    91
    Hardware:
    RPi1/Zero, RPi3, +Arduino, +nodeMCU/ESP8266
    Du hast doch nur die einen LEDs hinterm TV, oder? Dann brauchst Du doch gar keine zweite Instanz...?
    Anbei ein Screenshot, wie es bei einer Instanz aussieht. Die Zweite würde dann gleich aussehen, aber eine individuelle und unabhängige LED Konfiguration haben.
     

    Attached Files:

  11. Jigga

    Jigga New Member

    Messages:
    22
    Hardware:
    RPi3, 32/64bit, +nodeMCU/ESP8266
    Alles klar, danke!

    @Bub4
    ich habe nur zwei Felder zum Ausfüllen... ist das normal?
     
  12. Bub4

    Bub4 Member

    Messages:
    91
    Hardware:
    RPi1/Zero, RPi3, +Arduino, +nodeMCU/ESP8266
    Du hast alpha 8 und bei Steuerungstyp WLED ausgewählt, oder?
     
  13. Jigga

    Jigga New Member

    Messages:
    22
    Hardware:
    RPi3, 32/64bit, +nodeMCU/ESP8266
  14. Bub4

    Bub4 Member

    Messages:
    91
    Hardware:
    RPi1/Zero, RPi3, +Arduino, +nodeMCU/ESP8266
    dann sollte es eigentlich so aussehen, wie in meinen Screenshot

    Allgemeine Einstellungen:
    Anzahl Hardware LEDs = 1
    RGB Reihenfolge = RGB

    Spezifische Einstellungen:
    IP = IP Deines WLEDs
    Sperrzeit = 0
     
  15. Jigga

    Jigga New Member

    Messages:
    22
    Hardware:
    RPi3, 32/64bit, +nodeMCU/ESP8266
    Hmm... Habe nochmal installiert, es bleibt bei zwei Feldern
     
  16. Bub4

    Bub4 Member

    Messages:
    91
    Hardware:
    RPi1/Zero, RPi3, +Arduino, +nodeMCU/ESP8266
    bitte poste nochmal einen screenshot
     
  17. Jigga

    Jigga New Member

    Messages:
    22
    Hardware:
    RPi3, 32/64bit, +nodeMCU/ESP8266
    Ist genau das gleiche Bild, wie Bild 3... oder willst du etwas anderes sehen?
     
  18. pclin

    pclin Active Member

    Messages:
    395
    Hardware:
    +nodeMCU/ESP8266
    Hast du die 2 Instance gelöscht?
    Bei der ersten Controller Typ wled ausgewählt?

    Alternativ könntest du auch udpraw auswählen, Einstellungen dann wie im Screenshot, nur Anzahl LED und IP musst du dann natürlich ändern.

    gruß pclin
     

    Attached Files:

    Last edited: 5 November 2020
    • Like Like x 1
  19. Bub4

    Bub4 Member

    Messages:
    91
    Hardware:
    RPi1/Zero, RPi3, +Arduino, +nodeMCU/ESP8266
    udpraw hatte bei meiner initialen Konfiguration unter Alpha 8 nicht mehr funktioniert und ich musste auf WLED gehen.
    Bei mir sieht die LED Hardware Seite aber auch identisch aus zur Hauptinstanz (Screenshot anbei).
    Hast Du eventuell doch eine frühere Alpha installiert? :classy:
     

    Attached Files:

  20. pclin

    pclin Active Member

    Messages:
    395
    Hardware:
    +nodeMCU/ESP8266
    Ich habe bei mir in Alpha 8 nur die Haupt Instance auf Wled umgestellt für die Screenshots, mit udpraw laufen bei mir alle, nach wie vor.
    Bei einem Update oder drüber Installieren werden die Einstellungen ja nicht überschrieben oder gelöscht, und udpraw habe ich schon so lange eingestellt, da gab es wled noch gar nicht in Hyperion als Steuerungstyp.

    udpraw und Port 19446 wird auch bei der Auswahl von wled verwendet.

    gruß pclin