1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SOLVED HyperCon not able to take screenshoot

Discussion in 'Hardware Support' started by Stitch626, 25 May 2018.

  1. Stitch626

    Stitch626 New Member

    RPi1/Zero, RPi2, 32/64bit, +PhilipsHue
    i have installed HyperCon onto my Pi, and notice a few errors. could someone help me with is? i am not 100% sure if its a bad grabber or i need to install more software? below is the output of the HyperCon installation.

    ssh connected
    ssh out: cd /tmp && wget -nv -N https://raw.github.com/hyperion-project/hyperion/master/bin/install_hyperion.sh && chmod +x install_hyperion.sh && sudo sh ./install_hyperion.sh HyperConInstall ; rm install_hyperion.sh
    ssh out: Last-modified header missing -- time-stamps turned off.
    ssh out: 2018-05-25 00:23:19 URL:https://raw.githubusercontent.com/hyperion-project/hyperion/master/bin/install_hyperion.sh [14552/14552] -> "install_hyperion.sh" [1]
    ssh in: *******************************************************************************
    ssh in: This script will install/update Hyperion Ambient Light
    ssh in: Created by brindosch - hyperion-project.org - the official Hyperion source.
    ssh in: *******************************************************************************
    ssh in: ---> Stop Hyperion, if necessary
    ssh in: ---> Install/Update Hyperion dependencies (This may take a while)
    ssh in: ---> Downloading the appropriate Hyperion release
    ssh out: 2018-05-25 00:23:55 URL:https://newcontinuum.dl.sourceforge.net/project/hyperion-project/release/hyperion_rpi3.tar.gz [1640849/1640849] -> "-" [1]
    ssh in: ---> Installing systemd script
    ssh out: Created symlink /etc/systemd/system/multi-user.target.wants/hyperion.service ¬ニメ /etc/systemd/system/hyperion.service.
    ssh in: ---> Starting Hyperion
    ssh in: *******************************************************************************
    ssh in: Hyperion Installation/Update finished!
    ssh in: Please download the latest HyperCon version to benefit from new features!
    ssh in: To create a config, follow the HyperCon Guide at our Wiki (EN/DE)!
    ssh in: Wiki: wiki.hyperion-project.org Webpage: www.hyperion-project.org
    ssh in: *******************************************************************************

    here is the error i am getting when i try to take a screenshoot
    ssh in: hyperion-v4l2:
    ssh in: version : V1.03.4 (brindosch-c750c41/dc6a602-1522918225
    ssh in: build time: Apr 5 2018 01:57:25
    ssh out: VIDIOC_S_STD ERROR 25, Inappropriate ioctl for device
    sftp getFile(./screenshot.png, java.awt.Image)
  2. Mike72

    Mike72 Member

    What is the solution? I have the same error.
  3. The

    The New Member

    I've had success with Hyperion.NG using previously unsupported USB capture hardware (534d:0021) on RPi2. Hyperion.old failed to use my hardware and crashed during startup when attempting the USB capture.
    • Like Like x 1
  4. TPmodding

    TPmodding Administrator Staff Member Administrator

    RPi1/Zero, RPi2, RPi3, +Arduino, +nodeMCU/ESP8266
    • Like Like x 1