1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

HyperCon Hyperion does not start on Raspberry Pi 3 (systemd errors)

Discussion in 'Software Support' started by tpks, 12 October 2019 at 14:40.

  1. tpks

    tpks New Member

    Messages:
    1
    Hardware:
    RPi3, 32/64bit, +PhilipsHue
    Hi community, I've installed the hardware for the Hyperion/Raspberry Pi 3 Ambilight project.

    When it comes to installing and starting the software, I am having massive trouble, as the Pi does not seem to send a signal to the LEDs. I am sure you understand more of Hyperion than me since I have never even used a raspberry pi or Linux before. I would be extremely grateful if you had a look and told me what you think I did wrong.

    Sometimes, a few LEDs on when powering up the LED driver and the Pi and sometimes, nothing turns on at all.

    I am using this APA102 strip: https://www.amazon.de/gp/product/B06X9YC8N2/
    For the setup, I have used this tutorial:



    I am using Raspbian Jessie (21-06-2017) but have tried other, newer versions, it does not work on either version.

    I have tested the setup/hardware with Aki's image and it works: https://i.imgur.com/xBIJYBn.jpg

    Here are the connections between DC/Strip and most importantly, Raspberry Pi:
    https://i.imgur.com/zFlGNck.jpg
    https://i.imgur.com/UySQ6LV.jpg
    --- Green is Data In/Out (Pin 19), Yellow is Clock In/Out (Pin 23), Black is GND (Pin 9)
    --- The setup has 206 LEDs (2x66 horizontally and 2x37 vertically)

    You can find the:

    (1) Raspbian Jessie Config.txt here: https://github.com/tpks25/tpks/issues/2
    (2) hyperion.config.json here: https://github.com/tpks25/tpks/issues/3
    (3) Hyperion Log here: https://github.com/tpks25/tpks/issues/1

    The first LED is on the bottom left when you look towards the screen from the front and the direction counterclockwise when viewed from the front side.

    I recorded the entire HyperCon set up here:



    - unfortunately my Windows screen recorder did not record the popups, so you won't be able to see the installing loading screen popup (which worked successfully) and the "send config" popup, which did not show anything when trying it for the first time and showed a successful transfer log after reconnecting and sending the config file again (please read below for more info on that).

    Please note: After sending the config file to the device, the Pi seems to disconnect. This time, I waited a bit longer (YouTube video: 5:30 - 7:12) but it did not help.
    After connecting again, sending the config file again and then pressing "stop" and "start", nothing happens. I have never seen the rainbow bootup effect.

    I have not found an answer online/on the forum so far, hopefully I did not overlook a thread which shows the solution. If I did, I am sorry. In that case, I'd be grateful if you sent me the corresponding URL.

    Thank you for your time and help in advance!
    Tom
     
    Last edited: 12 October 2019 at 14:45