1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

hyperion.ng auf Raspberry 4, Raspbian Buster, USB Grabber

Discussion in 'German Talk' started by jochenf, 11 August 2019.

  1. Lucky007

    Lucky007 New Member

    Messages:
    17
    Hardware:
    RPi3, 32/64bit
    Oh man ja stimm .

    Ich gucke gleich sofort mal nach.
    Bist du noch etwas online?
    Wollte eine kurze Pause machen und was essen
     
  2. Paulchen-Panther

    Paulchen-Panther Active Member Developer

    Messages:
    307
    Hardware:
    RPi1/Zero, RPi3, 32/64bit, +Arduino
    Na klar. Bis 20:15 bin ich hier online
     
  3. Lucky007

    Lucky007 New Member

    Messages:
    17
    Hardware:
    RPi3, 32/64bit
    Hey cool läuft.
    Soll das dass neue Hyperion werden und das alte ablösen? Wäre natürlich echt cool wenn das so wäre.
    Ist das richtig die Meldung nach dem Start :

    qt.network.ssl: QSslSocket: cannot resolve CRYPTO_num_locks
    qt.network.ssl: QSslSocket: cannot resolve CRYPTO_set_id_callback
    qt.network.ssl: QSslSocket: cannot resolve CRYPTO_set_locking_callback
    qt.network.ssl: QSslSocket: cannot resolve ERR_free_strings
    qt.network.ssl: QSslSocket: cannot resolve EVP_CIPHER_CTX_cleanup
    qt.network.ssl: QSslSocket: cannot resolve EVP_CIPHER_CTX_init
    qt.network.ssl: QSslSocket: cannot resolve sk_new_null
    qt.network.ssl: QSslSocket: cannot resolve sk_push
    qt.network.ssl: QSslSocket: cannot resolve sk_free
    qt.network.ssl: QSslSocket: cannot resolve sk_num
    qt.network.ssl: QSslSocket: cannot resolve sk_pop_free
    qt.network.ssl: QSslSocket: cannot resolve sk_value
    qt.network.ssl: QSslSocket: cannot resolve SSL_library_init
    qt.network.ssl: QSslSocket: cannot resolve SSL_load_error_strings
    qt.network.ssl: QSslSocket: cannot resolve SSL_get_ex_new_index
    qt.network.ssl: QSslSocket: cannot resolve SSLv23_client_method
    qt.network.ssl: QSslSocket: cannot resolve SSLv23_server_method
    qt.network.ssl: QSslSocket: cannot resolve X509_STORE_CTX_get_chain
    qt.network.ssl: QSslSocket: cannot resolve OPENSSL_add_all_algorithms_noconf
    qt.network.ssl: QSslSocket: cannot resolve OPENSSL_add_all_algorithms_conf
    qt.network.ssl: QSslSocket: cannot resolve SSLeay
    qt.network.ssl: QSslSocket: cannot resolve SSLeay_version
    qt.network.ssl: QSslSocket: cannot call unresolved function SSLeay
    qt.network.ssl: QSslSocket: cannot call unresolved function CRYPTO_num_locks
    qt.network.ssl: QSslSocket: cannot call unresolved function CRYPTO_set_id_callback
    qt.network.ssl: QSslSocket: cannot call unresolved function CRYPTO_set_locking_callback
    qt.network.ssl: QSslSocket: cannot call unresolved function SSL_library_init
     
  4. Paulchen-Panther

    Paulchen-Panther Active Member Developer

    Messages:
    307
    Hardware:
    RPi1/Zero, RPi3, 32/64bit, +Arduino
    Wie geschrieben da fehlen noch die Dependencies für die HTTPS/SSL Verbindung.
     
  5. Lucky007

    Lucky007 New Member

    Messages:
    17
    Hardware:
    RPi3, 32/64bit
    Aber das soll mich nicht stören?
    Ich habe alles richtig gemacht?!
    Du bist der beste.
    Vielen vielen lieben Dank.
    Habe ich wieder was gelernt.
    Mach weiter so
    Danke und schönen Abend.
     
    • Like Like x 1
  6. Paulchen-Panther

    Paulchen-Panther Active Member Developer

    Messages:
    307
    Hardware:
    RPi1/Zero, RPi3, 32/64bit, +Arduino
    Danke. dir auch noch einen schönen Abend.

    P.S. sollte hyperion.ng nach dem ändern des led devices oder der anzahl an leds im WebUI abstürzen, einfach hyperiond neu starten. die einstellungen werden in den meisten fällen gespeichert.
    P.P.S. Ach ja, dieser version ist nicht ganz aktuell. Werde die Tage mal eine neue Version online stellen.
     
  7. Lucky007

    Lucky007 New Member

    Messages:
    17
    Hardware:
    RPi3, 32/64bit
    Tausend Dank,
    Ich hoffe ich bekomme das mit dem Systemd Zeug hin. :)
    Aber klappt schon.
    Ich kann mich nur noch einmal bedanken für deine Bemühungen und Geduld.
    Findet man heutzutage nicht mehr oft.
     
  8. Lord-Grey

    Lord-Grey New Member

    Messages:
    4
    Hardware:
    RPi3, 32/64bit
    Du kannst Hyperion auch mit “./hyperiond &” starten. Dann läuft es als eigener Unterprozess und beendet sich nicht beim Schließen des Terminals.
    Allerdings musst Du Dir zum Stoppen den Prozess heraussuchen (ps | grep hyperiond) und ein “kill” auf die Prozessnummer absetzen.
    So kannst Du erstmal testen.
    Nach einem pi Restart musst Du allerdings hyperiond erneut starten.
     
    • Like Like x 2
  9. Lucky007

    Lucky007 New Member

    Messages:
    17
    Hardware:
    RPi3, 32/64bit
    Danke, ich werde es testen
    Kurze Frage,
    Akzeptiert die Software auch das ich über kodi abgespielte Videos als ambilight beleuchtet werden so wie auch über den externen grabber?
    Ich hoffe ich bekomme die Einstellungen mit dem led gezähle richtig hin.
    Beim zählen kann man nicht viel falsch machen..
    Wie findest du das Hyperion?
    Besser als das andere?
    Wenn ich ohne Probleme zwischen 2 Quellen wechseln kann bin ich aufjedefall zufrieden :)))

    Grüße
     
  10. Lord-Grey

    Lord-Grey New Member

    Messages:
    4
    Hardware:
    RPi3, 32/64bit
    Ja. Die über Kodi abgespielten Videos werden auf dem jeweiligen LedDevice ausgegeben.
    Ich habe nur diese eine Quelle und kann zum externen Grabber nicht helfen. Sorry.
     
  11. tester38

    tester38 New Member

    Messages:
    14
    Hardware:
    RPi3, +Arduino
    kann es sein das hyperion.ng generell den usb grabber nicht erkennt ?
    Habe ein paar mal gelesen das leute mit hyperion.ng und externe grabber probleme hatten.

    Ich nutze zurzeit CoreElec auf dem Odroid n2.
    Hyperion.ng war in deren repo vorhanden und habe es dann einfach von da installiert.
    Der interne grabber funktioniert und ich kann ambilight bei fotos und videos nutzen. Der externe grabber wird garnicht erkannt. Schwarzes bild.
     
    • Agree Agree x 1
  12. tester38

    tester38 New Member

    Messages:
    14
    Hardware:
    RPi3, +Arduino
    @Paulchen-Panther könntest du mir vielleicht behilflich sein. Wäre dir sehr dankbar.
    Nutze CoreELEC auf dem ODROID N2. APA102 LEDs über arduino angeschlossen.
    Hyperion.ng über die coreELEC repo installiert. interner grabber läuft aber externer nicht,. Wenn ich die normale hyperion version installiere funktioniert der externe grabber wieder.
     
  13. Paulchen-Panther

    Paulchen-Panther Active Member Developer

    Messages:
    307
    Hardware:
    RPi1/Zero, RPi3, 32/64bit, +Arduino
    @tester38
    Kommst du an das Hyperion.ng log über ssh ran?
    Die Konsolenausgabe würde mich brennend interessieren.
     
  14. tester38

    tester38 New Member

    Messages:
    14
    Hardware:
    RPi3, +Arduino
    wo genau soll denn der log sein ? 'Auf dem pi4 war immer bei, logfiles ordner eine logdatei von hyperion selber.
    beim Odroid N2 mit CoreELEC finde ich keine solche datei.

    Meine verzeichnisse sind folgende:
    \\coreelec\Addons\service.hyperion
    \\coreelec\Userdata\addon_data\service.hyperion

    Noch eine Frage:
    beim normalen hyperion konnte ich z.b. auswählen wo der grabber aktif sein soll.
    z.b.:

    "xbmcVideoChecker" :
    {
    "xbmcAddress" : "127.0.0.1",
    "xbmcTcpPort" : 9090,
    "grabVideo" : true,
    "grabPictures" : true,
    "grabAudio" : true,
    "grabMenu" : true,
    "grabPause" : true,
    "grabScreensaver" : false,

    gibt es so eine option auch beim hyperion.NG ?
     
  15. tester38

    tester38 New Member

    Messages:
    14
    Hardware:
    RPi3, +Arduino
    waren jetzt oben die verzeichnisse vom normalen hyperion was ich per CoreELEC Repo installiert hatte.
    Beim NG ist es aber gleich nur mit einem .ng am ende also \\coreelec\Addons\service.hyperion.ng.

    Im CoreELEC Forum hab ich mal gefragt welche version ich habe bzw wo ich das überprüfen kann.
    Er hat folgendes geantwortet:

    This is the last version used in CE repo:
    https://github.com/CoreELEC/CoreELE...ages/addons/service/hyperion.ng/package.mk#L5

    I don’t know if a newer version include a external grabber. Newer versions are not compiling as a package is missing.