1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SOLVED Hyperion windows 10/raspberry

Discussion in 'French Talk' started by Greg45140, 23 November 2020.

  1. Greg45140

    Greg45140 New Member

    Messages:
    13
    Hardware:
    RPi3
    Bonjour a tous,

    Je voudrais utiliser Hyperion Alpha9 sur windows 10 via "localhost:8090". impossible, il me demande un mot de passe! avez vous une idée?

    merci
     
  2. NeeeeB

    NeeeeB Active Member

    Messages:
    237
    Hardware:
    RPi3, +Arduino, +nodeMCU/ESP8266
    Hyperion est installé sur quoi ?
    Si c'est sur un Pi, je ne comprend pas pkoi tu essayes d'y accéder par localhost, qui représente 127.0.0.1....
    l'adresse correcte pour accéder à hyperion installé sur un Pi c'est soit
    http://hyperion:8090
    soit http://192.168.x.x:8090 (l'adresse du Pi sur ton réseau)
    PS: bien remarquer que c'est HTTP et non pas HTTPS
     
  3. Greg45140

    Greg45140 New Member

    Messages:
    13
    Hardware:
    RPi3
    Bjr NeeeeB, ce n'est pas moi qui veut, c'est HyperionNg(alpha9). Clic droit/setting... il me lance mon navigateur avec "localhost:8090"
    Hyperion est installer via HyperionCon sur mon raspberry.
     
  4. NeeeeB

    NeeeeB Active Member

    Messages:
    237
    Hardware:
    RPi3, +Arduino, +nodeMCU/ESP8266
    Hein ?
    Quel click droit/setting ? je n'ai jamais vu ça de ma vie dans Hyperion.
    Comment ça tu as installé Hyperion.NG avec HyperCon ?
    HyperCon c'était l'outil qui servait à installer l'ancienne version d'Hyperion, pas Hyperion.NG, ça n'a absolument rien à voir.

    Tu t'es totalement emmêlé les pinceaux je crois...
    Tu as suivi un tuto pour en arriver là ? si oui lequel ?

    PS: hormis hyperion, y'a quoi d'installé sur ton Pi ?
     
  5. Greg45140

    Greg45140 New Member

    Messages:
    13
    Hardware:
    RPi3
    :singing: je crois aussi que je mélange un peu tout... je débute sur Pi..:unsure:
    Sur le Pi jai installer via Hypercon, hyperion.(Suivi Tuto sur YouTube) cela fonctionner bien sauf pour le grabber.

    Sur le Pc W10 jai installer HyperionAlph9. je voulais passer a quelque chose de plus récent mais je pense que j'utilise 2 méthode non compatible..? Du coup!
     
  6. Greg45140

    Greg45140 New Member

    Messages:
    13
    Hardware:
    RPi3
    Et sur Pi il y a que Hyperion, il est tout neuf...
     
  7. NeeeeB

    NeeeeB Active Member

    Messages:
    237
    Hardware:
    RPi3, +Arduino, +nodeMCU/ESP8266
    D'accord, ça s'éclaircit un peu lol, autre question, pourquoi tu veux installer Hyperion.NG sur ton PC ?
     
  8. Greg45140

    Greg45140 New Member

    Messages:
    13
    Hardware:
    RPi3
    bonne question... il ma l'aire plus complet que Hypercon?!..:) il qu'il est plus récent.
     
  9. NeeeeB

    NeeeeB Active Member

    Messages:
    237
    Hardware:
    RPi3, +Arduino, +nodeMCU/ESP8266
    Oui, mais en as tu besoin spécifiquement sur ton PC, c'était plutôt ça ma question ^^
     
  10. Greg45140

    Greg45140 New Member

    Messages:
    13
    Hardware:
    RPi3
    Sur mon projet Ambilight/Hyperion, jai un soucis de Grabber. jai acheter le même que sur le tuto mais ca ne fonctionne pas.
    Dés que créer un "Hyperion.config.Json" avec un grabber de configurer les leds ne s'allume plus.

    Voila pourquoi je voulais voir avec HyperionNg, si je pouvais régler ce problème. Mais en faite j'en ai créer un autre..lol
     
  11. Greg45140

    Greg45140 New Member

    Messages:
    13
    Hardware:
    RPi3
    Tuto de MCFLYPARTAGES
    Lien:
     
  12. NeeeeB

    NeeeeB Active Member

    Messages:
    237
    Hardware:
    RPi3, +Arduino, +nodeMCU/ESP8266
    Ton Pi est relié en wifi ou en ethernet à ton réseau ?
     
  13. Greg45140

    Greg45140 New Member

    Messages:
    13
    Hardware:
    RPi3
    wifi en liaison VNC via mon pc. (plus pratique pour copier/coller des CMD) ;)
    Mon grabber est bien configurer car je peux avoir son flux video via VLC sur Pi.
    Je penche un problème avec Hyperion, mais je sèche..:facepalm:
     
  14. NeeeeB

    NeeeeB Active Member

    Messages:
    237
    Hardware:
    RPi3, +Arduino, +nodeMCU/ESP8266
    Je pense tout simplement que tu utilises une trop vieille version de Hyperion, qui ne supporte pas ton grabber (les UTV007 n'existent plus, on ne trouve que des UTVF007, qui ne sont pas supportés par Hyperion OLD).
    Je t'invite donc à faire ceci :
    Télécharger ça : https://downloads.raspberrypi.org/imager/imager_1.4.exe
    et télécharger ça : https://github.com/hyperion-project/HyperBian/releases/download/HyperBian/HyperBian.zip

    tu dézippes le .zip, tu auras un fichier .img
    tu lances imager_1.4.exe et tu flash le fichier .img sur la carte SD de ton Pi.
    Quand c'est fini, tu sors la SD de ton PC et tu la remets (toujours dans le PC)
    Tu vas voir que la carte s'appelle maintenant BOOT
    à la racine de la carte, avec NotePad, tu crées un fichier que tu appelles exactement comme ça :
    wpa_supplicant.conf (pas de .txt au bout hein, faut changer le .txt en .conf)
    Ensuite dans ce fichier (tu l'édites avec notepad toujours) tu mets ça :
    Code:
    ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
    update_config=1
    country=FR
    
    network={
        ssid="TON_SSID"
        psk="TON_PWD"
        key_mgmt=WPA-PSK
    }
    en remplaçant le SSID et le PSK par ton ssid et ton password de réseau.
    Tu enregistres, tu remets la carte SD dans le Pi et 5 minutes après l'avoir rebooté tu pourras accéder à l'inteface Web de Hyperion.NG en tapant http://hyperion:8090 depuis ton navigateur.
    Tu verras que c'est beaucoup plus pratique que HyperCon (qui de toute façon est outdated).
     
  15. Greg45140

    Greg45140 New Member

    Messages:
    13
    Hardware:
    RPi3
    oui Hyperbian, jai lu la doc Hyperion dessus.
    J'essaye ce soir et je reviens te dire! encore merci!:thumbsup::thumbsup:
     
  16. Greg45140

    Greg45140 New Member

    Messages:
    13
    Hardware:
    RPi3
    Juste dans mon SSID jai un espace, dans le fichier conf je le remplace par "_"
    ex: WifiDeltaReg 2.4G = WifiDeltaReg_2.4G Jai bon?
     
  17. NeeeeB

    NeeeeB Active Member

    Messages:
    237
    Hardware:
    RPi3, +Arduino, +nodeMCU/ESP8266
    Non, tu mets ton SSID tel qu'il est, donc avec l'espace ;-)
    "WifiDeltaReg 2.4G"
     
  18. Greg45140

    Greg45140 New Member

    Messages:
    13
    Hardware:
    RPi3
  19. Greg45140

    Greg45140 New Member

    Messages:
    13
    Hardware:
    RPi3
    De retour sur notre affaire...TOUT FONCTIONNE DU PREMIER COUP!!
    Un grand merci NeeeeB!

    Demain montage autour de l'ecran 120cm!
     
  20. NeeeeB

    NeeeeB Active Member

    Messages:
    237
    Hardware:
    RPi3, +Arduino, +nodeMCU/ESP8266
    De rien, content que ça marche ;-)