1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

HyperCon Install on Rock64 LibreElec

Discussion in 'Software Support' started by thiagobucca, 11 July 2019 at 02:28.

  1. thiagobucca

    thiagobucca New Member


    recently i got my hands on a Rock64 board and i'm struggling to get hyperion installed through Hypercon, at first i got the "Wrong architecture error" then i started to fiddle with the install script to bypass this error and see if it will install but neither of the arq options is working for me.

    The Rock64 board uses the same processor as Raspberry Pi, so i thought it should work fine.

    Is there any way to install hyperion in this board, or at least point me to the right direction to make this happen?

    Thanks in advance.
  2. TPmodding

    TPmodding Administrator Staff Member Administrator

    RPi1/Zero, RPi2, RPi3, +Arduino, +nodeMCU/ESP8266
    • Like Like x 2
  3. thiagobucca

    thiagobucca New Member

    Thanks for the response.

    Yes i tried using this very same link, using cmake options given on line 41 and 37, but neither worked.

    When running hyperiond i get "Unexpected error '('"

    I tried compiling both on the board itself and on my mac and got the same result.

    If it helps, i installed normaly though Hypercon on a LibreELEC build and later moved the files i compiled over, since i can't compile on LibreELEC system as is read only

    any other tips i could try?