1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SOLVED Installs fine but stuck on reboot

Discussion in 'Software Support' started by FilthX, 21 July 2017.

  1. FilthX

    FilthX New Member

    OK thanks to @PawelGrzembka I have hyperion running with no problems. I will document it for anyone that might run into the same problem. As I said earlier, the way I have installed the led strip is documented here
    Leaving it just for the hardware part of the project.
    On the software side the way to do it is:
    1. Install Libreelec 8.0.2 (or whatever kodi distro you want, the problem appeared to me on kodi 17)
    2. Open HyperCon and enter the details of the led strip (amount of leds etc)
    3. Create Hyperion Configuration (button on the bottom of the HyperCon window.
    4. Edit the file you created adding the line
    "dmanum" : 10, (with the quotes and the comma)
    on the device part of the file like this:

    "device" :
    "name" : "MyPi",
    "type" : "ws281x",
    "colorOrder" : "grb",
    "dmanum" : 10,
    "leds" : 96

    5. Connect via SSH using the last tab on the HyperCon window.
    6. Install Hyperion
    7. System will reboot.
    8. Connect with WinSCP on your raspberry and send the configuration file you created earlier on /storage/.config folder (I tried to send it with HyperCon and it would not transfer to my Pi, that's why I use WinSCP. So make sure the file actually exists on the said folder.
    9. Either restart your Pi or start hyperion from HyperCon after sonnecting again via SSH from HyperCon. You should see the rainbow and hyperion should work as it should, finally.
    10. In case you have made a mistake on the amount of leds and need to create a new configuation file (like me) after you send the file to your Pi you need to edit the configuration file again to add the
    "dmanum" : 10,
    line on the file again.

    Thanks a lot to @PawelGrzembka that pointed me to the solution proposed by @penfold42 .
  2. Palumi

    Palumi New Member

    RPi2, RPi3, 32/64bit, +Arduino, +nodeMCU/ESP8266
    Thanks a ton guys i've been working on this the whole day and couldn't find the Error.
    Sometimes the setup would start but all leds would blink white and random so the long bootscreen is not the only indicator for this "bug"

    This finally solved it.
  3. Cody

    Cody New Member

    RPi3, +PhilipsHue
    This worked got me as well. No idea what it does but it runs much better!
  4. kensn

    kensn New Member

    RPi3, +Arduino
    Is there any chance of this being added to the Hardware tab when using the ws281x driver so a manual update is not needed?

  5. PawelGrzembka

    PawelGrzembka New Member

    I don’t know but it’s like that in Hyperion NG.