1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

RPi + Other Software LEDs not working with more than 31 LEDs configured

Discussion in 'Software Support' started by eric1905, 8 May 2020.

  1. eric1905

    eric1905 New Member

    Messages:
    12
    Hardware:
    RPi3
    Hi everybody. I try to build an ambilight with a Raspberry Pi 3 with raspbian and one LED Stripe (WS2801) 50 pcs.
    CLK, Data and GND are connected to GPIO 6,19,23.
    The raspberry is powered by microusb, the led stripe by a power supply
    After I installed Hyperion via HyperCon (had problems downloading the file, but after that I managed the installation) had the problem that no led was coloring up.
    I then tried different tutorials and had no luck. Until I tried that one, which was linked to another thread:
    https://blog.heimetli.ch/raspberry-led-strip-c.html
    This works for me, I can see the first 25 LEDs changing the color as expected.
    I tried to change the sourcecode to get it working with 50 LEDs but again -> no luck. Just the first one was red.
    After that I tried again Hyperion and still the problem that nothing worked. So I reduced the number of LEDs in my config file to 25 and it was working. The demo color swirl was showing up.
    I added one LED by another and after I changed it from 31 to 32 I came to the point that the LEDS are not working again.
    So how can I resolve this issue? What could be the problem? Is the LED not working? But why seems the whole stripe not working then? With my 31-LED-config everything is ok, so why not when I add another LED?
    In my opinion the only difference is that LED 32 can not be adressed? Because the voltage should be the same. Why is the whole stripe not working and not just LED 32 and LEDs 1-31 are working as before?
    Hope you can help.
    Best regards
    Eric

    I have attached 2 files. The one where the 31 LEDs are working and one where no led is working (or sometimes the first)
     

    Attached Files: