1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

RPi + OSMC Leds too slow, Smoothing settings?

Discussion in 'Software Support' started by Onedune, 20 December 2016.

  1. Onedune

    Onedune New Member

    Messages:
    9
    Hardware:
    RPi3, +Arduino
    First excuse my bad English ! ;)

    Hi everyone, i finally do my DIY Lightberry and it works but i have issue with leds. They are too slow when the image change.
    Raspberry Pi 3, Arduino UNO, WS2812B led strip, Alim 5v 20A
    OSMC, HYPERION, ADALIGHT



    How to reduce this reaction time? Will the smoothing setting solve my problem?
    Here are the current settings:

    Code:
    // SMOOTHING CONFIG
            "smoothing" :
            {
                "type"            : "linear",
                "time_ms"         : 200,
                "updateFrequency" : 20.0000,
                "updateDelay"     : 0
    Thanks ! :)
     
  2. penfold42

    penfold42 Moderator Developer

    Messages:
    399
    Hardware:
    RPi1/Zero, RPi2, RPi3, 32/64bit, +Arduino, +nodeMCU/ESP8266
    Turn off smoothing.

    200ms is 1/5th of a second.

    Just edit the config file and change smoothing to NOsmoothing should work.
    Restart Hyperiond
     
  3. Onedune

    Onedune New Member

    Messages:
    9
    Hardware:
    RPi3, +Arduino
    Thanks, but what are the best or lowest setting of smoothing?
     
  4. penfold42

    penfold42 Moderator Developer

    Messages:
    399
    Hardware:
    RPi1/Zero, RPi2, RPi3, 32/64bit, +Arduino, +nodeMCU/ESP8266
    It's really personal preference vs the image processing delay of the TV.

    There could be other causes - have you tried it with smoothing off ?
     
  5. Onedune

    Onedune New Member

    Messages:
    9
    Hardware:
    RPi3, +Arduino
    I did it but it does not please me.
    What is the smallest value for smoothing?
     
  6. Rick164

    Rick164 Administrator Staff Member Administrator

    Messages:
    159
    Hardware:
    RPi2, +Arduino, +AtmoOrb
    Would try a value in between and raise the update frequency a bit:

    Time_ms:
    140ms
    updateFrequency: 24

    WS2812B is generally a bit slower to begin with as well so anything lower then 100ms isn't gonna give a very pleasant experience when I used them for a few years (now APA102).
    Like @penfold42 mentioned it all comes down to personal experience :)