1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SOLVED Pi4 Hyperion

Discussion in 'German Talk' started by mfg, 9 January 2021.

  1. mfg

    mfg New Member

    Messages:
    3
    Hallo,

    ich möchte einen weiteren Pi4 mit Ambilight bestücken.

    Beim Pi4 funktioniert das install script leider nicht.
    https://github.com/hyperion-project/hyperion/blob/master/bin/install_hyperion.sh
    Fehlermeldung: Critical Error: CPU information does not match any known releases

    Ich habe einen Pi4 der funktioniert, weiss aber leider nnicht mehr was ich damals alles gemacht habe ...
    Also habe ich mir die Dateien von meinem ersten Pi4 für den neuen "geklaut".

    alter Pi4:
    Hardware : BCM2711
    Revision : c03111
    Model : Raspberry Pi 4 Model B Rev 1.1
    Raspian/Debian Buster

    neuer Pi4:
    Hardware : BCM2711
    Revision : b03114
    Model : Raspberry Pi 4 Model B Rev 1.4
    Raspian/Debian Buster


    Habe mir die Abhängigkeiten installiert.
    apt install libqtcore4 libqtgui4 libqt4-network libusb-1.0-0 ca-certificates libpython2.7

    Dateien vom alten Pi geholt und auf den neuen kopiert.
    Code:
    /usr/share/hyperion/*
    
    config nach
    /etc/hyperion/hyperion.config.json
    
    symlinks
    sudo ln -fs /usr/share/hyperion/bin/hyperiond /usr/bin/hyperiond
    sudo ln -fs /usr/share/hyperion/bin/hyperion-remote /usr/bin/hyperion-remote
    sudo ln -fs /usr/share/hyperion/bin/hyperion-v4l2 /usr/bin/hyperion-v4l2
    sudo ln -fs /usr/share/hyperion/bin/hyperion-dispmanx /usr/bin/hyperion-dispmanx 2>/dev/null
    sudo ln -fs /usr/share/hyperion/bin/hyperion-x11 /usr/bin/hyperion-x11 2>/dev/null
    sudo ln -fs /usr/share/hyperion/bin/hyperion-aml /usr/bin/hyperion-aml 2>/dev/null
    
    Start script
    /etc/systemd/system/hyperion.service
    Hyperion start/stop/status funktioniert.
    Code:
    ● hyperion.service - Hyperion Systemd service
      Loaded: loaded (/etc/systemd/system/hyperion.service; enabled; vendor preset: enabled)
      Active: active (running) since Sat 2021-01-09 06:50:40 CET; 6h ago
    Main PID: 451 (hyperiond)
        Tasks: 1 (limit: 3861)
      CGroup: /system.slice/hyperion.service
              └─451 /usr/bin/hyperiond /etc/hyperion/hyperion.config.json
    Jan 09 06:50:41 Verstaerker hyperiond[451]: INFO: V4L2 grabber created and started
    Jan 09 06:50:42 Verstaerker hyperiond[451]: BORDER SWITCH REQUIRED!!
    Jan 09 06:50:42 Verstaerker hyperiond[451]: CURRENT BORDER TYPE: unknown=0 hor.size=0 vert.size=0
    Jan 09 06:50:42 Verstaerker hyperiond[451]: V4L2GRABBER INFO: stopped
    Jan 09 06:50:52 Verstaerker hyperiond[451]: EFFECTENGINE INFO: effect finished
    Jan 09 06:50:53 Verstaerker hyperiond[451]: V4L2GRABBER INFO: started
    Jan 09 12:59:14 Verstaerker hyperiond[451]: BORDER SWITCH REQUIRED!!
    Jan 09 12:59:14 Verstaerker hyperiond[451]: CURRENT BORDER TYPE: unknown=0 hor.size=0 vert.size=11
    Jan 09 12:59:40 Verstaerker hyperiond[451]: BORDER SWITCH REQUIRED!!
    Jan 09 12:59:40 Verstaerker hyperiond[451]: CURRENT BORDER TYPE: unknown=0 hor.size=0 vert.size=0
    Hyperion läuft, aber es ist keine flüssige Darstellung.
    Ruckelt / abgehakt bzw. läuft nicht rund.

    Hyperion-2.0.0-alpha.9-Linux-armv7l.deb
    führt zum gleichen Ergebniss --> ruckelt/abgehackt / stürzt ab ... (scheinbar alpha ;-))

    Was habe ich vergessen / übersehen oder gar falsch gemacht ? ;-)

    Bin um jede Hilfe / Tip dankbar.

    HW: usb-grapper + splitter
    Bilder holen per usb grabber funktioniert per Hypercon v1.03.3
    LED APA102 (202 St.)
     
    Last edited: 9 January 2021
  2. mfg

    mfg New Member

    Messages:
    3
    Neuinstallation mit dem gleichen buster .img
    Im install-script den "unbekannten" neuen Pi4 (BCM2711) als "rpi3" ergänzt und schon läuft das install-script durch wie beim rPi3 ...

    Keine Ahnung was da schief ging.
    Jetzt läufts.

    Danke ...
     
    • Like Like x 1