1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

RPi + Other Software RasPi Baud rate?

Discussion in 'Software Support' started by Gershy13, 1 October 2017.

  1. Gershy13

    Gershy13 Member

    Messages:
    32
    Hardware:
    RPi2
    Hi,

    Im seeing that i need to change my pi's baud rate. Does anyone know how to do this on raspbian? in hypercon and arduino its set to 500,000... what do i change my pi to and how?

    Thanks
    Gershy13
     
    • Thank you Thank you x 1
  2. Akriss

    Akriss Active Member

    Messages:
    567
    Hardware:
    RPi1/Zero, RPi2, RPi3, 32/64bit, +Arduino, +nodeMCU/ESP8266
  3. Gershy13

    Gershy13 Member

    Messages:
    32
    Hardware:
    RPi2
    thanks, i was following this guide https://hyperion-project.org/threads/diy-amblight-project-guide-hyperion-ws2801-ws2812b-apa102.8/
    and at the bottom it says i need i need to do this.
    - Now for the tricky part, we need to do a few steps to make sure the baud rate is high enough to accommodate the data being send from the Raspberry Pi to your Arduino
    - First we need to increase the default baud rate on your Raspberry:

    Im not sure how to do it in raspbian and what to set it to... maybe i need to do this only if im using an arduino and WS2812b leds (which i am)
     
  4. Akriss

    Akriss Active Member

    Messages:
    567
    Hardware:
    RPi1/Zero, RPi2, RPi3, 32/64bit, +Arduino, +nodeMCU/ESP8266
    Yes, used when using a arduino and any LED attached to it.

    The arduino firmware file (https://github.com/hyperion-project...assets/firmware/arduino/adalight/adalight.ino) has some info in it about baud rate.
    And in Hyperion's config it's here:

    // DEVICE CONFIGURATION
    "device" :
    {
    "name" : "new-test-1",
    "type" : "adalight",
    "output" : "/dev/ttyUSB0",
    "rate" : 500000, <------------ Here
    "delayAfterConnect" : 0,
    "colorOrder" : "rgb"

    EDIT: There is mentioned in that link in your post.
    "
    Code:
    nano -w /flash/config.txt
    Add the following line at the end and be careful not to adjust anything else:

    Code:
    #Increase UART speed
    init_uart_clock=14745600
    "
    I missed that. I've not used that info with my setup. I'll have and try it out. my setup seems fine with out.
     
    Last edited: 1 October 2017
  5. Shane

    Shane New Member

    Messages:
    4
    Hardware:
    RPi1/Zero
    Hi guys,

    Is this something I can do though the web UI or directly though SSH. What is the path?
     
  6. NeeeeB

    NeeeeB Active Member

    Messages:
    237
    Hardware:
    RPi3, +Arduino, +nodeMCU/ESP8266
    Through the WebUI, in Led hardware tab.
     
  7. Shane

    Shane New Member

    Messages:
    4
    Hardware:
    RPi1/Zero
    Thanks, I didnt have expert settings enabled. Seen all the settings once that was enabled :)
     
    • Like Like x 1