1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

RPi + LibreELEC Rpi3 + Arduino + libreELEC >> vendor preset: disabled

Discussion in 'Software Support' started by luckyjacks, 17 February 2021.

  1. TPmodding

    TPmodding Administrator Staff Member Administrator

    Messages:
    2,132
    Hardware:
    RPi1/Zero, RPi2, RPi3, +Arduino, +WLED, RPi4
    sorry but will switch to german:

    hast du das ding aus dem video aus china bestellt zur steuerung? wenn ja, da ist glaube ich KEIN uno drin, sondern ein anderer microcontroller....
    und wo genau ist den dein problem? das du die leds absolut garnicht steuern kannst?
     
    • Like Like x 1
  2. luckyjacks

    luckyjacks Member

    Messages:
    33
    Hardware:
    RPi3, +Arduino
    Beim sketch Upload wird er als Arduino Diecimila /at Mega 328P erkannt, und im Grunde ja,. Beim 1. mal nach dem 1. Hyperion.ng + sketch upload setup haben die LEDs weiß geleuchtet bis zum Strom abschalten, und das wars. Für kurze Zeit stand im status dann auch vendor enabled, und danach nicht mehr. Hab dann noch viel probiert und Fehler gefunden, Hyperion funktioniert soweit ich sehe prima, aber am Grundproblem hat sich seid her nichts geändert, die LDS rühren sich nicht mehr....
     
  3. TPmodding

    TPmodding Administrator Staff Member Administrator

    Messages:
    2,132
    Hardware:
    RPi1/Zero, RPi2, RPi3, +Arduino, +WLED, RPi4
  4. luckyjacks

    luckyjacks Member

    Messages:
    33
    Hardware:
    RPi3, +Arduino
    Wo genau ich das her hab weiß ich auch nicht mehr, aber wenn ich den 168 wähle, schlägt der Upload fehl,,vielleicht ne China klone Eigenheit...?
     
  5. TPmodding

    TPmodding Administrator Staff Member Administrator

    Messages:
    2,132
    Hardware:
    RPi1/Zero, RPi2, RPi3, +Arduino, +WLED, RPi4
    ja weils keiner ist... also deine aussage auch falsch

    hat nix mit "china klon" zu tun...

    um sicher zu sein würde ich es öffnen, wenn du das nicht möchtest probier mal arduino micro müsste der mega32u4 sein
     
  6. luckyjacks

    luckyjacks Member

    Messages:
    33
    Hardware:
    RPi3, +Arduino
    OK, dann ist kein Diecimila, hatte halt ne halbe Ewigkeit gesucht, und dann in einem Thread entdeckt, und der war der erste und einzige das funktionierte, der Micro hat leider auch nicht geklappt, und der Mega32u4 wird garnicht gelistet, auch nicht beim online upload.
    Bin froh, daß er überhaupt etwas erkennt etc
     
  7. TPmodding

    TPmodding Administrator Staff Member Administrator

    Messages:
    2,132
    Hardware:
    RPi1/Zero, RPi2, RPi3, +Arduino, +WLED, RPi4
    1. tu mir bitten den gefallen und unterlass die vollzitate...machts nur unübersichtlich

    2. würde ich dich bitten das gehäuse aufzumachen und einfach mal nach schauen was da den überhaupt drin ist...wir wollen ja effizient arbeiten, raten war da noch nie angebracht :)
     
    • Agree Agree x 1
  8. davieboy

    davieboy Active Member

    Messages:
    242
    Hardware:
    RPi1/Zero, RPi2, RPi3, RPi4
    On this occasion it may have been a whole lot easier to put a jumper in that plug and run them straight from the GPIO :)
     
    • Like Like x 1
  9. luckyjacks

    luckyjacks Member

    Messages:
    33
    Hardware:
    RPi3, +Arduino
    True

    Kein Ding, drück halt bloß reply,
    hab ihn aufgekriegt, 2 Fotos sind hier
    https://www.dropbox.com/sh/bp2n3kl9ektk54j/AADp3jEf87rA6Sl9zJLi1ECma?dl=0

    Ok, hab jetzt doch noch was relevantes rausgefunden, und zwar hab nachgefragt was für einen pi der tutorial producer tatsächlich benutzt hat, und stellt sich raus, es war doch ein 4. Hab jetzt inzwischen auch einen da, warte aber auf ein paar Kabel und netzteil stuff, zum anschließen, bin gespannt...
     
    Last edited by a moderator: 25 February 2021
  10. davieboy

    davieboy Active Member

    Messages:
    242
    Hardware:
    RPi1/Zero, RPi2, RPi3, RPi4
  11. TPmodding

    TPmodding Administrator Staff Member Administrator

    Messages:
    2,132
    Hardware:
    RPi1/Zero, RPi2, RPi3, +Arduino, +WLED, RPi4
    ok sieht gut aus, kannst du lesen was auf dem chip steht, da ist normal die bezeichnung abgebildet...

    das mit dem pi ist egal, könntest auch nen pi1 nutzen... oder an nem windows pc da es über usb funktioniert

    wir bleiben bei einer sache erstmal,
     
  12. luckyjacks

    luckyjacks Member

    Messages:
    33
    Hardware:
    RPi3, +Arduino
    Joa bin ja auch immer von, ausgegangen, aber da es so ein komisches setup ist, und sonst alles identisch, dacht ich wer weiß...
    Egal da ist ein länglicher Chip, da steht
    CH340G
    25656A22
    sonst steht nirgendwo etwas. Hab nochmal ein besseres Bild auf den DB link geladen.
     
  13. TPmodding

    TPmodding Administrator Staff Member Administrator

    Messages:
    2,132
    Hardware:
    RPi1/Zero, RPi2, RPi3, +Arduino, +WLED, RPi4
    CH340G ist der serial to usb...also nur die kommunikation zwischen usb und dem chip...hm und auf dem quadratischen nicht lesbar? schade...dann müssen wir durchraten...
    was passiert wenn du "boardinformationen holen" klickst unter werkzeuge in der arduino ide...
     
  14. luckyjacks

    luckyjacks Member

    Messages:
    33
    Hardware:
    RPi3, +Arduino
    BN: Unbekanntes Board
    VID: 1A86
    PID: 7523
     
  15. TPmodding

    TPmodding Administrator Staff Member Administrator

    Messages:
    2,132
    Hardware:
    RPi1/Zero, RPi2, RPi3, +Arduino, +WLED, RPi4
    probier mal arduino uno (denke eher nicht) danach nano mit ATMega328p (Old Bootloader) ggf. die anderen beiden in nano auch
     
  16. luckyjacks

    luckyjacks Member

    Messages:
    33
    Hardware:
    RPi3, +Arduino
    WoW, Nano mit altem Bootloader hat gleich geklappt :)
     
    • Like Like x 1
  17. TPmodding

    TPmodding Administrator Staff Member Administrator

    Messages:
    2,132
    Hardware:
    RPi1/Zero, RPi2, RPi3, +Arduino, +WLED, RPi4
    super, dann können wir das als gelöst markieren?
     
  18. luckyjacks

    luckyjacks Member

    Messages:
    33
    Hardware:
    RPi3, +Arduino
    Leider, nein, die LEDs bleiben aus, und beim Status war alles unverändert..
     
  19. TPmodding

    TPmodding Administrator Staff Member Administrator

    Messages:
    2,132
    Hardware:
    RPi1/Zero, RPi2, RPi3, +Arduino, +WLED, RPi4
    zeig mal deine ino du in arduino geladen haste, bitte per pastebin.com und nicht den code hier posten, danke
     
  20. luckyjacks

    luckyjacks Member

    Messages:
    33
    Hardware:
    RPi3, +Arduino


    hoffe OK so..
     
    Last edited: 25 February 2021