1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

RPi + LibreELEC RPi4 Hyperion Kills HDMI Signal in 4K

Discussion in 'Software Support' started by Mitch7391, 2 December 2019.

  1. Mitch7391

    Mitch7391 Member

    Messages:
    41
    Hardware:
    RPi3
    This one has been driving me nuts and I cannot got a straight answer anywhere. All worked perfectly fine on RPi3 with Libreelec, I’m using apa102 leds and have upgraded to a RPi4 with Libreelec and the moment I install Hyperion, it reboots, I get the colour swirl and then no HDMI signal until I uninstall Hyperion. If I leave it there with no signal, I can see the lights are working to the video playing on the RPi4 screensavers, but no HMDI signal. I am getting desperate here, I feel like I shouldn’t have had to trade my ambilight for 4K...
     
  2. Mitch7391

    Mitch7391 Member

    Messages:
    41
    Hardware:
    RPi3
  3. siz

    siz New Member

    Messages:
    25
    Hardware:
    RPi2
  4. Mitch7391

    Mitch7391 Member

    Messages:
    41
    Hardware:
    RPi3
    I’ll take a look at that, but doesn’t look like there is a solution yet...
     
  5. harun

    harun Member

    Messages:
    105
    Hardware:
    RPi3
    hi,

    i have the same problem. I am using the genuine micro hdmi cable of rasp and the usb c charger of rasp.

    I think to go back the rpi3b
     
  6. mommel.alternative

    mommel.alternative New Member

    Messages:
    2
    Hardware:
    RPi1/Zero, RPi2, RPi3, 32/64bit, +Arduino, +PhilipsHue, +nodeMCU/ESP8266
    Maybe you want to install hyperion via cli after a downgrade to LE 9.1.5
    http://archive.libreelec.tv/LibreELEC-RPi4.arm-9.1.501.img.gz

    curl -# -L --get https://sourceforge.net/projects/hyperion-project/files/release/hyperion_rpi3_le.tar.gz/download | tar -C /storage -xz && \
    curl -# -L --get https://sourceforge.net/projects/hy...se/hyperion.deps.openelec-rpi.tar.gz/download | tar -C
    /storage/hyperion/bin && \
    chmod +x -R /storage/hyperion/bin

    That worked on multiple rpi4 - but remember to suspend the autoupdate of le for now
     
  7. harun

    harun Member

    Messages:
    105
    Hardware:
    RPi3
    The problem is that 4k with hyperion kills the hdmi signal.

    an developper wrote this on the forum of libreelec. So the rpi4 is for 1080 in combination with hyperion

    of course you need to make some settings that 4k movies will made 1080
     
  8. Aesopin

    Aesopin New Member

    Messages:
    1
    Hardware:
    RPi3, +Arduino

    can you link to this
     
  9. harun

    harun Member

    Messages:
    105
    Hardware:
    RPi3
    Check on the forum of libreelec self.