1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SOLVED SK6812 wechselt immer zu weiß zurück.

Discussion in 'German Talk' started by eMd, 17 November 2020.

  1. eMd

    eMd New Member

    Messages:
    28
    Hi,

    Habe heute meine neue Strip in Betrieb genommen. Diese bleibt die ganze Zeit auf weiß stehen.

    Starte ich ein Film oder ein einfaches blaues Bild zur Kalibrierung sehe ich die Farbe kurz bei den LEDs, nach so einer Sekunde wird die LEDs wieder weiß.
    Bei einem Film wechselt es sich die ganze Zeit ab.

    GND strip ist an GND Netzteil und RPI4
    Data in ist an MOSI vom Rpi4.

    Kann mir jemand bei der Fehlersuche helfen?

    Deine Version: 2.0.0-alpha.7-PR#935
     
  2. eMd

    eMd New Member

    Messages:
    28
    Lösung:

    core_freq=500
    core_freq_min=500

    In die config.txt anhängen...

    MfG
    eMd
     
  3. panec

    panec New Member

    Messages:
    15
    Hardware:
    RPi3
    Thx for the tip it fixed the issue with the full white led strip. Now I only have the following issues:
    • first led is always on and is not possible to change its color - always green (tested on hyperion.ng alpha 8 & 9)
    • leads blink with full brightness from time to time, once every couple of seconds
    Had you had any of those issues?
     
  4. eMd

    eMd New Member

    Messages:
    28
    No, since i changed the config All is perfect. But my strip turns off if i didnt use it...
     
  5. panec

    panec New Member

    Messages:
    15
    Hardware:
    RPi3
    I was using level shifter with my previous setup to bump up voltage on the signal rail, but it turns out that it is not needed and was causing the problem. That + common ground and your setting fixed everything. Thx.