1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

STK1160/UTV007 comparison and V4l2 tweaking

Discussion in 'Hyperion Hardware' started by hopfinger, 13 February 2018.

  1. hopfinger

    hopfinger New Member

    Messages:
    2
    Hardware:
    RPi1/Zero, RPi2, RPi3
    I want to share some informations regarding both grabbers.
    First I started with the UTV007, because everybody is recommend it.

    After many hours of calibration and switching settings, I was not really happy with the produced colours of the APA102 Leds. I needed to put Saturation in Hypercon down to 0.2-0.3 to get natural looking colors but due to an oversaturated grabbed image this was only a dirty tweak.

    Since the UTV007 gives no options to tweak in the V4l2-ctl, I tried the STK1160 grabber. https://www.amazon.de/dp/B01FPXCSYM/ref=cm_sw_em_r_mt_dp_U_H8XGAbC037GE4

    With standard v4l2 settings, the image saturation and color looks nearly the same compared to the UT007.

    UTV007 Screenshot
    UTV007.jpeg

    STK1160 with standard settings
    STK1160.jpeg

    and the STK1160 with tweaked settings. The colours arent over saturated and look exactly like the image on my TV.
    STK1160tweaked.jpeg

    These are my tweaked settings in V4l2.
    v4lsettings.jpeg

    I created also a start-script, because all settings will be gone after reboot.
    startscript.jpeg

    I read many post´s that the STK1160 grabber will do problems during startup or after reboot. I cannot reproduce these faults. The grabber is working normal and without any issues.

    After all this UTV007 calibration trouble, I cannot recommend using it.

    Next days I will test the Haupauge grabber which is more than double the price of the STK1160 and should also be supported by V4l2.
    https://www.amazon.de/dp/B003Q2ZA36/ref=cm_sw_em_r_mt_dp_U_uqYGAbFSTQP9T
     
    Last edited: 13 February 2018
    • Like Like x 3
  2. Akriss

    Akriss Active Member

    Messages:
    355
    Hardware:
    RPi1/Zero, RPi2, RPi3, 32/64bit, +Arduino, +nodeMCU/ESP8266
    Interesting,

    It looks like that STK1160 grabber is not NTSC friendly, as it only lists Pal standards. (as seen from the screenshot.)

    Thanks for the info.
     
  3. Emre

    Emre New Member

    Messages:
    20
    Very good feedback and comparison with good supporting attachments. Thank you very much.

    I was thinking UTV007 is life saver (I do not have installed ambilight system yet but still searching) as it is 1 device (compared to STK1160 grabber as you have to have additional HDMI to AV device )but it looks like in reality it might cause issues.
     
  4. LunarBlue

    LunarBlue Member

    Messages:
    88
    Hardware:
    RPi1/Zero
    Can only confirm that the image of these Chinese utv0007 is terrible. Take in mind that the background is nearly white (the Youtube and Netflix logo are white)

    [​IMG]

    just look at this hyperion config, took me a day:

    Code:
    "transform" :
            [
                    {
                            "id"   : "default",
                            "leds" : "*",
                            "hsv" :
                            {
                                    "saturationGain" : 0.4,
                                    "valueGain"      : 1.6,
                                    "luminanceGain"        : 1.0000,
                                    "luminanceMinimum"    : 1.3500
                            },
                            "red" :
                            {
                                    "threshold"  : 0.0000,
                                    "gamma"      : 4.5,
                                    "blacklevel" : 0.0000,
                                    "whitelevel" : 1
                            },
                            "green" :
                            {
                                    "threshold"  : 0.0000,
                                    "gamma"      : 4.5,
                                    "blacklevel" : 0.0000,
                                    "whitelevel" : 0.86
                            },
                            "blue" :
                            {
                                    "threshold"  : 0.0000,
                                    "gamma"      : 4.5,
                                    "blacklevel" : 0.0000,
                                    "whitelevel" : 0.66
                            }
                    }
            ],
     
  5. LunarBlue

    LunarBlue Member

    Messages:
    88
    Hardware:
    RPi1/Zero

    quite interested how the "Hauppauge USB-Live2 Analog Video Digitizer" is performing.

    I ordered one of these https://www.fasttech.com/p/8589800
     
  6. Lyr3x

    Lyr3x New Member

    Messages:
    9
    Hardware:
    RPi1/Zero, RPi2, RPi3, +Arduino, +PhilipsHue
    Any news on this? Very interested in your testing results

    Also: How did you get the stk1160 running? Struggeling with a black picture on my pi zero w
     
    Last edited: 4 July 2018