1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

WLED Talk & Support

Discussion in 'German Talk' started by TPmodding, 10 March 2020.

  1. Drehknopf

    Drehknopf New Member

    Messages:
    19
    Hardware:
    RPi3, +Arduino, +PhilipsHue, +nodeMCU/ESP8266
    Nene Grabber und Co. hätte ich erwähnt. Liegt aber schon auf dem Plan.

    @TPmodding die liegt zwischen meinem Pi 4 und meinem ESP. Mit nen Abstand von vllt 2metern. Hab in meinem WLAN aber noch nen pi-hole zu laufen separat am Pi 3. der war zum testen aber aus.

    3module (ESP+Levelshifter) mit WLED hatte ich an den Streifen auch dran, das gleiche Ergebnis. Ich kann es mir nur mit der baudrate erklären.

    Kann mir nicht vorstellen das meine fritzbox fertig ist, am Rechner läuft es ja.

    Mit den Einstellungen in der webgui von alpha wurde auch schon experimentiert.

    In langsamen Bildern läuft es halbwegs sobald es etwas hektischer wird ( action, horror-film ) kommen die LEDs garnicht mehr hinterher
     
  2. TPmodding

    TPmodding Administrator Staff Member Administrator

    Messages:
    2,132
    Hardware:
    RPi1/Zero, RPi2, RPi3, +Arduino, +WLED, RPi4
    okay, der pi und dein wemos sind beide im wlan? pi-hole sollte nicht stören...

    ich weiss nicht ob die baudrate im wlan verbessern würde... ich GLAUBE das ist nur für die serielle schnittstelle...lass mich aber gerne eines besseren belehren...

    in WLED wenn du auf info klickst, siehst du die wlan infos, was sagt den signal strength bei dir?
     
  3. pclin

    pclin Active Member

    Messages:
    634
    Hardware:
    +nodeMCU/ESP8266
    OK, auch wenn es immer noch einige User gibt die classic verwenden, oder noch die Einstellungen dafür kennen. ;)
    Ich verstehe aber auch das ihr nur noch hyperion-ng supported.

    Bei mir läuft das am besten mir SK6812 mit Baudrate 800.000.

    gruß pclin
     
    • Like Like x 3
  4. TPmodding

    TPmodding Administrator Staff Member Administrator

    Messages:
    2,132
    Hardware:
    RPi1/Zero, RPi2, RPi3, +Arduino, +WLED, RPi4
  5. pclin

    pclin Active Member

    Messages:
    634
    Hardware:
    +nodeMCU/ESP8266
    In der 'alten' Version habe ich das ausgetestet, weniger oder mehr als 800.000 war eindeutig schlechter.

    gruß pclin
     
    • Like Like x 1
  6. Drehknopf

    Drehknopf New Member

    Messages:
    19
    Hardware:
    RPi3, +Arduino, +PhilipsHue, +nodeMCU/ESP8266
    sorry, musste gerade erstmal alles hochfahren, hab mal Spaßenshalber die Version 0.10.0 draufgeflasht, aber irgendwie noch keine Verbesserung.

    Signal strength ist bei mir 100% ( -36 dBm ) also alles im grünen Bereich.

    Aber schaut mal hier:

    @TPmodding @pclin

    https://github.com/Aircoookie/WLED/issues/1173

    Hier wird nämlich darüber gesprochen, wenn ich es richtig verstanden hab, könnte dieser Fall zumindest Ähnlichkeiten zu dem jetzigen haben.

    Ach siehst, hab in Hyperion die untere Leiste deaktiviert so das ich anstelle von 194, auf 130 Leds komme

    Grüße
     
  7. TPmodding

    TPmodding Administrator Staff Member Administrator

    Messages:
    2,132
    Hardware:
    RPi1/Zero, RPi2, RPi3, +Arduino, +WLED, RPi4
    ok gut aber dann musst du beachten das du dein wemos auch über usb anschliessen musst...ist dir bewusst? da dann adalight einspringt
     
  8. Drehknopf

    Drehknopf New Member

    Messages:
    19
    Hardware:
    RPi3, +Arduino, +PhilipsHue, +nodeMCU/ESP8266
    Jetzt, wo ich es nochmal nachgelesen hab, ja. Aber das ist nicht der sinn des Erfinders. Sollte alles ohne großen schnick schnack sein. Wenn ich das Problem nicht gelöst bekomme, muss ich zwangsläufig komplett an den PI gehen.

    Grüße
     
  9. TPmodding

    TPmodding Administrator Staff Member Administrator

    Messages:
    2,132
    Hardware:
    RPi1/Zero, RPi2, RPi3, +Arduino, +WLED, RPi4
    wie hoch ist den deine latenz?
     
  10. Drehknopf

    Drehknopf New Member

    Messages:
    19
    Hardware:
    RPi3, +Arduino, +PhilipsHue, +nodeMCU/ESP8266
    Locker 2 Sekunden. Oder kann man es irgendwo auslesen?

    In der Glättung zb:

    Zeit: 50
    Aktualisierungsfrequenz:20
    Interpolationsfrequenz:25
    Ausgabefrequenz:25

    Geht in die richtige Richtung schaut nur etwas merkwürdig aus.

    Ich werd mir mal nen ESP32 besorgen. Probier es damit mal aus.Bis dahin erstmal.

    Grüße
     
    Last edited: 24 January 2021
  11. DayOne

    DayOne Active Member

    Messages:
    272
    Was für ein Grabber nutzt du denn und welche Einstellungen?
     
  12. Drehknopf

    Drehknopf New Member

    Messages:
    19
    Hardware:
    RPi3, +Arduino, +PhilipsHue, +nodeMCU/ESP8266
    @DayOne Ahoi...

    Nichts davon. Die Kommunikation besteht ausschließlich zwischen Pi und ESP. Hatte ich aber schon erwähnt.

    Wie gesagt ich werds mal mit nen Esp32 probieren, soll ja mehr (Arbeits) Speicher haben.

    Versuch macht klug...

    Grüße
     
  13. DayOne

    DayOne Active Member

    Messages:
    272
    Also nutzt du den internen Grabber.
    Dann weiß ich leider auch nicht woran es liegen kann sorry.
     
    • Like Like x 1
  14. pclin

    pclin Active Member

    Messages:
    634
    Hardware:
    +nodeMCU/ESP8266
    Einen spürbaren Unterschied soll es zwischen ESP8266 und ESP32 nach nicht geben.
    Die Vorteile vom ESP32 (Arbeits) Speicher usw. werden von WLED meines Wissens nach nicht ausgeschöpft.

    gruß pclin
     
    • Like Like x 1
  15. Drehknopf

    Drehknopf New Member

    Messages:
    19
    Hardware:
    RPi3, +Arduino, +PhilipsHue, +nodeMCU/ESP8266
    @pclin das ist soweit korrekt.

    Jedoch muss ich ja mit irgendwas anfangen um das Problem zu lösen...

    Bevor ich den ESP bestell werd ich morgen mal Libreelec neu aufsetzen.

    Kann doch nicht sein, das es nicht so recht will...

    Grüße
     
  16. pclin

    pclin Active Member

    Messages:
    634
    Hardware:
    +nodeMCU/ESP8266
    Ich habe schon davon gelesen das es je nach System mit internen Grabber zu Problemen kommen kann.
    Kann aber weiter nichts dazu schreiben, da ich ja keinen RPI oder Libreelec verwende und zu 90% das 'alte' nicht mehr supportete System verwende.

    gruß pclin
     
    • Like Like x 1
  17. pclin

    pclin Active Member

    Messages:
    634
    Hardware:
    +nodeMCU/ESP8266
    Grundsätzlich empfehle ich aber immer für hyperion die Verwendung eines Splitters und Digitalen HDMI > USB Grabber.
    Selbst bei meiner Box mit Amlogic S922X und sehr gutem internen Amlogic Grabber, siehe meine Signatur.

    gruß pclin
     
    • Like Like x 2
  18. Drehknopf

    Drehknopf New Member

    Messages:
    19
    Hardware:
    RPi3, +Arduino, +PhilipsHue, +nodeMCU/ESP8266
    Ja, die Planung steht schon...Entsprechende Hardware hab ich schon auf meiner Liste. Das Problem hat sich nun auch in Rauch aufgelöst.
    Hab die Leds vom TV einfach mal Rechner verbunden, brauchte ja nur die IP und die Anzahl der LEDs ändern. Und siehe da, kaum spürbare Latenz. Die Einstellungen von meinen APA102 ( Monitor )übernommen.

    Das ist aller Wahrscheinlichkeit nach der Interne Grabber.

    Grüße
     
  19. Daniel_

    Daniel_ New Member

    Messages:
    1
    Hardware:
    RPi1/Zero, RPi2, RPi3, 32/64bit, +PhilipsHue
    Einen schönen Abend,

    ich habe da mal eine Frage bzgl. WLED. Im englischen Wiki wird in die Dataleitung ein 62Ohm Widerstand eingelötet und im deutschen Wiki ist an selbiger Stelle ein 470Ohm Widerstand, welchen muss ich denn nun nehmen? Und weiter bin ich mir nicht ganz sicher wieviel Watt der Wiederstand haben sollte, die gängigsten zum basteln scheinen ja 0,25W und 0,6W zu sein.

    Vielen Dank schon einmal.
     
  20. pclin

    pclin Active Member

    Messages:
    634
    Hardware:
    +nodeMCU/ESP8266
    Deutsche Übersetzung des WLED Wiki. Hier geht es zum Wiki.

    Keine Garantie für Aktualität, die englische Ausgabe des Wikis ist immer maßgeblich.

    Vielen Dank an @pclin-dream, der alle Seiten des Wiki übersetzt hat!

    gruß pclin

    ps.
    bisher keine Zeit gefunden...