Posts by borussemd

    Hi,


    zu 1:

    60 LEDs pro m geben halt ein deutlich weicheres Farbbild, als 30. Nur wirst du bei einem 82" Monster mit 3m nicht weit kommen. Ich hab an meinem 55" 3,2m SK6812. Ein toller Streifen. Aber auch etwas teurer. Lohnt aber definitiv. Aber auch so würde ich die Streifen nicht mischen. Demnach musst du so oder so nach ordnern. Ich würde dann entweder WS2812b aufstocken, oder direkt SK6812 nehmen, da die neben RGB auch einen weißen Anteil in jeder LED haben.


    zu 2 und 3:

    HDMI Switch mit 4k, CEC und Downscaler zwischen AVR und TV. Von da mit einem digitalen HDMI2USB Grabber (kostet ca 11,- €) an den Pi.

    Bonusantwort:
    Ich würde den LED Streifen nicht an den Pi sondern an einen WLED Controller (ich hab ESP32 und ESP8266 getestet und die ESP32 gingen aufgrund Verzögerungen zurück) hängen, um die Streifen außerhalb von Hyperion ebenfalls smart ansteuern zu können.


    Gruß

    bmd

    Wieder ein kleines Update:
    Nachdem ich Hyperion NG in verschiedenen Installationen getestet habe (HyperBian, Pi OS, Pi OS light) und immer etwas Schwierigkeiten bekam, sobald weitere Dienste auf den Pi hinzukamen, habe ich nun die wohl einfachste Art und Weise für mich gefunden, Hyperion NG mit anderen Diensten zu nutzen.

    Ich hatte ja von Anfang an vor, eine Smart Home Zentrale einzusetzen, sobald Hyperion stabil läuft, um es automatisieren zu können.

    Seit nun 4 Tagen habe ich Home Assistant OS auf meinem Raspberry Pi 4 installiert.

    HA bietet ein Addon, welches mit ein paar wenigen Klicks Hyperion in der aktuellen Alpha 10 bereitstellt und vollautomatisch vorbereitet, sodass man sofort in die Web GUI gelangt, um die Konfigurationen vorzunehmen.

    Die Kombination HA OS mit Hyperion Addon läuft bei mir so stabil, wie es nur HyperBian ohne Zusatzdienste tat.

    Dank HA OS habe ich nun eine Automatisierung meines Ambilights, abhängig vom Sonnenstand.

    Sobald ich meinen TV einschalte prüft HA ob die Sonne bereits untergegangen ist. Wenn ja, schaltet sich Hyperion ein. Sollte dies nicht der Fall sein bleibt Hyperion aus.

    Dies war mein Grundgedanke von Anfang an.
    Unterwegs habe ich erfreut festgestellt, dass der Pi 4 (jedenfalls meiner, ohne lästiges Firmware flashen, etc)) out of the box Boot von USB unterstützt. Somit läuft HA OS nun auf einem 240 MB/s USB 3.1 Stick und ich bin sehr zufrieden mit der Performance des bisherigen Systems.
    Mal schauen, was sich noch so alles bei mir zum Automatisieren findet :D

    Du könntest mal testen, ob die Weiterleitung in die VM vllt das Problem auslöst. Manche USB Redirectors sind nicht besonders sauber programmiert. Daher schmieren die Dienste gerne mal ab. Leider bin ich mit der Umgebung selbst nicht vertraut, ich kenne aber einige andere virtuelle Umgebungen und da kann dies schonmal der Grund sein.
    Weiteres, was ich gestern rausgefunden habe, solltest du einen Grabber nutzen, der in Hyperion mit YUVY läuft, dann musst du den an einen USB3 Anschluss anschließen, da YUVY ggü. mjpeg einen erhöhten Datenstrom hat. Läuft solch ein Grabber an einem USB2 Anschluss, kann das zu Abstürzen führen.

    Nunja...ich werde das Thema hier als erledigt ansehen. Hab jetzt nochmal auf HyperBian umgestellt und da lief Hyperion 1 Std fehlerfrei.

    Mal schauen, ob ich Home Assistant auf HyperBian installiert bekomme.

    Aber für hier lag der Fehler irgendwo in der Konfig, den ich aber vermutlich nie gefunden hätte.

    kurzen USB Verlängerung

    Das versuche ich doch mal direkt. Schaue eh jetzt Fußball, da kann ich 2 Std beobachten.


    Und wieder Absturz nach 10 Minuten. Das ist zum verrückt werden.

    3 Minuten später stürzt der Pi komplett ab. Confusing.


    Ich werde nachher noch mal HyperBian installieren und mal erst nur Hyperion testen. Mal schauen, vllt liegt es wirklich irgendwo in der Hardware.


    JumpigJoe es scheint die Glättung zu sein. Nach dem letzten Crash ist Glättung aus und läuft jetzt schon 20 Minuten durch.

    Ich glaube es liegt am Grabber. Und zwar das Gewicht scheint am USB Port zu ziehen. Eben (Log 12:29 Uhr) fiel Hyperion kurz aus, dann hab ich den Grabber angefasst und direkt fiel der Raspberry komplett aus (Log 12:33 Uhr)
    Da der Raspy flach liegt und der Grabber mit Kabel etwas hinten runter drückt, vermute ich hier das Problem. Hab den Grabber nun etwas fixiert, sodass er am Port nicht mehr zieht.


    Aber um auch die anderen Fragen zu beantworten:
    Auflösung 640x480 px

    20 FPS

    Bildverkleinerung 8


    Beim erneuten Ausfall um 12:38 Uhr fiel nur Hyperion aus.


    Im Moment scheint es so, als würde Hyperion kontinuierlich alle 10 Minuten ausfallen.

    Hi allerseits,


    Ich habe heute meinen Raspberry Pi 4 4GB neu konfiguriert.

    Installiert habe ich Raspberry Pi OS, danach Home Assistent und Hyperion NG. Home Assistent und Hyperion laufen als Dienste mit Autostart.

    Ich habe zuerst Hyperion konfiguriert. Während ich dann Home Assistent konfiguriert habe, habe ich auf dem Fire TV 4k Stick Youtube mit einem 8 Std Ambilight Video laufen lassen. Das ganze lief 1,5 Std problemlos.

    Als ich mit Home Assistent fertig war habe ich mir auf dem Fire TV 4k Stick einen Film auf Netflix an gemacht.

    Bei dem Film passierte es allerdings alle 10 bis 20 Minuten, dass Hyperion und oder der ganze Raspberry abstürzte.

    Nun läuft das Youtube Video schon wieder eine ganze Weile und das System läuft wieder fehlerfrei.

    Kann mir jemand sagen, wo hier der Fehler liegen könnte?

    Da sich nur die genutzte App ändert, kann ich mir das Verhalten leider nicht selbst erklären.


    Edit: kaum gefragt stürzt es auch bei Youtube ab.

    Das ist mir aber die ganze Zeit passiert. Egal ob mit Pi OS lite und nur Hyperion, oder mit Hyperbian, auch mit LibreElec.

    Pi wird mit dem originalen 5V 3A Netzteil betrieben und außer dem USB Grabber ist nichts angesteckt.


    Danke und Gruß

    bmd

    Servus liebe Freunde des bunten Lichtes,


    meine Männerhöhle nimmt langsam Gestalt an. Die technische Basis ist geschafft. Doch nun stellt sich mir die nächste Frage...

    Wie gestalte ich die Wand hinter dem TV, um das Ambilight noch besser in Scene zu setzen?

    2016 hatte ich die Wand hinter dem TV (in einer anderen Wohnung) auf 2,6m x 1,8m Anthrazit gestrichen, mit einer Schöner Wohnen Matt Farbe. Das war schon nice.

    Vllt kann ich aber von euch etwas Inspiration erhalten.

    Ich bin momentan für alles offen. So schaue ich nach 3D Wandpaneelen (diverse Optiken), oder Vliestapeten (mit und ohne Muster, auch Abstrakt), oder halt wieder den Bereich streichen...

    Gerne könnt ihr mir eure Settings mal zeigen.


    Danke und Gruß

    Danke wladi

    Ich mein das richtige und laber das falsche...Dass das LPV-100-5 12A hat war mir tatsächlich bewusst, aber da es momentan bei Amazon etwas dauert bis das geliefert werden kann, hab ich nach dem nicht isolierten 5V 20A NT geschaut. Und hier werf ichs dann durcheinander.

    Edit:

    und während ich das von mir gebe seh ich bei Amazon den Restock *facepalm*

    Tja, leider lief meine Installation mit HyperBian ins leere. Hab jetzt mal Pi OS Lite drauf gemacht und versuche ioBroker und Hyperion NG via SSH drauf zu packen.


    JumpigJoe

    Brauch ich nur die ersten beiden Codezeilen? Oder auch die 3.?

    Hat sich erledigt. hab das YT Video von TPmodding gefunden :D

    JumpigJoe

    Grüß dich,

    ich muss hier mal einhaken...Da mein Ambilight nun wunderbar funktioniert, kommt der nächste Schritt...Automatisierung.

    Hab im Forum schon ein paar relevante Threads gefunden, aber ich muss an der Basis anfangen und das wäre das OS:
    Wenn ich ein per Astrodaten gesteuertes Ambilight via ioBroker erzeugen will, wäre doch OpenELEC das beste OS für Raspi 4 - Hyperion.NG - ioBroker und evtl Blockly...Oder?

    Ich korrigiere mich selbst...Pi OS Lite ist schlank und ausreichend und somit kann ich bei HyperBian bleiben :)

    Kurz hier noch als Feedback:
    Mit empfohlenen Einstellungen und dem Wechsel von ESP32 auf ESP8266 läuft mein Ambilight erste Sahne. Kein wahrnembarer Zeitversatz zwischen Bild und Licht. Sehr smooth alles.
    Optimierungspotential gibt es noch im genutzten LED Netzteil (das alte summt inzwischen etwas zu laut und wird noch erneuert) und der gesamten Verkabelung, jetzt wo alles funktioniert. Vllt bau ich den Raspi auch noch auf Autostart-Stopp um. Mal schauen.
    Danke an alle, die mir bis hier her geholfen haben.