Posts by Mike72

    Hört sich eindeutig nach HDMI-Handshake- Problem(en) an. Ich kenne den VSP01202 zwar nicht, aber da sollte es 'ne Einstellung „Learning EDID from TV“ oder so ähnlich geben. Downscalen von 4K zu 1080p an HDMI 2 für den Grabber kann das Ding nicht?

    Entweder einen Rahmen aus hölzernen Dreiecksleisten mit 45 Grad-Winkel nach aussen bauen, oder den TV auf eine Holzplatte montieren und darauf die Dreiecksleisten kleben, oder direkt auf den TV kleben. Variante drei wird aber kaum jemand machen der sich gerade einen neuen Fernseher gekauft hat (Garantieverlust).

    Die „Boxen“ sind eigentlich für Zocker gedacht, die ihr Gameplay live ins Netz streamen oder aufzeichnen wollen. HDCP sollten die eigentlich unterstützen, ob dann allerdings Netflix, Prime und Co., darüber abgegriffen werden kann musst du selber herausfinden, da DRM geschützt. CEC unterstützen 99% der Capture Cards mit Loop Out nicht, kann aber, wenn du löten kannst nachgerüstet werden.

    How long is the data wire between RPi and LED stripe? If too long (more than 0.5 meter) the data cable works like an antenna and get influences of WLAN, Bluetooth and other radio frequencies. In most cases a shielded cable could help. Maybe also you need a level shifter (3.3V to 5V).

    Mike72


    …gebrückt wurde die vermeindliche defekte LED von Dout zu Din.

    Angenommen ab der 12. LED geht nix mehr. D Out von LED 11 zu D In von LED 13 überbrücken. Wenn du ein Multimeter besitzt kannst du testweise auch mal von den Kupferpads zu den LED-Pins auf Durchgang messen. Kommt eher selten vor, kann aber vorkommen, dass die Leiterbahnen von 5V, GND oder Data irgendwo unterbrochen sind.

    Schaltbare Steckdose heißt…?

    Der RPi wird wahrscheinlich durch „Stecker ziehen“ ausgeschaltet und nicht anständig heruntergefahren. In 99% der Fälle tödlich für die SD-Karte.

    Da ist wahrscheinlich die erste LED, die nicht leuchtet defekt. Leicht herauszufinden, indem bei der vermutlich defekten LED die Daten-Pins mit einem Jumperkabel überbrückt werden. DI auf DO, bzw. CI auf CO.

    Warum nimmst du nicht gleich einen digitalen Grabber bzw. Video Capture Card?

    Vermeidet die Wandlung Digital→Analog und Analog→Digital. Bessere, kräftigere Farben an den LEDs nebenbei.;)

    Z.B.: oder mit Splitter

    1. YUYV ist unkomprimiert, MJPEG ein komprimiertes Format. Meine Erfahrungswerte: Wenn deine Capture Card bzw. RPi USB 3.0 tauglich ist kannst du beide Formate auswählen, bei USB 2.0 nur MJPEG.


    2. Ist eigentlich selbsterklärend:

    Die Auflösung in Pixel die der Grabber an den RPi ausgeben soll.

    720x480 Pixel bei 30 Fps reichen an und für sich, je nach CPU-Auslastung.


    3. Hast du z.B. 25 LEDs am oberen Bildschirmrand, könntest du die Size Decimation auf bis zu 25 setzen.

    Die Bildschirmbreite wird damit in 25 Teile geteilt, die dann auf die LEDs gemappt werden.

    Wenn du z.B. 1000 Bildschirmpunkte hast, aber nur 25 LEDs, deckt jede LED 40 Punkte ab, die gemittelt werden. Also höhere Auflösung hilft nicht bei Genauigkeit und Performance für ein Ambilight.


    (Zitat Lord-Grey)

    Das übliche Problem mit blassen bzw. ausgewaschenen Farben wie bei Dolby Vision bzw. HDR dürftest du ja nicht haben, wenn du "nur" 1080p Equipment hast...?

    Als erstes würde ich mal den HDMI zu AV 2160px Konverter und den analogen Video Grabber Chipsatz UTV007 gegen eine digitalen tauschen. Damit hast du auch mit den APA102 viel bessere Farben. Am besten hier mal vorbeischauen.

    Weiters wirst du um eine komplette Farbkalibrierung nicht herumkommen, die Konfiguration kann vom alten Hyperion Classic leider nicht auf NG übernommen werden. Hier dazu alle Informationen.

    Kleiner Tipp noch: Am besten oben rechts auf "Experten-Modus" umstellen, da gibt's viel mehr Einstellungsmöglichkeiten.

    Könntest du bitte von dem ezcoo Grabber with Loop die üblichen Ausgaben posten.

    Mach' ich, wenn ich wieder an den 'rankomme. Der Ezcoo ist bei meinem Bruder im Einsatz.

    Bei DV wird das Bild wohl Pink sein und bei HDR ausgewaschen?

    Genau, ist auch der übliche MS2109 drinnen.

    Könntest du auch ein Bild der EDID Einstellungen posten, die sind wohl nur auf der Unterseite des Geräts...


    Soweit ich mich erinnere steht der auf "Learning EDID from HDMI Out".

    Wie ist das mit CEC und ARC?

    Ging beides von Haus aus nicht. CEC wurde mit einer Drahtbrücke von HDMI IN Pin13 ←→ HDMI OUT Pin13 nachgerüstet.

    500mA sollte für den Grabber aber reichen

    Normalerweise für diesen Typ (USB-Stick Form) schon, ist schon richtig. Ich habe mich aber mit verschiedenen Grabbern, bzw. Video Capture Cards die derzeit am Markt erhältlich sind näher beschäftigt und für verschiedene Projekte getestet. Ergebnis:

    Die einfachen (diese in USB-Stick Form) ziehen von 300 - 800mA (!). Die mit integriertem Splitter, bei denen das HDMI-Signal durchgeschliffen wird, ziehen zwischen 50 und 300mA, wobei da meistens eine eigene microUSB-Buchse zur Stromversorgung vorgesehen ist. Einige davon wurden sogar nur durch die HDMI 5V versorgt, obwohl diese laut Specs nur 50mA zur Verfügung stellt...:/. Bei anderen wurde einfach eine Diode von USB 5V+ zu HDMI 5V+ verschaltet, was auch nicht gerade gut sein kann. Diese hatten übrigens auch die meiste Wärmeentwicklung. Ich glaube jeder Hersteller kocht da sein eigenes Süppchen, weil die externe Beschaltung ziemlich unterschiedlich, der Chip zu 99% aber immer der gleiche ist (MacroSilicon 2109).

    Ich habe übrigens ziemlich gute Erfahrungen mit diesem gemacht. Kombi aus Splitter/Capture Card, USB 3.0, EDID kann konfiguriert werden, Ausgabe YUYV oder MJPEG. Nachteile: Die üblichen Einschränkungen bei DV und HDR. Stromversorgung über USB 3.0 möglich und beim einstecken vom microUSB (Power) wird diese Verbindung automatisch unterbrochen.:thumbup:

    Aber ich glaube jetzt wird's zu Off Topic ;).

    Ich häng' mich hier mal an...


    GreenDie: Wenn du einen RPi Zero hast kann es sein, dass dein USB Capture Device von Haus aus zu wenig Strom bekommt,

    da die USB-Ports standardmäßig auf 500mA limitiert sind. Abhilfe schafft meistens die Zeile max_usb_current=1 in /boot/config.txt einzufügen. Bin mir aber auch nicht sicher ob das beim RPi Zero funktioniert, da der wieder andere USB Controller hat.