Posts by jochenf

    Hallo,


    gute Arbeit, Danke.


    Leider zu früh gerfreut, muß gerade mit Entsetzen feststellen, das du ja das "alte" hyperion nutzt und ich hyperion.ng. Hätte ich in meiner .json Variablen wie saturationGain oder luminanceGain entdeckt, hätte mich sicherlich auch der Spieltrieb gepackt. :)


    Die Config für .ng sieht leider etwas anders aus, einen "transform" Bereich und ein "saturationGain" gibt es in dieser leider nicht.


    Mal schauen, hau ich mir die "alte" Version vielleicht paralell mit drauf.


    Kurz und knapp zur ha-bridge: Simuliert für Alexa eine Hue-Bridge, kann lokale scripte auf dem Raspy dann per "schalte hdr ein" ausführen


    Grüße


    Micha


    p.s. - werde mich mal an den Beitrag im Git anhängen, vielleicht da ja was draus


    https://github.com/hyperion-project/hyperion.ng/issues/622

    Hi,


    kannst den Thread gern kapern, dann bleibt er den Entwicklern vielleicht im Auge. ;)


    Dein Howto ist zwar wunderschön, die für mich einzig wichtige Info, wie eigentlich deine .json Konfiguration für HDR aussieht, kann ich darin aber leider nicht finden. Meine Versuche mit v4l2-ctl waren irgendwie auch nicht erfolgreich, es sah danach aus, dass hyperion und das Screenshottool dieses einfach ignoriert.


    Das was du "umständlich" über die Fernbedienung machen musst, könnte ich dank ha-bridge ja alexa machen lassen.


    Grüße


    Micha

    Kein Problem, müsste ja auch über Hyperion-Remote funktionieren. Da lass ich das Dank ha-bridge einfach Alexa machen. ;)


    Edit:


    Mit


    /usr/local/share/hyperion/bin/hyperion-remote -I "Samsung Ambilight" --sourceSelect 110


    funktionierts. :thumbsup:


    Edit 2:


    Manchmal steht man aber auch total auf dem Schlauch, lässt sich mit den Prioritäten doch wunderbar realisieren. Für den Monitor ist der USB Capture nun komplett deaktiviert für den TV hat er die 170. Den Screencapture am PC gebe ich einfach beim Start die 180 mit.


    grüße


    Micha

    Ja, das geht. Über Fernbedienung kann ich die Quellen routen wie gewünscht. Habe auf dem TV Live und auf dem Monitor HyperCap.
    Wenn ich HyperCap erstmailg starte, landet es aber erstmal auf beiden, muß dann auf dem TV das USB Live Capture über Fernbedienung erstmal manuell starten.


    Gibt es da vielleicht einen bequemeren Weg, dass der Hyperion Screencapture garnicht erst auf dem TV landet?

    Nein,


    nicht ganz.


    Quote

    Du hast einen usbgrabber, der das bild für den TV ausgewertet und die leds am TV steuert...zusätzlich soll das selbe Bild am Monitor ausgewertet werden und die LEDS am Monitor steuern...?


    Dies funktioniert ja soweit unter ng schon.


    Ich möchte aber das Bild was von "Hyperion Screen Capture" per UDP kommt an den Monitor schicken, während der TV weiterhin das Bild vom USB Grabber bekommt.

    Hallo,


    das "alte" hyperion konnte ich doch einfach ein zweites mal mit einer eigenen json Konfiguration starten. Bei hyperion.ng läuft das ja irgendwie etwas anders.
    Hyperion.ng ist es anscheinend egal welche .json ich als Startoption mitgebe, es nutzt einfach seine .db aus dem .hyperion Ordner. Lege ich im Webinterface eine zweite Instanz an, kann ich diese bezüglich LED Konfiguration ja wunderbar anpassen und parallel zur primären Beleuchtung laufen lassen. Bei mir also 1x TV mit 256 LED's + 1x Monitor mit 75 LED's. Die für mich eigentlich wichtige Optionen "Aufname Hardware" und "Netzwerk" gelten dann aber wieder global für beide Instanzen. Ein Forwarder ginge also nicht.


    Um mein eigentliches Anliegen USB Graber steuert TV, zweite Version per UDP nur den Monitor umzusetzen, stehe ich nun irgendwie auf dem Schlauch.


    Hat da jemand vielleicht ne Idee, wie ich dies umsetzen könnte?


    Danke und Grüße


    Micha

    Hallo,


    sieht gut aus, ist nun wieder alles schön bunt. :)




    Grüße und vielen Dank für deine Mühe


    Micha

    Hi,



    Danke für die Rückmeldung. Habe mal noch etwas in Photoshop rumgespielt. Vielleicht ist das Ganze mit der Tonwertkorrektur sogar schon etwas übertrieben.
    Man könnte vielleicht einfach die Farbe, die letztendlich bei der LED landet, für verkorkstes HDR am Eingang, anders berechnen.
    Laienhaft müsste die Sättigung in einem verkorksten HDR Bild wegen nicht stattgefunden Tone Mappings ja nur maximal 1/4 des Maximalwerts von 256 sein. Damit die LED wieder die richtige Farbe bekommt, würde ich den gescrappten Wert einfach mit 4 multiplizieren und damit hoffentlich noch unter 256 landen.


    Das Hyperion das Ganze selbst zu unterscheiden weiß, muss ja gar nicht unbedingt sein. Quasi einfach ne zweite Hyperion Version deren Farbberechnung auf das verkorkste HDR Bild abgestimmt ist.
    Oder vielleicht während der Laufzeit automatisch reagieren, wenn Sättigung des Eingangssignals längere Zeit unter 64? bleibt, dann mit 4 multiplizieren.



    Grüße



    Micha

    Hi,


    zwei Tage bei und schon der nächste Beitrag von mir. ;)


    Bezüglich der Problematik mit den blassen Farben bei HDR Zuspielung hätte ich mal noch eine Frage.


    Würde die Rechenleitung des Raspi's (4) möglicherweise dafür ausreichen, am gegrappten Bild eine "Gamma-" oder auch "Tonwertkorrektur" durchzuführen? Quasi wie in Adobe Premiere wenn man *-Log Videos von ner Sonny oder Panasonic DSLR graded.


    Die korrekten Farben ließen sich damit aus einer verkapten und blassen HDR Aufnahme ja halbwegs wiederherstellen und mit dem Ambilight wäre auch alles wieder o.k.


    Danke und Grüße


    Micha

    Hallo,


    kein Problem. Werde derweil mal etwas damit rumspielen, wusste garnicht, dass man das Ganze auch darüber beeinflussen kannn.




    Was mir gerade selbst daran auffällt, dass bei Format NTSC gesetzt ist, obwohl in meiner Konfig PAL steht.


    Stelle ich vor dem Start einmalig per :~$ v4l2-ctl --set-standard 0x000000ff manuell auf PAL, funktioniert NG einwandfrei, egal wie offt ich danach das Programm starte oder stoppe.



    Danke und Grüße


    micha

    Hallo,


    bevor ich in meinen ersten Beitrag um Hilfe bitte, erst mal ein großes Lob für das Projekt und vor allem die Weiterentwicklung zu hyperion.ng.


    Nun zu meinem Problem:


    Neben der originalen Hyperion Version, habe ich auf meinem Raspi 4 auch das aktuelle Hyperion.ng vom github installiert.


    Ich greife bei beiden Versionen auf den verbreiteten USB Grabber Fushicai UTV007 zu. Während das "allte" Hyperion das Bild korrekt abgreift und meine LED's bunt leuchten lässt, habe ich mit hyperion.ng nur ein s/w Bild. Die LED's leuchten demzufolge nur in weiß. Auch Screenshots die ich über hyperion-v4l2 anfertige, sind nur in s/w. Unabhängig davon, was in der Konfiguration für Format bzw. Farbraum angebe oder als Option für den screenshot mittels hyperion-v4l2 mitgebe.
    Da hyperion-v4l2 die eigentliche Hyperion Konfiguration nach meinen Verstehen ja ignoriert, schließe ich einen Fehler in der .json aus.


    Wenn ich jedoch vor dem Start von hyperion.ng das originale hyperion kurz starte und danach wieder beende, liefert auch hyperion.ng und das integrierte hyperion-v4l2 bunte Bilder!


    Auch wenn ich nach nem Neustart Hyperion garnicht starte und nur mit dem Screenshottool probiere, selbiges Fehlerbild.


    Grüße


    Micha