1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Tips and tricks for near black flickering/inaccuracies and blackbar detection on static scenes?

Discussion in 'Hyperion General' started by osen, 4 December 2020.

  1. osen

    osen New Member

    Messages:
    2
    Hardware:
    RPi3, +Arduino
    My setup is the following:

    RPi3B running LibreELEC 9.2.6 and Hyperion-ng 2.0.0-alpha.9 (dispmanx platform capture)
    Arduino Nano w. adalight sketch
    WS2812B LEDs

    I've spent quite a bit of time calibrating and I would say I'm about 80-90% happy with medium bright to bright scenes. I don't think it's going to get much better with these LEDs. Fully dark (black) background scenes with defined light sources are OK but what I can't figure out how to fix is dark, low contrast scenes with a lot of near black colours. I get a lot of "threshold" flickering (which smoothing doesn't seem to be able to get rid off) and very inaccurate colours here. Often very saturated green on brownish colours and saturated blue on dark grey, for example.

    I can't seem to get rid of these "artifacts" no matter how much I tweak gamma and brightness settings and they are very distracting. Do I need to change something in my hardware setup to fix this or is it possible to fix with calibration? I would rather the LEDs stayed off completely under a certain threshold but there doesn't seem to be such a value? Only way seems to be to crank the gamma values up or cut the brightness massively but this causes all sorts of different issues and lower quality experience overall. Can't seem to find a balance here.

    The second thing I'm having an issue with is blackbar detection. As of now I'm using the letterbox mode and while it works very well for detecting black bars, the issue is that on static scenes it seems to keep going indefinitely until it finds a light source. So if a scene is "static" for more than a second or two, it will set a ridiculous blackbar and LEDs can go from fully off to very bright in the middle of such a static scene and it's super distracting.

    I have tried setting "Inconsistent frames" to extremely high values but it doesn't seem to make a difference. Maybe I'm not understanding what this value does? I've also tried all the different detection modes but they seem to behave more or less the same in regards to this particular issue.
     
  2. jncanches

    jncanches New Member

    Messages:
    1
    Hardware:
    RPi1/Zero
    Hi,

    I have the same problem concerning near dark scenes with flickering LEDs. Can't get rid of this behavior. I think the better option would be a percentage under which LED stays off.
     
    • Agree Agree x 1
  3. jeroen warmerdam

    jeroen warmerdam Raspberry 3B / APA102 / Hyperion.NG relaisbox

    Messages:
    397
    Hardware:
    RPi3
    if you adjust backlight treshold to 4 and colour tresholds to 10 it should help already.
    also boosting gamma values to 2.5 each channel.

    thats how i set it.
    i post some settings of my setup
     
  4. jeroen warmerdam

    jeroen warmerdam Raspberry 3B / APA102 / Hyperion.NG relaisbox

    Messages:
    397
    Hardware:
    RPi3
  5. jeroen warmerdam

    jeroen warmerdam Raspberry 3B / APA102 / Hyperion.NG relaisbox

    Messages:
    397
    Hardware:
    RPi3

    i had this before these settings that i posted;

    WhatsApp Image 2020-11-23 at 20.43.09.jpeg



    greenish and greyish disruptions in images.

    tip; also check your display settings in KODI settings
     
  6. osen

    osen New Member

    Messages:
    2
    Hardware:
    RPi3, +Arduino
    Agreed, I would also much rather have a setting like this. Seems like it would be an easy fix to have a threshold value under which the LEDs stay completely off. I also wonder if it would be possible to have several points of gamma correction instead of just one. Just two would be much better I imagine, one for low light conditions and one for bright.

    It seems these values are only available when using a hardware grabber? There's no such settings for platform capture, at least not in the web config. I wonder if it would be worth getting a hardware grabber just for this. The backlight threshold option seems to be "inverted" from what I'm looking for; it adds a minimum brightness level instead of ignoring values below the threshold. Cranking gamma kind of works, but you still get the flicker when the LEDs are turning on. This effectively "moves" the issue to slightly brighter scenes. Even if this is slightly less distracting, for me I feel like cranking gamma takes away more from the overall experience than the flickering in dark scenes does.
     
  7. jeroen warmerdam

    jeroen warmerdam Raspberry 3B / APA102 / Hyperion.NG relaisbox

    Messages:
    397
    Hardware:
    RPi3

    you're right sorry i gave you the wrong information, these settings are only for USB grabber.

    but you can use Vmin Hmin and Vmax Hmax settings also to cut off imagestream from USB grabber when wanted :)

    goodluck.