Yeelight Color S1 Problem (RPi + USB HDMI + Yeelight)

  • Hello, I'm trying to get Hyperion set up for the first time and was hoping for some help with a problem. My end goal is to use HyperBian with HDMI input and an LED strip wired to the GPIO. I have a Pi 3B and splitter/capture devices for HDMI but don't have an LED strip, and wanted to try to get a feel for Hyperion before buying more hardware. I noticed Hyperion supports Yeelight, and I have a couple of Color S1 bulbs, so I'm trying to set these up as a first step.

    Installing Hyperion on the Pi and accessing the web interface is straightforward. The USB capture seems to work fine, and I've also tried the 3rd-party Android app as an alternate source - both appearing in the live feed and showing an appropriate hue in the LED overlay.

    However the bulb itself never seems to change, although it does respond when testing with the wizard. Trying to load an effect via Effect Configurator will appear successful in the UI, and load the effect in Remote Control > Source Selection, but still has no impact on the bulb.

    These are the logs from the webUI: [MEDIA=pastebin]8rc4ytiS[/MEDIA]
    (I couldn't seem to find the logs on the Hyperbian file system over SSH, if someone could point me there that would also be appreciated)

    • Official Post

    Could you just test to disable Smoothing and Platform Capture and USB Capture via the Remote Control
    and then run a simple Color Effect?
    Does that work?

    Edit: do you have any Power-LAN between your rpi and the router to stream to teh Yeelight devices?

    • Official Post

    To see all log-output you can use the journalctl command:

    journalctl --since yesterday

    or you do

    journalctl -f

    then disable the Led-Device and then enable it again (via Remote Control UI).
    You will see all logs since you started the command in the terminal window....

  • I gave this a shot and the logs look quite a bit different:
    [INDENT][INDENT] 2021-02-23T04:26:53.312Z [hyperiond LEDDEVICE] (ERROR) Yeelight device '' signals error: 'Socket operation timed out'
    2021-02-23T04:27:39.620Z [hyperiond LEDDEVICE] (ERROR) Yeelight device '' signals error: 'Socket operation timed out'
    2021-02-23T04:27:39.621Z [hyperiond LEDDEVICE] (ERROR) Failed to open []
    2021-02-23T04:27:39.621Z [hyperiond LEDDEVICE] (ERROR) Device disabled, device 'yeelight' signals error: 'All Yeelights failed to be opened!'
    2021-02-23T04:29:50.037Z [hyperiond LEDDEVICE] (ERROR) Previous line repeats 1 times
    2021-02-23T04:29:50.038Z [hyperiond WEBSOCKET] (DEBUG) (JsonAPI.cpp:1054:handleLoggingCommand()) log streaming activated for client ::ffff:
    2021-02-23T04:29:52.673Z [hyperiond WEBSOCKET] (DEBUG) (JsonAPI.cpp:1063:handleLoggingCommand()) log streaming deactivated for client ::ffff:
    2021-02-23T04:31:41.819Z [hyperiond LEDDEVICE] (DEBUG) (LedDeviceYeelight.cpp:1185:stopMusicModeServer()) Stop MusicModeServer
    2021-02-23T04:31:41.820Z [hyperiond COMPONENTREG] (DEBUG) (ComponentRegister.cpp:36:setNewComponentState()) LED device: disabled
    2021-02-23T04:31:42.572Z [hyperiond LEDDEVICE] (DEBUG) (LedDeviceYeelight.cpp:1171:startMusicModeServer()) The music mode server is running at
    2021-02-23T04:31:43.575Z [hyperiond LEDDEVICE] (ERROR) Yeelight device '' signals error: 'Socket operation timed out'
    2021-02-23T04:31:43.575Z [hyperiond LEDDEVICE] (ERROR) Failed to open []
    2021-02-23T04:31:43.575Z [hyperiond LEDDEVICE] (ERROR) Device disabled, device 'yeelight' signals error: 'All Yeelights failed to be opened!'
    2021-02-23T04:31:49.768Z [hyperiond WEBSOCKET] (DEBUG) (JsonAPI.cpp:1054:handleLoggingCommand()) log streaming activated for client ::ffff:[/INDENT][/INDENT]
    I'm not too sure what you mean by "Power-LAN"; googling that came up with ethernet-over-power which I definitely don't have. If you're just talking about wiring up the Pi to the router over ethernet, I gave that a try and also repositioned the bulb. The bulb has been mounted behind my TV for a few months now and responding fine to commands issued from Home Assistant, but I guess music mode is more sensitive to connection issues and these new logs would definitely seem to back that up.
    This was still causing some errors (didn't manage to capture, sorry), but after some experimentation it seems like changing the LED Configuration > Transition to Sudden got things working for both solid colours and HDMI via USB capture. I need to spend some more time from here to see how it works with the bulb behind the TV again and/or the Pi back on Wifi. But thanks! I'm glad it's now responsive :D

    • Official Post

    @Nassau Sorry, with Power-LAN I was referring to, if you run parts of your network via your Powerlines using something like

    As you rightly said, the Yeelight are unfortunately very sensitive....
    You might want trying to increase the latch-time of the device.
    Latch-time is the time that passes between two updates to an device.
    For me it looks like that the device cannot cope with the update frequency and then fails responding to updates.

    You need to enable "expert" settings level via the wrench icon to see the "Latch-time" .

  • Were you asking about power-LAN because it might introduce issues, or just as a convenient way to connect the Pi? Fortunately my Pi is about 30cm closer to a network switch than a power socket so a direct connection is actually easier :) I don't own any power-LAN adaptors right now but I've experimented in a few homes I've rented and old or new it's always been a poor experience.

    Have also tried experimenting with latch times as high as 1000 but it doesn't seem to make a noticeable difference. There have also been a few under-voltage warnings popping up so I'll need to sort that out before fiddling around much more... Probably a job for another day though.

    • Official Post

    I was asking the Power-LAN, as often certain UDP traffic is not broadcasted through.
    If you do not have any, then we can sort is out as a problem area....

    Adding the obvious question:
    Is the Yeelight running the latest firmware? Could you check which version is reported by the app?

    Plus, I would suggest to move away from debug level 3, as it eats many resources too.
    Any network failure, you would see also with hyperion debug log on and Yeelight debug log off..

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!