Videograbber (HDMI to USB 2.0) not shown on Hyperion nor Raspbian

  • Hi everyone!

    First of all let me introduce myself, I'm Juan from Mexico, I've recently started this project to be used on my son's TV/Xbox.

    My son uses Xbox One Series X for all the multimedia stuff like YouTube, Netflix, Prime Video, Gaming and so on, so I've decided to make the hyperion to be running on a Raspberry to be installed on the back of his TV.

    I will list the main electronics I've been using on this project(I will skip listing stuff like microusb cables, dc jack connectors and so on) and also include the aliexpress links(and yes, I've bought about 85% of the project there).

    Raspberry Pi 3 Zero W(without GPIO pins)

    (I'm also using a USB power addon: )

    Power supply 120V AC input, 5V 10A output.


    4.2 meters WS2812 LED strip(10mm wide, 3 pin connection 5V, Data in and Negative).

    Rullz HDMI to USB capture device which in the description says it uses UVC standard.

    Here's the issue I'm struggling with:

    I've connected the 5V power supply to the LED strip and at the same time I've connected to the Pi 3 using a microUSB cable, this way, the Pi 3 and LED strips are powered from the same 5V output and the same negative output, so I don't have the "random LED color" issue.

    I've had to erase the text line "User=%i" from the Hyperiond@.service using nano, so all the LEDs are working as expected.

    The thing I haven't solved is the videograbber, when I login into Hyperion's web interface I try to select a videograbber, I enable the videograbber but it says can't find any videograbber attached.

    So I SSH to the Pi, I've tried to run the command:

    v4l2-ctl --list-devices

    I've tried lsusb command, but it only returns this:

    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

    Looks like the videograbber is not being recognized by the Pi3 but I've tried on my Macbook Pro, on a Predator laptop and my PC with Windows 10. The weird thing is, the videograbber works using it with OBS by example.

    I though it was a power issue, but I'm using the 5V 10A power supply to run the Pi 3 and the LED stripes.

    I've been trying the Hyperbian distro, Raspbian Lite, and Raspbian with desktop, and I have the same result.

    BTW: I'm using 2 different types of OTG cables, both of them work perfectly on many different android devices, I test them with USB thumb drives and had no issues.

    I don't remember the exact command, but I've obtained in some try a result on the terminal listing the OTG device, so I think the microUSB port is in good condition.

    Hope I can find the answer, I've been reading a lot of posts from many different sources related to UVC devices, v4l2, raspbian and hyperion without success, I'm about to get crazy.

    Thanks in advance for everyone and hope you don't have to fight with this little issue like me. :thumbup:

  • Go to Best Answer
  • don't get crazy, first in terminal/ssh >> lsusb     dmesg

    is the capturing device visible there, no? probably first need a update.

    (its visible after reboot? then turn off the USB capture in Hyperion and On again, save and repeat> seems to be a bug because i have the same in 2.10)


    in terminal: follow up these commands.

    sudo apt-get update

    sudo apt-get upgrade

    stil nothing, then upgrade your firmware. but first try this

    after that with no dice>>

    try this

    apt-cache search firmware

    find these 2

    1. hdmi2usb-fx2-firmware - FX2 firmware for hdmi2usb board development
    2. fxload - Firmware download to EZ-USB devices

    and execute them

    code to install if found

    apt-get install hdmi2usb-fx2-firmware

    apt-get install fxload

  • Hello,

    I'm currently setting up my Hyperion with

    the same hardware like in the first post.

    In my RP-zero the gabber is not recognized either. Are there any solutions yet?

    I performed the update as described, unfortunately without success


  • Thanks for the quick response!

    I'm trying all the steps you've suggested.

    The lsusb shows this:

    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

    The dmesg shows this:

  • Thanks for the quick response!

    I'm trying all the steps you've suggested.

    The lsusb shows this:

    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

    The dmesg shows this:

  • With apt-cache search firmware I found both of them, installed then rebooted, went to Hyperion WebUI with the same result even in terminal, is the same.

    I was thinking, might this issue be caused by a lower power on the microUSB port, so I need like an active OTG and fortunately I have one, I'm going to test that, and do all the steps you suggested too, just in case is not working out of the box.

    Thanks for the quick response!!

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!