Framegrabber only catches a single frame? Fresh install on RPi3B, Kodi 19, LibreElec v10

  • I know that LibreElec broke the framegrabber functionality with version 11, so I made a fresh install of LE v10 on a RPi3B.


    I installed Hyperion, and just for a test, connected a string of 9 WS2812 to the Rpi's SPI port. Using the framegrabber for an input. I know the LED's work fine, because I can load and test Effects in the EffectConfigurator. But other than that, they don't do anything except light up the central LED a very dim white.


    I


    So while I'm playing a video on the Rpi, I look at the "LED Layout Preview" and click Live-Video. This is what shows up. Its not actually grabbing live video, its just responding to a frame grab of the boot boot sequence, which perfectly explains why my central LED is dimly lit and all others are black.


    Is there some trick to making the framegrabber work? It does not let me change any of these options (FrameBuffer, FB0 and 1600X900 are the only available selections in the drop downs). I tried with the actual RPI set to 1600X900, i also tried setting it to lower resolutions, rebooting, but this drop down still only ever shows 1600X900.


    I know I must be doing some obviously stupid. I appreciate any thoughts, thanks!


    Fixed! totally by accident, but heres what ended up working:


    in my distroconfig.txt file, changed dtoverlay=vc4-kms-v3d to dtoverlay=vc4-fkms-v3d


    reboot


    in hyperion CaptureHardware settings, now have option to select "DispmanX". Did that and it worked.

    Edited once, last by EngineerGuy314: Merged a post created by EngineerGuy314 into this post. ().

  • my joy was a little premature. Changine kms to fkms worked for Rpi3. But making that change on a Pi4 (did allow the DispamX frame grabber to work) but prevented the Rpi from being able to playback videos, so its kinda useless...

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!