RPi SD Card failure, now LEDs will not light

  • Hey all,


    I have a setup that has been trucking away for like a year and half with occasional use, started using the smart tv vice XBOX / PS4 to watch streaming services so it only gets used for gaming. Recently I went to turn the system on and there was nothing, RPi flashed but didn't show up on the network and the LEDs didn't light so I assumed SD card failure. I was using cheap SD cards for a project that is constantly writing and reading and the card said no! I decide this is a problem for another day...


    Well yesterday was that day, I purchased some sandisk extreme SD cards and set upon rebuilding the OS and adding a push button shutdown script (GPIO3) and a function LED (GPIO4) and fired up HyperBian. RPI flashes, LED lights, shows up on the network and I can configure away. I entered my LED count and matrix, set up screen capture, enabled the LEDs and ... nothing! In debuggin it says that the LEDs have been turned on, it says that it is flashing RED & GREEN but there is no output. So I am at a loss, there was no powere spike or anything, it just stopped working one day and doesn't turn back on.


    Has this happened to anyone else?


    I have not touched the hardware other than to remove the SD card, everything else is hard mounted to the back of the TV. This is to say it makes no sense to me, should I just try starting from scratch again? Yes, current version of OS, BalenaEtcher to write the card.


    Thanks


    WS2812b LEDs, 179 total

    5v 15A PSU

    USB capture card

  • So, I have confirmed that the LEDs do still in fact work, the strip has been connected to an Arduino running fastLED and all pixels work. I have tested the HyperBian with 2 different RPis, the zeroW that lives on the tv (that stopped working), and on a 3B+, both flash indicating TX/RX activity but there is no output from the LEDs, both are fully configurable via the webpage, but that is all I am getting.

    I have even tried moving GPIO from 18 to 23 and there is no change in the light output, there was some slop in the dupont header socket, but that has been corrected and stll no difference.


    Any help would be appreciated

  • I am sorry for the previous post, I had tried to remove it as it is not helpful or approriate, however, I got pulled away mid-edit and now the post is permanent. Sorry


    Have retried with an arduino nano driving the LEDs running USB off of the RPi ZeroW.

    Arduino Nano is using D2 and the neighbouring GND pin to connect to the Data cable off the LED strip. When I tested the LED strip independently with the arduino they were not lighting up as they are now, they ran the coulour patterns



    The lights light up to white as soon as power is supplied, like before the RPi even boots.


    Everything looks like it is supposed to, if I select live display, IE. the lights extend as they should but there is zero change to the LED from all white.


    Finally corrected, took out the ardiuno out, reconnected the data line to GPIO 18 again (and adjacent Gnd), reconfigured the output to ws2812 again and things worked!! I have no idea but I have saved notes after this, the third or fourth time I have had to rebuild from scratch.

  • Settings level > Expert

    Hyperion log > Log-Level Debug, please.


    Do colors and effects work?

    Do you have a live picture of the grabber?


    regards pclin

    Dreambox ONE / TWO

    dreamOS OE2.6

    Amlogic S922X - 53.000 DMIPS - 2 GB RAM - 16 GB Flash - Twin-DVB-S2X Tuner - HDR10 - HLG
    -
    AudioDSP: miniDSP 2x4HD - Amp: Pentagon - Lautsprecher ELAC / ARENDAL
    LG OLED65BX9LB (PicCap, hyperion.NG webOS)

    FireTV 4K max

    -
    hyperion (classic) & Plugin HyperionControl | hyperion-ng 2.0.16-beta.1 (dreamOS)
    Hyperion-ng (Debian bullseye)
    -
    6 x ESP32/Wemos D1 mini - WLED - SK6812 RGBW-NW 60 LEDs/m
    FeinTech VSP01201 - Grabber Macrosilicon

    LG TV Hyperion webOS & PicCap


    snoozer_likelinux_manvtkns.gif


    Ambilight for ever

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!