NEWBIE HERE, please help

  • sudo netstat --listen:



    Active Internet connections (only servers)
    Proto Recv-Q Send-Q Local Address Foreign Address State
    tcp 0 0 *:19444 *:* LISTEN
    tcp 0 0 *:19445 *:* LISTEN
    tcp 0 0 *:ssh *:* LISTEN
    tcp6 0 0 [::]:ssh [::]:* LISTEN
    udp 0 0 *:57309 *:*
    udp 0 0 *:mdns *:*
    udp 0 0 *:bootpc *:*
    udp 0 0 raspberrypiZERO.fri:ntp *:*
    udp 0 0 localhost:ntp *:*
    udp 0 0 *:ntp *:*
    udp6 0 0 [::]:mdns [::]:*
    udp6 0 0 [::]:59451 [::]:*
    udp6 0 0 fe80::9dac:12b6:508:ntp [::]:*
    udp6 0 0 localhost:ntp [::]:*
    udp6 0 0 [::]:ntp [::]:*
    raw6 0 0 [::]:ipv6-icmp [::]:* 7
    Active UNIX domain sockets (only servers)
    Proto RefCnt Flags Type State I-Node Path
    unix 2 [ ACC ] SEQPACKET LISTENING 4865 /run/udev/control
    unix 2 [ ACC ] STREAM LISTENING 4869 /run/systemd/journal/stdout
    unix 2 [ ACC ] STREAM LISTENING 11113 @/tmp/dbus-BVk8rH8Ohb
    unix 2 [ ACC ] STREAM LISTENING 10280 @/tmp/.X11-unix/X0
    unix 2 [ ACC ] STREAM LISTENING 10281 /tmp/.X11-unix/X0
    unix 2 [ ACC ] STREAM LISTENING 12217 @/dbus-vfs-daemon/socket-IXnNJMJs
    unix 2 [ ACC ] STREAM LISTENING 11703 /tmp/.pcmanfm-socket--0-pi
    unix 2 [ ACC ] STREAM LISTENING 12105 /tmp/.menu-cached-:0-pi
    unix 2 [ ACC ] STREAM LISTENING 12211 @/dbus-vfs-daemon/socket-yPoIlt7Z
    unix 2 [ ACC ] STREAM LISTENING 11098 /tmp/ssh-p9cbFt6qC2Ha/agent.691
    unix 2 [ ACC ] STREAM LISTENING 11601 /tmp/ssh-s6XWqiBlshwA/agent.872
    unix 2 [ ACC ] STREAM LISTENING 8878 /var/run/avahi-daemon/socket
    unix 2 [ ACC ] STREAM LISTENING 8881 /var/run/dbus/system_bus_socket
    unix 2 [ ACC ] STREAM LISTENING 9142 /var/run/dhcpcd.sock
    unix 2 [ ACC ] STREAM LISTENING 10941 /run/user/1000/systemd/private
    unix 2 [ ACC ] STREAM LISTENING 9151 /var/run/dhcpcd.unpriv.sock
    unix 2 [ ACC ] STREAM LISTENING 4842 /run/systemd/private

  • Wait (sorry).


    I changed the ip-adress of Kodi from the shield to the desktop (probably a wrong setting in the shield, from pi2?) and now I get all white leds for a few seconds, than probably kodi's leds, than all white again, etc. No more "KODICHECK ERROR: Kodi Connection error (7)".
    And when I use the android app, I get an effect for a few seconds and than all white leds for a few seconds and then the effect again for a few seconds, etc!


    Meaning a change is being set correct, but after 1 second all leds turn white and I can't see the setting anymore. So the question is not why the change stops, but why the leds turn all white after a second.



    JSONSERVER ERROR remaining:


    Hyperion Ambilight Deamon (1316)
    Version : V1.03.3 (brindosch-2fbbcff/2f01dfa-1495880388
    Build Time: Jun 3 2017 02:06:37
    INFO: Selected configuration file: /etc/hyperion/hyperion.config.json
    HYPERION INFO: ColorTransform 'default' => [0; 179]
    HYPERION INFO: ColorCorrection 'default' => [0; 179]
    HYPERION INFO: ColorAdjustment 'default' => [0; 179]
    LEDDEVICE INFO: configuration:
    {
    "colorOrder" : "grb",
    "name" : "MyHyperionConfig",
    "type" : "ws2812spi"
    }


    INFO: Creating linear smoothing
    HYPERION (CS) INFO: Created linear-smoothing(interval_ms=50;settlingTime_ms=200;updateDelay=0
    EFFECTENGINE INFO: 27 effects loaded from directory /usr/share/hyperion/effects
    EFFECTENGINE INFO: Initializing Python interpreter
    INFO: Hyperion started and initialised
    INFO: Boot sequence 'Knight rider' EFFECTENGINE INFO: run effect Knight rider on channel 0
    BLACKBORDER INFO: threshold set to 0.01 (3)
    BLACKBORDER INFO: mode:default
    started
    INFO: Kodi checker created and started
    terminate called after throwing an instance of 'std::runtime_error'
    what(): JSONSERVER ERROR: could not bind to port

  • Okay, checked Kodi-addon on the Shield. It was disabled, that's why the Kodicheck error. Sorry about that.


    Now the white-leds-issue and the jsonserver error.

  • The log looks ok.


    How confident are you in the wiring ?

    With the pi2, everything works ok. When I put the sd from the pi0 in the pi2, same. The sd from the pi2 in the pi0 won't boot. So must be hardware related. With the pi2, everything works okay, so at most the soldered headers on the pi0 are not okay, but I don't think so. I thought that the gpio pins on the pi2 and pi0 are the same, true?

    I tried ls /dev and spi loopback test (https://www.raspberrypi.org/do…raspberrypi/spi/README.md)
    both are okay.


    There seems to be a little response with pi zero, but very short (some flickering of the leds) when using hyperion-lights app.


    I bought this one: https://www.kiwi-electronics.nl/raspberry-pi-zero-versie-1-3?search=pi zero
    with an unsoldered 40-pin GPIO header. I soldered pins 6, 19 and 21. Do I need to solder all the pins for hyperion to function (perhaps because of gnd)?


    What level shifter are you using ?

    SN74HCT125N


    The SPI loopback test worked ok ?

    Will try it again to be sure.


    Try stopping Hyperion and directly manipulating the gpio from a command prompt to set it high and low and then check the voltage you get at the 1st led.

    I'm going to do that now.


    Wim


  • Penfold,


    Have you seen these posts on mine:
    https://hyperion-project.org/t…help.917/page-7#post-7245
    https://hyperion-project.org/t…help.917/page-7#post-7246
    https://hyperion-project.org/t…help.917/page-7#post-7250


    Wim
    I'm going to run the tests now and report back.

  • sudo service hyperion stop
    gpio -1 mode 19 out


    gpio -1 write 19 1
    DI (data in) -0.02
    BI (backup in, I'm using ws2813) -5.16


    gpio -1 write 19 0
    DI (data in) -0.02
    BI (backup in, I'm using ws2813) 0.00



    Reboot (so hyperion active again)
    Before making a change (color or effect):
    DI (data in) -0.07 (white leds)
    BI (backup in, I'm using ws2813) 0.00


    Making a change, for 0.5s:
    DI (data in) -0.01 (effect or color)
    BI (backup in, I'm using ws2813) 0.00


    After 0.5s:
    DI (data in) -0.07 (white leds again)
    BI (backup in, I'm using ws2813) 0.00


    I didn't mix up the results from DI and BI!
    BI and DI are correctly tied together.


    It did work correct with the pi2.


    When the leds have turned white after 0.5s and I wait long enough I can see the color I set before, again for 0.5 and than all white again, while DI drops to -0.01 and when the leds turn white again up to -0.07 again.


    I don't know what you make of it, but I think I have a faulty pi0. And it seems that all tests are useless. Perhaps the same as this:

    I searched the web and found someone with a broken pi zero wifi (in fact 2 were broken, the third he got was okay):
    https://github.com/PiSupply/PaPiRus/issues/81


    Loopback test okay: https://github.com/PiSupply/Pa…81#issuecomment-286412767
    Third pi0 working: https://github.com/PiSupply/Pa…81#issuecomment-286723151



    After 10 mins, not only the leds I addressed with hyperion are white (for testing purposing I reduced the number to 5):
    led 6 pink
    7 white
    8 green
    9 -13 black
    14, 15 white
    16 yellow
    17-19 black
    20, 21 white
    22 yellow
    23-25 black
    26,27 white
    28 yellow (although less pronounced yellow, more whitish).


    There seems to be a pattern here. And maybe it's green, yellow green, white yellow?


    Changing the color or effect on the first 5 leds, makes no change to the other leds.


    Wim

  • Isn't spi MOSI on gpio 10 ?


    Yes, gpio 10, physical pin 19.


    Fragment from http://wiringpi.com/the-gpio-utility/:
    "Examples


    gpio mode 0 out
    gpio write 0 1
    The above uses the wiringPi pin numbers to set pin 0 as an output and then sets the pin to a logic 1.


    gpio -g mode 17 out
    gpio -g write 17 1
    This uses the BCM_GPIO pin numbering scheme and performs the same operation as above.


    gpio -1 mode 11 out
    gpio -1 write 11 1
    This uses the physical P1 pin numbering scheme and performs the same operation as above."


    I'm using the last kind, physical pin number


  • Penfold, sorry for the late response, the email got stuck in spambox.


    sudo service hyperion stop
    watch -n 0.1 "vcgencmd measure_clock core"


    I see alternating 250000000 and 400000000



    sudo service hyperion start
    watch -n 0.1 "vcgencmd measure_clock core"


    Same results, but also the leds are flashing white.


    Wim
    Thanks for helping me!

  • I already had core_freq=400 at the bottom of the file, I now added it on top and rebooted. Same results.


    Not on every flash, but on most of them, clock core changed from 250000000 to 400000000. Sometimes it stays at one or the other. And on a few occasions I see a different number, something with a lot of 999.

  • I think the leds flash at every command I type???


    When I type sudo nano /boot/config.txt the leds also flash.


    Wait, they don't flash when typing:
    gpio -1 write 21 0


    But again flashing when:
    sudo gpio -1 write 21 0


    Is this normal???

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!