1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

HDMI colors different from Color Picker

Discussion in 'Hyperion General' started by Artorious8, 23 February 2020.

  1. Artorious8

    Artorious8 New Member

    Messages:
    3
    Hardware:
    RPi3
    Hey guys sorry if this has been solved earlier but couldn't seem to find a similar issue posted anywhere.

    So I'm kinda new to Hyperion but I had a build working for a while before my original grabber died on me. I bought a new UTVF007(all I could find) and used the "no-change" workaround in my config file. But ever since after that my HDMI screen cap flipped the blue and red channels. I can fix it by changing the RGB color order but then my color picker is wrong and flips the blue and red channels.

    Does anyone know a solution for this?
     
  2. Akriss

    Akriss Active Member

    Messages:
    561
    Hardware:
    RPi1/Zero, RPi2, RPi3, 32/64bit, +Arduino, +nodeMCU/ESP8266
    In Hyperion try changing the RGB order.
    Image from classic Hyperion.
    rgb-order.PNG

    Hope it helps.
     
  3. Artorious8

    Artorious8 New Member

    Messages:
    3
    Hardware:
    RPi3
    Yea I tried every option on the list to fix it. So if I use the BGR option the Color Picker works correctly, blue=blue,red=red, green=green, but then using the grabber it will switch the blue and red channels for some reason. And if I use the RGB option the grabber shows the right colors, blue=blue,red=red, green=green, but now on the Color Picker the blue and red channels are switched.

    It worked perfectly the first time I set it up with the UTV007 chip
     
  4. T-IOOO

    T-IOOO New Member

    Messages:
    1
    Hardware:
    RPi1/Zero
    I am also running BGR configuration with APA102.
    One thing I've noticed is that the Gamma values will be incorrect.
     
  5. Artorious8

    Artorious8 New Member

    Messages:
    3
    Hardware:
    RPi3
    We're you able to correct it?