1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SOLVED manipulating /sys/class/leds breaks Hyperion?

Discussion in 'Software Support' started by amirook, 11 June 2018.

  1. amirook

    amirook New Member

    Messages:
    3
    Hardware:
    RPi3, +Arduino, +PhilipsHue
    Hi everyone,

    I am running Hyperion (current version) on a raspi3 Model B with raspbian 9.
    I am not even using external sources yet.
    Everything worked fine. Setting the colors and effects in HyperCon or iOS App worked perfect.

    Then I wanted to deactivate the internal LEDs so I tried the following:
    Code:
    sudo sh -c 'echo none > /sys/class/leds/led0/trigger'
    sudo sh -c 'echo none > /sys/class/leds/led1/trigger'
    sudo sh -c 'echo 0 > /sys/class/leds/led0/brightness'
    sudo sh -c 'echo 0 > /sys/class/leds/led1/brightness'
    After first restart my Hyperion is going crazy!
    • Starting the deamon shows random colors on each LED on the strip.
    • Setting an explicit color sometimes makes these random colors change to some other random colors.
    • Stopping the deamon won't turn off the LEDs.
    • Syslog is not showing anyting about it
    • Reboot does not help
    So is it just coinccidence, that it broke after manipulating /sys/class/leds ? Any suggestions?

    Thanks in advance.
     
  2. amirook

    amirook New Member

    Messages:
    3
    Hardware:
    RPi3, +Arduino, +PhilipsHue
    OK, after hours of search. I found the problem just seconds after i posted my problem. It was a hyperion misconfiguration. I was using the wrong Type. WS2801 instead of APA102.