Brand new setup - HDMI capture just shows black screen

  • Hi Folks,


    New at this platform, but I have some experience with WS2812B. I got my Hyperbian setup running well enough that I can successfully run preset effects from the web interface and remote app, but I can't get capture to work. Hyperion can see my capture device, but preview always just shows a black screen.




    I'm using this capture device: https://www.amazon.com/gp/prod…tle_o03_s00?ie=UTF8&psc=1


    Please let me know what I can do to provide more info to troubleshoot this.


  • What do you get when you "lsusb" in ssh?
    Also is your input device (playstation, Xbox etc) on when you start raspberry? If yes try turning it off and on again while raspberry is running.

  • Thank you TPModding


    debug logs:
    2020-11-04T15:53:49.582Z [hyperiond DAEMON] (INFO) CEC handler created
    2020-11-04T15:53:49.603Z [hyperiond EFFECTFILES] (INFO) 39 effects loaded from directory :/effects/
    2020-11-04T15:53:49.608Z [hyperiond EFFECTFILES] (INFO) 22 effect schemas loaded from directory :/effects/schema/
    2020-11-04T15:53:49.611Z [hyperiond EFFECTFILES] (INFO) 1 effects loaded from directory //.hyperion/custom-effects
    2020-11-04T15:53:49.678Z [hyperiond SETTINGSMGR] (DEBUG) (SettingsManager.cpp:107:SettingsManager()) Settings database initialized
    2020-11-04T15:53:49.684Z [hyperiond BLACKBORDER] (DEBUG) (BlackBorderProcessor.cpp:64:handleSettingsUpdate()) Set mode to: default
    2020-11-04T15:53:49.684Z [hyperiond COMPONENTREG] (DEBUG) (ComponentRegister.cpp:36:setNewComponentState()) Blackborder detector: enabled
    2020-11-04T15:53:49.720Z [hyperiond DAEMON] (INFO) set screen capture device to 'dispmanx'
    2020-11-04T15:53:49.720Z [hyperiond DISPMANXGRABBER] (DEBUG) (Grabber.cpp:30:setVideoMode()) Set videomode to 0
    2020-11-04T15:53:49.740Z [hyperiond DISPMANXGRABBER] (INFO) Display opened with resolution: 640x480
    2020-11-04T15:53:49.741Z [hyperiond DISPMANXGRABBER] (DEBUG) (Grabber.cpp:90:setWidthHeight()) Set new width: 1080, height: 1920 for capture
    2020-11-04T15:53:49.760Z [hyperiond DAEMON] (INFO) DISPMANX frame grabber created
    2020-11-04T15:53:49.761Z [hyperiond V4L2:/DEV/VIDEO0] (DEBUG) (Grabber.cpp:30:setVideoMode()) Set videomode to 0
    2020-11-04T15:53:49.845Z [hyperiond V4L2:/DEV/VIDEO0] (DEBUG) (Grabber.cpp:90:setWidthHeight()) Set new width: 1920, height: 1080 for capture
    2020-11-04T15:53:49.845Z [hyperiond V4L2:/DEV/VIDEO0] (INFO) Signal threshold set to: {12, 12, 12}
    2020-11-04T15:53:49.845Z [hyperiond V4L2:/DEV/VIDEO0] (INFO) CEC detection is now disabled
    2020-11-04T15:53:49.845Z [hyperiond V4L2:/DEV/VIDEO0] (INFO) Signal detection is now disabled
    2020-11-04T15:53:49.845Z [hyperiond V4L2:/DEV/VIDEO0] (INFO) Signal detection area set to: 0.250000,0.250000 x 0.750000,0.750000
    2020-11-04T15:53:49.845Z [hyperiond DAEMON] (DEBUG) (hyperiond.cpp:568:handleSettingsUpdate()) V4L2 grabber created
    2020-11-04T15:53:49.846Z [hyperiond JSONSERVER] (DEBUG) (JsonServer.cpp:27:JsonServer()) Created instance
    2020-11-04T15:53:49.847Z [hyperiond JSONSERVER] (INFO) Started on port 19444
    2020-11-04T15:53:49.731Z [hyperiond LEDDEVICE] (INFO) Start LedDevice 'ws281x'.
    2020-11-04T15:53:49.731Z [hyperiond COMPONENTREG] (DEBUG) (ComponentRegister.cpp:36:setNewComponentState()) Smoothing: enabled
    2020-11-04T15:53:49.731Z [hyperiond LEDDEVICE] (DEBUG) (LedDevice.cpp:147:init()) deviceConfig: [{"colorOrder":"grb","currentLedCount":214,"dma":5,"gpio":18,"hardwareLedCount":1,"invert":false,"latchTime":0,"leds":256,"pwmchannel":0,"rewriteTime":1000,"rgbw":false,"type":"ws281x","whiteAlgorithm":"subtract_minimum"}]
    2020-11-04T15:53:49.731Z [hyperiond LEDDEVICE] (DEBUG) (LedDevice.cpp:403:setLatchTime()) LatchTime updated to 0ms
    2020-11-04T15:53:49.732Z [hyperiond LEDDEVICE] (DEBUG) (LedDevice.cpp:423:setRewriteTime()) Refresh interval = 1000ms
    2020-11-04T15:53:49.732Z [hyperiond LEDDEVICE] (DEBUG) (LedDevice.cpp:429:setRewriteTime()) RewriteTime updated to 1000ms
    2020-11-04T15:53:49.732Z [hyperiond LEDDEVICE] (DEBUG) (LedDeviceWS281x.cpp:59:init()) ws281x strip type : 1050624
    2020-11-04T15:53:49.746Z [hyperiond FLATBUFCONN] (INFO) Connecting to Hyperion: 127.0.0.1:19401
    2020-11-04T15:53:49.759Z [hyperiond EFFECTENGINE] (INFO) Run effect "Candle" on channel 0
    2020-11-04T15:53:49.818Z [hyperiond EFFECTENGINE] (DEBUG) (EffectEngine.cpp:183:runEffectScript()) Start the effect: name [Candle], smoothCfg [2]
    2020-11-04T15:53:49.819Z [hyperiond HYPERION] (DEBUG) (PriorityMuxer.cpp:159:registerInput()) Register new input 'System/EFFECT' with priority 0 as inactive
    2020-11-04T15:53:49.819Z [hyperiond HYPERION] (INFO) Initial foreground effect 'Candle' started
    2020-11-04T15:53:49.820Z [hyperiond EFFECTENGINE] (INFO) Run effect "cooler candle" on channel 254
    2020-11-04T15:53:49.821Z [hyperiond EFFECTENGINE] (DEBUG) (EffectEngine.cpp:183:runEffectScript()) Start the effect: name [cooler candle], smoothCfg [2]
    2020-11-04T15:53:49.821Z [hyperiond HYPERION] (DEBUG) (PriorityMuxer.cpp:159:registerInput()) Register new input 'System/EFFECT' with priority 254 as inactive
    2020-11-04T15:53:49.822Z [hyperiond HYPERION] (INFO) Inital background effect 'cooler candle' started
    2020-11-04T15:53:49.823Z [hyperiond HYPERION] (DEBUG) (PriorityMuxer.cpp:159:registerInput()) Register new input 'System/V4L' with priority 210 as inactive
    2020-11-04T15:53:49.823Z [hyperiond COMPONENTREG] (DEBUG) (ComponentRegister.cpp:36:setNewComponentState()) V4L capture device: enabled
    2020-11-04T15:53:49.854Z [hyperiond V4L2:/DEV/VIDEO0] (INFO) configured v4l device: /dev/video0
    2020-11-04T15:53:49.854Z [hyperiond V4L2:/DEV/VIDEO0] (DEBUG) (V4L2Grabber.cpp:582:init_device()) Set device input to: Camera 1
    2020-11-04T15:53:49.855Z [hyperiond V4L2:/DEV/VIDEO0] (DEBUG) (V4L2Grabber.cpp:696:init_device()) Set resolution to width=1920 height=1080
    2020-11-04T15:53:49.857Z [hyperiond V4L2:/DEV/VIDEO0] (DEBUG) (V4L2Grabber.cpp:713:init_device()) Set framerate to 5 fps
    2020-11-04T15:53:49.857Z [hyperiond V4L2:/DEV/VIDEO0] (DEBUG) (V4L2Grabber.cpp:735:init_device()) Pixel format=YUYV
    2020-11-04T15:53:49.877Z [hyperiond V4L2:/DEV/VIDEO0] (INFO) Started
    2020-11-04T15:53:49.877Z [hyperiond V4L2:/dev/video0] (DEBUG) (GrabberWrapper.cpp:48:start()) Grabber start()
    2020-11-04T15:53:49.824Z [hyperiond BOBLIGHT] (DEBUG) (BoblightServer.cpp:28:BoblightServer()) Instance created
    2020-11-04T15:53:49.878Z [hyperiond HYPERION] (INFO) Hyperion instance 'First LED Hardware instance' has been started
    2020-11-04T15:53:49.825Z [hyperiond COMPONENTREG] (DEBUG) (ComponentRegister.cpp:36:setNewComponentState()) LED device: enabled
    2020-11-04T15:53:49.849Z [hyperiond PROTOSERVER] (INFO) Started on port 19445
    2020-11-04T15:53:49.850Z [hyperiond FLATBUFSERVER] (INFO) Started on port 19400
    2020-11-04T15:53:49.851Z [hyperiond WEBSERVER] (DEBUG) (WebServer.cpp:32:initServer()) Initialize Webserver
    2020-11-04T15:53:49.855Z [hyperiond WEBSERVER] (DEBUG) (WebServer.cpp:32:initServer()) Initialize Webserver
    2020-11-04T15:53:50.006Z [hyperiond WEBSERVER] (DEBUG) (WebServer.cpp:90:handleSettingsUpdate()) Apply Webserver settings
    2020-11-04T15:53:50.006Z [hyperiond WEBSERVER] (DEBUG) (WebServer.cpp:108:handleSettingsUpdate()) Set document root to: :/webconfig
    2020-11-04T15:53:50.006Z [hyperiond WEBSERVER] (DEBUG) (WebServer.cpp:90:handleSettingsUpdate()) Apply Webserver settings
    2020-11-04T15:53:50.007Z [hyperiond WEBSERVER] (DEBUG) (WebServer.cpp:108:handleSettingsUpdate()) Set document root to: :/webconfig
    2020-11-04T15:53:50.008Z [hyperiond WEBSERVER] (INFO) Started on port 8090 name 'Hyperion Webserver'
    2020-11-04T15:53:50.086Z [hyperiond HYPERION] (DEBUG) (PriorityMuxer.cpp:333:setCurrentTime()) Set visible priority to 0
    2020-11-04T15:53:50.087Z [hyperiond HYPERION] (DEBUG) (Hyperion.cpp:538:handlPriorityChangedLedDevice()) priority[0], previousPriority[255]
    2020-11-04T15:53:50.087Z [hyperiond HYPERION] (DEBUG) (Hyperion.cpp:548:handlPriorityChangedLedDevice()) new source available -> switch LED-Device on
    2020-11-04T15:53:50.123Z [hyperiond HYPERION] (DEBUG) (PriorityMuxer.cpp:198:setInput()) Priority 0 is now active
    2020-11-04T15:53:50.125Z [hyperiond HYPERION] (DEBUG) (PriorityMuxer.cpp:198:setInput()) Priority 254 is now active
    2020-11-04T15:53:50.305Z [hyperiond HYPERION] (DEBUG) (PriorityMuxer.cpp:238:setInputImage()) Priority 210 is now active
    2020-11-04T15:53:50.446Z [hyperiond WEBSERVER] (DEBUG) (WebServer.cpp:174:handleSettingsUpdate()) Setup SSL certificate
    2020-11-04T15:53:50.447Z [hyperiond WEBSERVER] (DEBUG) (WebServer.cpp:190:handleSettingsUpdate()) Setup private SSL key
    2020-11-04T15:53:50.447Z [hyperiond WEBSERVER] (INFO) Started on port 8092 name 'Hyperion Webserver'
    2020-11-04T15:53:50.676Z [hyperiond WEBSOCKET] (DEBUG) (WebSocketClient.cpp:30:WebSocketClient()) New connection from ::ffff:192.168.1.101
    2020-11-04T15:53:50.677Z [hyperiond WEBSOCKET] (DEBUG) (JsonAPI.cpp:81:handleInstanceSwitch()) Client '::ffff:192.168.1.101' switch to Hyperion instance 0
    2020-11-04T15:53:53.145Z [hyperiond HYPERION] (DEBUG) (PriorityMuxer.cpp:298:setCurrentTime()) Timeout clear for priority 0
    2020-11-04T15:53:53.395Z [hyperiond HYPERION] (DEBUG) (PriorityMuxer.cpp:333:setCurrentTime()) Set visible priority to 210
    2020-11-04T15:53:53.396Z [hyperiond HYPERION] (DEBUG) (Hyperion.cpp:538:handlPriorityChangedLedDevice()) priority[210], previousPriority[0]
    2020-11-04T15:53:56.595Z [hyperiond WEBSOCKET] (DEBUG) (JsonAPI.cpp:1032:handleLoggingCommand()) log streaming activated for client ::ffff:192.168.1.101

  • What do you get when you "lsusb" in ssh?
    Also is your input device (playstation, Xbox etc) on when you start raspberry? If yes try turning it off and on again while raspberry is running.


    lsusb output:
    Bus 001 Device 004: ID 534d:2109
    Bus 001 Device 005: ID 0424:7800 Standard Microsystems Corp.
    Bus 001 Device 003: ID 0424:2514 Standard Microsystems Corp. USB 2.0 Hub
    Bus 001 Device 002: ID 0424:2514 Standard Microsystems Corp. USB 2.0 Hub
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

  • 2020-11-04T15:53:49.845Z [hyperiond V4L2:/DEV/VIDEO0] (INFO) CEC detection is now disabled
    2020-11-04T15:53:49.845Z [hyperiond V4L2:/DEV/VIDEO0] (INFO) Signal detection is now disabled



    can you enable this one ? Signal detection is off


    what's the values there for signal detection? it has to be 0.25 and 0.75 default

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!