Problems with the configuration or with the Hardware?

  • Hello I need help please. I already had the system working, however I moved house and now I can't get Hyperion to work with Hyberbian.

    I have APA102 leds strip connected to the Raspberry 2b, with a LogiLink grabber with the USBTV007 chipset.

    I've tried all the settings but I can't get them to work.

    I already think that I will have damaged the leds or even the raspberry since no led lights up.

    There is some way to test and why it works?

    I have already measured with a multimeter and apparently everything is fine, but nothing works. Are there any tests I can do?

    Thanks a lot.

    My installation and configuration





  • hello Pedro Teixeira

    good that you had it working! but there is a fault in your setup; >>> remove that red wire connector (PIN2 ) from the PI completely,

    because you are using USB power on the PI you don't need the power the PI extra.

    2 diffrent +5 volts is coming together and clashing, so remove that immediatelly!

    i hope you didn't hurt the PI

  • Yes I use pin 19 and 23.

    About your question..

    'If you look at remote section is the LEd device running'

    I don't understand... In Raspberry our Led strip?

    Maybe I already have the LEd strip burned or something like that.


    Thanks for your reply.

    But I don't think it's a Raspberry problem, because I've tried it with another Pi2 and it's still the same. Unfortunately I think the LEd strip may have broken .

    Edited 2 times, last by Pedro Teixeira: 2 Beiträge von Pedro Teixeira mit diesem Beitrag zusammengefügt. ().

  • TPmodding

    my apologies for my silence, but unfortunately I caught COVID19 and I was down.

    Now I am recovered and back to this project. I already made the connections and the leds work but the image on the right side, and bottom right, shows flickering.

    (please see all clip 30s)

    Gif sampe clip

    If you see this little clip after a few seconds, the image on the right side will start to shake. It is to repair yourself even with the still image the leds are on this side.


    What could it be? Any configuration or connection problems? In GPIO I only connected Ground and MOSI and SCLK. Pi is being powered by the original power.

  • Ledtou Yes I know. And this is how it is.

    TPmodding When there is only one color there is no problem. I noticed even when I use an effect if the brightness is at maximum there are no problems, if you reduce the intensity the leds start to flash.

    With 1 color 100% brightness


    With 1 color 80% or less brightness (blinking)


    More than 1 color effect with 100% brightness


    Will it be a problem connecting the led strips on the right and bottom?

    • Official Post

    it could be sure, but i dont think so...could you take some pictures with goog quality pls? from the whole back and from the corners

    thinks i would check:

    1. are the connections good

    2. what does the live preview shows at the webui, can i see some flickering on it

    4. try out lower capturing resolutions with different framerates

    3. may i need a level shifter to keep the signal stable

  • Ok. I'm going to try to take the TV off the wall to get the photos.

    The connections will be difficult to see because I put hot glue to help prevent the wires from coming off.

    Once again thank you very much for your help.

    I hope to give you news soon.

  • Now while my son was playing, I started doing tests to change the resolution and framerates. I stopped the service and saw that the right side and the bottom keep some LEDs on. So there may even be problems with the connections.



    Service stop


    It's possible?

  • I already change the resolution to 640x480 and 320x240 and change the framerate but the problems continue. I removed the TV from the wall and follows pictures of the electrical wiring.

    Top corner wiring


    Bottom corner wiring


    Test light back TV out


    Thanks again.

  • Pedro Teixeira

    i see that you have more than one instance, are you sure you selected the default one like instance one

    and have all the settings correct for the apa102?

    to select, just run the instance at remote and then choose the instance thats running into top corner ( screen icon) has to become an green dot.

    note; only instance one you can controll in the app Hyperion Free the others don't work so you can not test in instance two with an app.

    note2; use flux when you solder because the solderjoints seem to overlap contact each other. with flux/no clean you have a solid and clean connection.

  • Hello guys.

    Problem solved.

    I remake the connections in the upper right corner and solved it. The CI connection was not with good continuity and I re-soldered. At the moment it is running at full speed without any type of flickering.

    I want to thank everyone for their help, especially to TPmodding for their patience and cooperation.

    Thank you, thank you, thank you.

    Happy Easter to all.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!