PicCap - Hyperion Sender App | Ambilight for LG WebOS TVs

  • vi /media/developer/apps/usr/palm/services/org.webosbrew.piccap.service/piccapautostart


    gruß pclin

  • Wenn ich den Befehl eingebe, sehe ich zwar was da drin steht, aber ich kann nichts bearbeiten.

    Habe jetzt versucht in der config bei Autostart true einzutragen, aber das geht nicht.


    Wie kann ich das jetzt einstellen das Autostart aktiv ist?


    edit:

    Habs jetzt mit FileZilla angepasst.

    Ambilight läuft jetzt, sogar alle 4 Instanzen.

    Was ich jetzt nur noch habe, ist das die Leds etwas nachhängen.


    Muss ich jetzt mit der Auflösung spielen um diese anzupassen?

  • Alle --backend versucht?

    Bei einem backend gibt es Probleme, ich meine bei libdile_vt.

    Da geht nur 5 FPS, es gibt aber einen anderen hyperion-webos build wo das gelöst ist.

    Da gibt es eine neue Option vsync=false.


    Ansonsten kannst du nur mit Auflösung und FPS versuchen.


    gruß pclin

  • Ich habe mal beide mit 2020 probiert. Habe auch mal die Werte genommen die hier im Forum beschrieben wurden.


    Ich hab mir mal eine Magie Remote Fernbedienung bestellt, damit ich nicht immer mit filezilla die config hochladen muss.


    Ist es aber richtig das man nach einem Neustart vom TV immer erst die App öffnen musst damit er den Dienst startet? Sollte das nicht mit Autostart funktionieren?

  • Quick Start+ ausgeschaltet?


    gruß pclin

  • Dann sollte der Autostart eigentlich funktionieren.


    Schau am bestem mal auf Discord OpenLGTV > piccap-hyperion nach dem build von infowski dort ist der Autostart gefixt und auch das backend Problem.

    Weiterhin ist man am HDR | SDR Problem dran, was einige User haben (Bild zu dunkel).

    Download und Anleitung findest du dort auch.


    gruß pclin

    Dreambox ONE / TWO

    dreamOS OE2.6

    Amlogic S922X - 53.000 DMIPS - 2 GB RAM - 16 GB Flash - Twin-DVB-S2X Tuner - HDR10 - HLG
    -
    AudioDSP: miniDSP 2x4HD - Lautsprecher ELAC
    LG OLED65BX9LB (PicCap, hyperion.NG webOS)

    FireTV 4K max

    -
    hyperion (classic) & Plugin HyperionControl | hyperion-ng 2.0.12 (dreamOS)
    Hyperion-ng (Debian Buster)
    -
    6 x Wemos D1 mini - WLED - SK6812 RGBW-NW 60 LEDs/m
    5-Port HDMI Switch - FeinTech VSP01201 - Grabber Macrosilicon


    snoozer_likelinux_manvtkns.gif


    Ambilight for ever

    Edited 2 times, last by pclin ().

  • Bilder vo PicCap libvtcapture OLED65BX9LB.

    Für die Bilder in PicCap temporär auf 1280x720 gestellt.

    Auf den Bildern sieht man das die DolbyVision und HDR Bilder etwas heller sein könnten, sind bei mir aber schon recht akzeptabel im Gegensatz zu den Bilder von anderen Usern, beim Ambilight fällt das schon fast nicht auf.


    gruß pclin


    Nach unicapture oder vsync suchen, sind so ca. die letzten 100 Einträge in piccap-hyperion.

    Google Übersetzter nutzen... ;)


    gruß pclin

  • Es funktionieren die üblichen Linux commands.

    ls, cd, usw.

    vsync false geht z.Zt. nur mit dem unicapture branch von Infowski, das musst du dir herunterladen und hyperion-webos austauschen.

    Anleitung und Download Link in Discord OpenLGTV > piccap-hyperion

    Z.Zt. funktioniert das dann aber nicht über die PicCap UI im LG TV nur über telnet oder ssh kann man das konfigurieren.


    Quote from infowski

    Just download latest github actions artifacts and dump them to /media/developer/apps/usr/palm/services/org.webosbrew.piccap.service (replacing existing binaries)


    Ah, kill hyperion-webos (pkill -9 -f hyperion-webos) before extracting/replacing binaries, since it may fail to overwrite the binary.


    1. The only downside is that the UI is partially broken, but start/stop works and you can still use luna://org.webosbrew.piccap.service/setSettings and such to adjust the settings.


    gruß pclin

    Dreambox ONE / TWO

    dreamOS OE2.6

    Amlogic S922X - 53.000 DMIPS - 2 GB RAM - 16 GB Flash - Twin-DVB-S2X Tuner - HDR10 - HLG
    -
    AudioDSP: miniDSP 2x4HD - Lautsprecher ELAC
    LG OLED65BX9LB (PicCap, hyperion.NG webOS)

    FireTV 4K max

    -
    hyperion (classic) & Plugin HyperionControl | hyperion-ng 2.0.12 (dreamOS)
    Hyperion-ng (Debian Buster)
    -
    6 x Wemos D1 mini - WLED - SK6812 RGBW-NW 60 LEDs/m
    5-Port HDMI Switch - FeinTech VSP01201 - Grabber Macrosilicon


    snoozer_likelinux_manvtkns.gif


    Ambilight for ever

    Edited 3 times, last by pclin ().

  • Also es ist egal was ich für Werte eintrage, ich habe immer eine Verzögerung. Ich weiß nicht mehr was ich sonst noch versuchen soll :(


    Ps.

    Ich habe teilweise eine Auslastung von bis zu 135% könnte mir vorstellen das es davon kommt. Aber wie kann ich das reduzieren.


    Welchen pi nutzt ihr? Nutzt ihr wlan?

    Ich habe ein pi3+b


    Und nicht nur das er hängt, sondern kommt kurz dieses Bild

  • n0n3m3d88 ich hab auch den pi 3b und wled. Tv und pi sind mit lan verbunden. Ich habe nur mit libdile eine verzögerung, mit libvt+libgm ohne verzögerung und läuft perfekt. Nur bei libvt+libgm ist bei mir dolby vision über shield und hdmi "kaputt". Würde deswegen lieber libdilevt verwenden. Da funzt es. Aber man kann ja nicht alles haben :D

  • n0n3m3d88 ich hab auch den pi 3b und wled. Tv und pi sind mit lan verbunden. Ich habe nur mit libdile eine verzögerung, mit libvt+libgm ohne verzögerung und läuft perfekt. Nur bei libvt+libgm ist bei mir dolby vision über shield und hdmi "kaputt". Würde deswegen lieber libdilevt verwenden. Da funzt es. Aber man kann ja nicht alles haben :D

    Welche Werte nutzt du denn?

  • 135% beim RPI. das ist nicht normal!

    hyperiond benötigt mit Flatbuffers nicht viel an CPU.


    Schau dir das mal mit htop an wieviel hyperiond dort benötigt.


    gruß pclin

    Dreambox ONE / TWO

    dreamOS OE2.6

    Amlogic S922X - 53.000 DMIPS - 2 GB RAM - 16 GB Flash - Twin-DVB-S2X Tuner - HDR10 - HLG
    -
    AudioDSP: miniDSP 2x4HD - Lautsprecher ELAC
    LG OLED65BX9LB (PicCap, hyperion.NG webOS)

    FireTV 4K max

    -
    hyperion (classic) & Plugin HyperionControl | hyperion-ng 2.0.12 (dreamOS)
    Hyperion-ng (Debian Buster)
    -
    6 x Wemos D1 mini - WLED - SK6812 RGBW-NW 60 LEDs/m
    5-Port HDMI Switch - FeinTech VSP01201 - Grabber Macrosilicon


    snoozer_likelinux_manvtkns.gif


    Ambilight for ever

    Edited once, last by pclin ().

  • So sieht das bei mir aus.

    TV und pi sind per wlan drin

    1. Bild ist mit piccap = Verzögerung

    2. Bild mit hdmi Grabber = keine Verzögerung

  • Ok das ist schon viel, bei mir ist Flatbuffers unter den Werten von internen und externen Grabber, und das mit 384x216 50FS FPS in PicCap.


    Meg_the_Face

    wie sind die Werte bei dir, hast du da auch so eine hohe CPU Last?


    gruß pclin

  • Per SSH auf dein pi und dann htop eingeben.


    Kann das ggf. an der Größe der sd Karte liegen? Habe 16gb drin.

    Hast du pi und tv per lan oder wlan im Netzwerk?

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!