LED wont turn on

  • Hey, i tried hard to get the Setup to run, but i am clueless right now.

    I startet to build my first Hyperion Setup:
    WS2812b 60LED/m "or" WS2812b 30LED/m
    Raspberry Pi 1b+ "or" Raspberry Pi Zero W
    5V 10A Power Sup.
    and a cheap HDMI Capture Card

    First, I cut apart and stripped a microUSB cable. After that I mounted the microUSB cable (red and black) and the cables of the LED strip (red and white) to a DC connector. When I checked the wiring several times using Youtube videos, I plugged the power supply into the DC connector, the Raspberry Pi 1b+ booted up, I waited and waited, but the LED strip gave no signal.

    Before that, of course, I set the LED strip via Hyperion website as it was described in the Youtube videos.

    As controller type I took WS281X.

    I checked the settings countless times. I have uninstalled and reinstalled Hyperbian several times. The LED strips just don't give out any signal.

    Then I tested every single LED and everywhere the desired 5V was present. After that I thought maybe the GPIO pins on the Raspberry Pi 1 didn't work properly anymore, so I bought a Raspberry Pi Zero W. But after the error was not there either, I thought okay, maybe the LED strip is defective. So I bought a second LED strip, but this time only 30LED/m . And to check the functionality this time I ordered a small remote controller for this LED strip. With the small remote controller both LED strips work fine, but with Hyperion the LED just doesn't want to output a signal.

    What can I do now to make it work?

    btw. I checked the log files every time, but they were ALWAYS empty.

    Here is my test wiring.

    LED strip at DC connector

    Raspberry Pi Zero with an external power supply

    This test wiring was to see if the LED strip receives signals when I run an effect via Hyperion webpage.


    LED Strip connected to DC Connector

    LED Data Kabel connected to Raspberry Pi Zero GPIO

    LED Strip wont turn on with an effect enabled

    My Remote Controller "Tool"

    LED Strip enabled with the Remote Controller - works perfectly

    I hope someone of you gentlemens can help me, i m clueless, i have no more ideas :/

    Merry Christmas
    Best Regards

  • So I got the problem with the root fixed.

    But now I have a second problem. The LED's react to all effects, can do them without flickering and without voltage drop.

    But as soon as I activate my HDMI Grabber in the Hyperion settings, the LED changes to white and flickers. As soon as I disconnect the power supply from the DC connector, the LED's stay orange, as soon as I disconnect the grabber from the Raspberry Pi, the LED strip loses the remaining voltage and goes off.

  • How did you fix the root of the problem. When i power up my strips to a raspberry pi 0 i get maybe 1 or 2 lights up. I have them on on a dedicated 5v 15a power supply with a common ground to the raspberry pi and its own power supply

  • Code
    sudo systemctl disable --now hyperion@pi.service
    sudo systemctl enable --now hyperion@root.service 

    restart the pi
    After that hyperion starts with root

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!