First time setting up my first DIY Ambient Light

  • Noob here, I am following some guides in YouTube how to setup my very own DIY ambient lights, however I have encountered a lot of problems since last week and near to none to give up on this project of mine and almost throw these stuff away.


    I installed HyperBian and did as what the video says but what it was not stated is how to make your LEDs light up. I have encountered this type of problem in my log:

    [LEDDEVICE|First LED Hardware instance] (ERROR) Device disabled, device 'ws281x' signals error: 'Hyperion must run with "root" privileges for this device. Current user is: "hyperion"'


    I just google it and I saw this site, under Hyperion 2.0.0-alpha.11:

    Releases · hyperion-project/hyperion.ng
    The successor to Hyperion aka Hyperion Next Generation - hyperion-project/hyperion.ng
    github.com


    I did enter this code

    sudo updateHyperionUser -u root

    and I cannot access the terminal via putty or the :8090 browser.


    YouTube links:

    External Content www.youtube.com
    Content embedded from external sources will not be displayed without your consent.
    Through the activation of external content, you agree that personal data may be transferred to third party platforms. We have provided more information on this in our privacy policy.

    External Content www.youtube.com
    Content embedded from external sources will not be displayed without your consent.
    Through the activation of external content, you agree that personal data may be transferred to third party platforms. We have provided more information on this in our privacy policy.

  • If you can't SSH or webgui, just reinstall to speed things up.


    SSH into your new install and run these commands-


    sudo systemctl disable --now hyperion@pi


    sudo systemctl enable --now hyperion@root

  • Have you read and followed the Hyperbian documentation?

    SSH LOGIN

    • User: hyperion
    • Password: ambientlight


    sudo updateHyperionUser -u root

    is the right!

    How did you type that if you can't connect to putty.



    If you don't get IP:8090 hyperion won't run, if you get into the console you can type systemctl status hyperion@root start with systemctl start hyperion@root. Post the issues if you have problems.


    regards pclin

    Dreambox ONE / TWO

    dreamOS OE2.6

    Amlogic S922X - 53.000 DMIPS - 2 GB RAM - 16 GB Flash - Twin-DVB-S2X Tuner - HDR10 - HLG
    -
    AudioDSP: miniDSP 2x4HD - Amp: Pentagon - Lautsprecher ELAC / ARENDAL
    LG OLED65BX9LB (PicCap, hyperion.NG webOS)

    FireTV 4K max

    -
    hyperion (classic) & Plugin HyperionControl | hyperion-ng 2.0.16-beta.1 (dreamOS)
    Hyperion-ng (Debian bullseye)
    -
    6 x ESP32/Wemos D1 mini - WLED - SK6812 RGBW-NW 60 LEDs/m
    FeinTech VSP01201 - Grabber Macrosilicon

    LG TV Hyperion webOS & PicCap


    snoozer_likelinux_manvtkns.gif


    Ambilight for ever

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!