Usb grabber does not provide input from Android box (Mibox S)

  • I have setup an ambilight system, Hyperion running on PC/Win11, SK6812 RGBW Led Strip, ESP D1 Mini V3.0 (ESP8266), which is working normally, when i use the USB grabber to provide input from another PC.


    However, when i try to get input from Xiaomi Mibox S, the USB grabber does not provide any signal and the Leds go off in Hyperion after some seconds...


    The grabber gets input from an HDMI 8K switch/splitter with HDCP 2.3 support.


    The switch is this one: https://www.aliexpress.com/ite…st_main.10.21ef1802PDr2yn


    and the grabber is this:

    Dieser Artikel wurde abgekündigt - Temu Germany


    I would appreciate some input on what is going wrong , if someone has already setup Mibox S with Hyperion and a USB grabber, please inform me about the setup.

  • However, when i try to get input from Xiaomi Mibox S, the USB grabber does not provide any signal and the Leds go off in Hyperion after some seconds...

    Hi, what about to connect external monitor to the splitter/switch (place of grabber) and test the output.
    Interesting topic, I want to build the similar setup and also use Mibox S as the source of video.

  • This was the first thing i tried, i also connected the exact same setup, to grab video from my laptop and it is working perfectly. I do not know what is going on, maybe something with Android, or something else....

    • Official Post

    HDCP/DRM and/or see Screenshot


    regards pclin

  • Well, my TV is an older one, only 1920x1080, so i have the Mibox S to output only this resolution.

    When i connect the setup to a Laptop (Win11) i get a signal on both outputs of the splitter.


    I just did some more testing and the following odd thing happens: I connect only one output to the splitter and feed it to the grabber, it works, i get a signal and ambilight works. However, when i connect the second output, which feeds the signal to the TV, the splitter cuts off the other output, the USB grabber one, i have tried different combinations, connect it to the first output and the TV to the second or reverse, but the splitter always cuts off the grabber output...


    Maybe the HDMI cable i connect to the grabber is not 2.1, i know for a fact that the other two are, because i just bought them. I will try using the exact brand and certification cables to both outputs and see what happens....

  • Update, i have three identical HDMI 2.1 cables (Ugreen braided), when i connect the USB grabber first to the splitter, i get an output, but as soon as i connect the second output to the TV, the splitter cuts off the signal to the grabber and outputs only to the TV!!!


    I do not know what to try next, maybe a different splitter....

  • So, i have used a different splitter, a very simple one i' ve had for years, no HDMI 2.1 support, no HDCP 2.3 support and it works perfectly, no disconnections, working flawlessly with Hyperion. I can watch everything, Netflix, Disney, YouTube with ambilight.


    Maybe the problem with the advanced splitter i had was my TV, which is a 2009 Samsung and it does not support HDMI 2.1, so it maybe broke the chain for the splitter....


    To summarize, i have solved my problem and hopefully also helped anyone who wishes to connect the Xiaomi Mibox S to Hyperion and ambilight...

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!