1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

RPi + OSMC Another flickering thread...

Discussion in 'Hardware Support' started by Mhut, 11 October 2016.

  1. Mhut

    Mhut New Member

    Messages:
    23
    Hardware:
    RPi3
    Hi.
    My setup:
    RPI3 + OSMC + LIGHTBERRY (APA102, using 92 LEDs).
    All is working almost fine, but i suffer some flickering ONLY on the top strip of my led (install beggins on bottom left, the goes up and counterclock aroung all the tv sides). It is more noticeable on static pictures, like menu backgrounds, or more likely, on the pictures with full colors used for calibrating (like the ones available here from the configuration wiki). Of course, when watching videos i barely can see any flicker at all, because normally the color is changing a lot.
    Strange thing is, if i send a static rbg value from the hyperion android app, it does not flicker at all, so the leds seems ok.
    Also, it does not flicker at all if i display a full white picture, but flickers if i display a full red/blue/yellow/etc
    And also, i can´t understand why it only flickers on the top part of the strip (never see that on the sides nor bottom, and i tested that a lot).

    Any ideas to throw ??
     
  2. rayjam

    rayjam New Member

    Messages:
    3
    Hi,

    I have exactly the same problem. Did you fix it in the meantime?
     
  3. Mhut

    Mhut New Member

    Messages:
    23
    Hardware:
    RPi3
    Sorry but no way. I surrender because I can't find the reason nor I dont have any ideas on what can be the cause.
     
  4. eltanque

    eltanque New Member

    Messages:
    13
    Hardware:
    RPi2
    Have you connected the LED ground to the Pi?
     
  5. Mhut

    Mhut New Member

    Messages:
    23
    Hardware:
    RPi3
    Led is connected through USB to the pi.
    And is one unique strip, no soldering nor cuts.
    If the whole led was flickering, I've read some things to check and do. But what is strange to me is that I've described, just flickers only on the top way. The laterals and bottom are fine.