1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SOLVED No white light

Discussion in 'Software Support' started by Bill, 23 March 2020.

  1. Bill

    Bill New Member

    Messages:
    11
    Hardware:
    RPi3
    Greetings. I finally got my setup running and starting to calibrate the color. I run the first color, white, as a jpeg or video. I have no white light. I have tweaked ever setting under the sun. What am I missing?

    My setup is:
    Raspberry pi 4 running Raspbian.
    293 WS2813 LEDs.
    Easycap USB capture stick plugged into a powered hub.
    20 amp power supply for the lights.
    5 amp power supply for the Rpi.
    Hyperion.ng.

    The log is here:

    Note that you will see in the log: (WARNING) SPI rate 10000000 outside recommended range (2106000 -> 3075000).
    If I set the SPI rate inside that recommended range, the lights don't come on at all.

    Here is the config file:

    Thanks in advance for any help.
     
    Last edited: 24 April 2020
  2. Akriss

    Akriss Active Member

    Messages:
    562
    Hardware:
    RPi1/Zero, RPi2, RPi3, 32/64bit, +Arduino, +nodeMCU/ESP8266
    You can get your currant config by going to the web interface, under Configuration/General page,. There you can export the config file to your PC and then edit it if needed then import it back.

    Hope it helps.

    On a side note:
    Web interface of .NG is just Soooo easy. Thanks Dev's
    =)
     
  3. Bill

    Bill New Member

    Messages:
    11
    Hardware:
    RPi3
    Thanks! I added it to the original post.
     
  4. Akriss

    Akriss Active Member

    Messages:
    562
    Hardware:
    RPi1/Zero, RPi2, RPi3, 32/64bit, +Arduino, +nodeMCU/ESP8266
    Try adding " spidev.bufsiz=32768 " to " /boot/cmdline.txt ". Also try adding " core_freq=250 " to " /boot/config.txt " if running on a Rpi3.

    That's the tips from the rpi_ws281x library git page ( https://github.com/jgarff/rpi_ws281x#spi ) Hyperion makes use of that library.

    Hope its of help.
     
  5. harun

    harun Member

    Messages:
    150
    Hardware:
    RPi3

    Could you use your hyperion with watching movies? Because there should be a signol drop.
     
  6. Bill

    Bill New Member

    Messages:
    11
    Hardware:
    RPi3
    I added it to cmdline.txt. Same result, no white lights. I tried adding to config.txt but it wouldn't boot, probably because it's a Pi4.
     
  7. Bill

    Bill New Member

    Messages:
    11
    Hardware:
    RPi3
    Yes it works fine with movies and tv shows.
     
  8. harun

    harun Member

    Messages:
    150
    Hardware:
    RPi3
    What kind of movies? 1080 or 2160?
     
  9. Bill

    Bill New Member

    Messages:
    11
    Hardware:
    RPi3
    Both. Actually, I think I found the problem. I just realized I hooked up these 12 volt strips to a 5 volt power supply. When the 12 volt shows up in the mail I'll post if that fixed it.
     
  10. Bill

    Bill New Member

    Messages:
    11
    Hardware:
    RPi3
    Got my 12 volt power supply today. I have white lights. All is well. Thanks for everyone's help.
     
  11. harun

    harun Member

    Messages:
    150
    Hardware:
    RPi3
    nice buddy. But how is it possible that you could have ambilifht with 2160p movies? Every body got issues on the forum and on the libreelec forum.
     
  12. Bill

    Bill New Member

    Messages:
    11
    Hardware:
    RPi3
    Hello. Sorry for the late reply as I don't get notifications someone posted (is that possible?).

    Anyway, I believe the key is this splitter I got: https://www.amazon.com/gp/product/B07YTWL8Q8/ref=ppx_yo_dt_b_search_asin_title?ie=UTF8&psc=1. You can flip the dip switches to have some hdmi ports 4k and some 1080p. Hook up the 4k port to the tv and the 1080 port to the ambilight.

    Note: I just noticed I made a mistake in my first post. I'm running Raspbian, not Librelec, so I don't know if matters or not. I changed the first post to reflect Raspbian.
     
    Last edited: 24 April 2020
  13. harun

    harun Member

    Messages:
    150
    Hardware:
    RPi3
    no worries brother. Maybe because libreelec is different. I dont know. So many issues with the pi4.