1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Update Hyperion NG

Discussion in 'Development' started by fir3drag0n, 22 October 2019.

  1. Lord-Grey

    Lord-Grey Member

    Messages:
    36
    Hardware:
    RPi3, 32/64bit
    @Cosmicbase: Im Rahmen des PR #654 habe ich den LEDDevice-Code dahingehend geändert, dass bei einem Device Switch-off immer nocheinmal "Schwarz" ausgegeben wird. Bei API Devices kann natürlich auch ein API-Switch-off passieren.
    Das sollte eigentlich Dein Problem addressieren.
     
  2. Cosmicbase

    Cosmicbase Member

    Messages:
    163
    Hardware:
    RPi3, +Arduino
    Das bedeutet jetzt für uns, mich was?
    Muss ich jetzt irgendwas ändern oder kommt ein Update?
    Ich habe unter anderem bemerkt das die LEDs gelegentlich beim ausschalten des Odroid N2 anbleiben wenn ich ihn mit IR Fernbedienung auschalte.
    Wenn ich den N2 über Kodi ausschalte besteht das Problem nicht (die LEDs schalten aus).

    Meiner Meinung nach müsste beim betätigen der IR Fernbedienung noch eine shutdown der LEDs statt finden bevor er runter fährt.
     
    Last edited: 15 January 2020
  3. Lord-Grey

    Lord-Grey Member

    Messages:
    36
    Hardware:
    RPi3, 32/64bit
    Aktuell beendet hyperion.ng die LedDevices nicht definiert bei einem Shutdown.
    Es kann sein, dass Du das als Effekt siehst und mit dem IR Fernbedienungsausschalten verbindest.
    Kann aber auch sein, dass es andere Gründe gibt.

    Der PR #654 stellt sicher, dass das Device beendet wird bevor hyperion.ng ganz beendet wird.
    Der PR ist aktuell im Review der anderen Developer. Ein ETA-Date habe ich nicht.
     
  4. Cosmicbase

    Cosmicbase Member

    Messages:
    163
    Hardware:
    RPi3, +Arduino
    Super danke für die Info.
    Wäre super wenn es bald umgesetzt wird.
    Hoffentlich in Form eines Update in der CoreElec Repo.
    Wäre super wenn sich der eine oder andere Dev dazu äußert.
     
  5. Paulchen-Panther

    Paulchen-Panther Active Member Developer

    Messages:
    476
    Hardware:
    RPi1/Zero, RPi3, 32/64bit, +Arduino
    @Cosmicbase
    Hab dir Hyperion.NG als Kodi-addon für LibreElec kompiliert. Da ich aber kein Odroid N2 besitze müsstest du mal für uns testen. ;)
    service.hyperion.ng-9.80.2.100-amlogic.zip

    Wenn es im Main repo ist, wird @Portisch das bestimmt aktualisieren.
     
  6. Cosmicbase

    Cosmicbase Member

    Messages:
    163
    Hardware:
    RPi3, +Arduino
    OK werde es testen. Besten Dank.

    Bzgl. installieren:

    1. Direkt über .zip installieren funktioniert.

    2. Muss bei LE auch ein Dienst geschrieben und gestartet werden wie bei OSMC
     
    Last edited: 17 January 2020
  7. Cosmicbase

    Cosmicbase Member

    Messages:
    163
    Hardware:
    RPi3, +Arduino
    Hyperion.ng auf Odroid N2

    Ich fahre momentan auf 2 Systemen

    - CoreELEC --> mSD Card
    - LibreELEC --> USB 3.0

    Realisiert wird dieser Dualboot via Petitboot

    Für Tests von Hyperion.ng stehe ich für alle 2 Distributionen gerne zur Verfügung.
     
  8. fir3drag0n

    fir3drag0n Member

    Messages:
    54
    Hardware:
    RPi2, RPi3, +PhilipsHue
    Wo liegt der Vorteil eines Odroid N2 im Vergleich zum RPi(4)?
     
  9. Cosmicbase

    Cosmicbase Member

    Messages:
    163
    Hardware:
    RPi3, +Arduino
    Vorteile gibt es sehr viele.
    - der N2 ca 50 % schneller ist als der RPi 4
    - Steckplatz für emmc
    - 8Mb SPI für Multiboot (Petitboot)
    - BuildIn Infrarotsensor
    - schnelleren Grafikprozessor
    - Ein besseres Kühlungssystem
     
  10. Cosmicbase

    Cosmicbase Member

    Messages:
    163
    Hardware:
    RPi3, +Arduino
    @Paulchen-Panther
    Kurzes Update zu LE

    1. Installation via "Aus ZIP-Datei installieren hat geklappt.

    2. Komme aber auf die WebGui nur wenn ich in Konsole hyperiond eingebe.

    Bekomme aber diese Ausgabe...

    ##############################################
    # LibreELEC #
    # https://libreelec.tv #
    ##############################################

    LibreELEC (community): devel-20191224124640-6e9040d (AML.arm)
    LibreELEC:~ # hyeriond
    -sh: hyeriond: not found
    LibreELEC:~ # hyperion
    -sh: hyperion: not found
    LibreELEC:~ # hyperiond
    [hyperiond DAEMON] <ERROR> The AMLOGIC grabber can not be instantiated, because it has been left out from the build

    3. Test via Hyperion App funktioniert. Es lassen sich alle Farben mit App abbilden.

    4. Amlogic Grabber wirft keine Bildausgabe aus wenn ich TV schaue

    5. Es fehlt noch der Autostart Dienst.
    Wäre super wenn man den in die Zip mit rein schmeißen könnte.
     
  11. Cosmicbase

    Cosmicbase Member

    Messages:
    163
    Hardware:
    RPi3, +Arduino
    In der WebGui ist als Platform Frame buffer vordefiniert. Ich weiß nicht ob das so gewollt ist.
    Habe natürlich mal von Amlogic Grabber auf Framebuffer umgestellt und bekomme diese Ausgabe.

    ##############################################
    # LibreELEC #
    # https://libreelec.tv #
    ##############################################

    LibreELEC (community): devel-20191224124640-6e9040d (AML.arm)
    LibreELEC:~ # hyperiond
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Could not get screen information
    Segmentation fault
    LibreELEC:~ # hyperiond
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Could not get screen information
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Unknown pixel format: 43717680 bits per pixel
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Previous line repeats 1 times
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Unknown pixel format: 43500748 bits per pixel
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Previous line repeats 5 times
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Unknown pixel format: 43717740 bits per pixel
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Previous line repeats 1 times
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Unknown pixel format: 43500748 bits per pixel
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Previous line repeats 6 times
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Unknown pixel format: 43717812 bits per pixel
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Unknown pixel format: 43500748 bits per pixel
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Previous line repeats 7 times
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Unknown pixel format: 43717776 bits per pixel
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Previous line repeats 1 times
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Unknown pixel format: 43500748 bits per pixel
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Previous line repeats 64 times
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Unknown pixel format: 13199828 bits per pixel
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Previous line repeats 6 times
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Unknown pixel format: 43500748 bits per pixel
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Unknown pixel format: 43727364 bits per pixel
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Previous line repeats 3 times
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Unknown pixel format: 43500748 bits per pixel
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Previous line repeats 5 times
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Unknown pixel format: 43727364 bits per pixel
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Previous line repeats 3 times
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Unknown pixel format: 43500748 bits per pixel
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Unknown pixel format: 43727364 bits per pixel
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Previous line repeats 1 times
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Unknown pixel format: 43500748 bits per pixel
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Unknown pixel format: 43727364 bits per pixel
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Unknown pixel format: 43500748 bits per pixel
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Unknown pixel format: 43727364 bits per pixel
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Previous line repeats 1 times
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Unknown pixel format: 43500748 bits per pixel
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Previous line repeats 4 times
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Unknown pixel format: -265287808 bits per pixel
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Previous line repeats 4 times
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Unknown pixel format: 13199828 bits per pixel
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Previous line repeats 200 times
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Previous line repeats 200 times
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Previous line repeats 200 times
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Previous line repeats 200 times
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Previous line repeats 200 times
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Previous line repeats 200 times
    QSocketNotifier: Socket notifiers cannot be enabled or disabled from another thread
    QObject::startTimer: Timers cannot be started from another thread
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Previous line repeats 169 times
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Unknown pixel format: 42983772 bits per pixel
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Unknown pixel format: 43500748 bits per pixel
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Unknown pixel format: 42983772 bits per pixel
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Previous line repeats 1 times
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Unknown pixel format: 43500748 bits per pixel
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Previous line repeats 7 times
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Unknown pixel format: 42983772 bits per pixel
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Previous line repeats 1 times
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Unknown pixel format: 43500748 bits per pixel
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Previous line repeats 5 times
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Unknown pixel format: 42983772 bits per pixel
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Unknown pixel format: 43500748 bits per pixel
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Previous line repeats 6 times
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Unknown pixel format: 43733352 bits per pixel
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Previous line repeats 2 times
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Unknown pixel format: 13199828 bits per pixel
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Previous line repeats 2 times
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Unknown pixel format: 42983772 bits per pixel
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Previous line repeats 1 times
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Unknown pixel format: 43500748 bits per pixel
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Unknown pixel format: 42983772 bits per pixel
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Previous line repeats 1 times
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Unknown pixel format: 43500748 bits per pixel
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Previous line repeats 4 times
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Unknown pixel format: 42983772 bits per pixel
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Previous line repeats 1 times
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Unknown pixel format: 43500748 bits per pixel
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Unknown pixel format: 42983772 bits per pixel
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Previous line repeats 1 times
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Unknown pixel format: 43500748 bits per pixel
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Previous line repeats 200 times
     
  12. Paulchen-Panther

    Paulchen-Panther Active Member Developer

    Messages:
    476
    Hardware:
    RPi1/Zero, RPi3, 32/64bit, +Arduino
    @Cosmicbase
    Starte mal hyperiond mit debug ausgabe
    "hyperiond -d"
     
  13. Paulchen-Panther

    Paulchen-Panther Active Member Developer

    Messages:
    476
    Hardware:
    RPi1/Zero, RPi3, 32/64bit, +Arduino
    Am besten noch mal deinstallieren und neu installieren. Danach mit Debugausgabe starten. Danke
     
  14. Paulchen-Panther

    Paulchen-Panther Active Member Developer

    Messages:
    476
    Hardware:
    RPi1/Zero, RPi3, 32/64bit, +Arduino
    Ich lad mal das LibreELEC image für dich hoch. Musste ein paar Dependencies ergänzen. Kann sein das es daran liegt das dem normalen Image was fehlt.

    @fir3drag0n
    Werde am WE das Hyperion.NG Kodi Addon für den RPi compilieren.
     
  15. Paulchen-Panther

    Paulchen-Panther Active Member Developer

    Messages:
    476
    Hardware:
    RPi1/Zero, RPi3, 32/64bit, +Arduino
  16. Cosmicbase

    Cosmicbase Member

    Messages:
    163
    Hardware:
    RPi3, +Arduino
    Schreib wenn es oben ist.
    Werde es dann nochmal installieren und wie oben beschrieben loggen.

    Startet Hyperion.ng beim Start von Odroid automatisch oder muss noch ein Dienst erstellt werden...
     
  17. Paulchen-Panther

    Paulchen-Panther Active Member Developer

    Messages:
    476
    Hardware:
    RPi1/Zero, RPi3, 32/64bit, +Arduino
    Ist oben. Einen Post vor dir.

    Sollte eigentlich alleine starten.
     
  18. Cosmicbase

    Cosmicbase Member

    Messages:
    163
    Hardware:
    RPi3, +Arduino
    Upps OK.
    Hmm Ich glaube die richte DTB ist da schon richtig.
    Musste bei mir nix ändern weil der Odroid N2 bei dem Image Standart ist.
     
  19. Cosmicbase

    Cosmicbase Member

    Messages:
    163
    Hardware:
    RPi3, +Arduino
    Welche Plattform Framegrabber oder Amlogic?

    Hier mal ein kleiner log.

    ##############################################
    # LibreELEC #
    # https://libreelec.tv #
    ##############################################

    LibreELEC (community): devel-20191224124640-6e9040d (AML.arm)
    LibreELEC:~ # hyperiond -d
    [hyperiond MAIN] <INFO> Set user data path to '/storage/.hyperion'
    [hyperiond DAEMON] <DEBUG> <PythonInit.cpp:20:pythonInit()> Initializing Python interpreter
    [hyperiond SettingsManager] <DEBUG> <SettingsManager.cpp:101:SettingsManager()> Settings database initialized
    [hyperiond EFFECTFILES] <INFO> 37 effects loaded from directory :/effects/
    [hyperiond EFFECTFILES] <INFO> 20 effect schemas loaded from directory :/effects/schema/
    [hyperiond EFFECTFILES] <INFO> 0 effects loaded from directory /storage/.hyperion/custom-effects
    [hyperiond SettingsManager] <DEBUG> <SettingsManager.cpp:101:SettingsManager()> Settings database initialized
    [hyperiond BLACKBORDER] <DEBUG> <BlackBorderProcessor.cpp:65:handleSettingsUpdate()> Set mode to: default
    [hyperiond ComponentRegister] <DEBUG> <ComponentRegister.cpp:67:componentStateChanged()> Blackborder detector: enabled
    [hyperiond DAEMON] <INFO> set screen capture device to 'framebuffer'
    [hyperiond FRAMEBUFFERGRABBER] <DEBUG> <Grabber.cpp:33:setVideoMode()> Set videomode to 0
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Could not get screen information
    [hyperiond DAEMON] <INFO> Framebuffer grabber created
    [hyperiond V4L2:auto] <DEBUG> <Grabber.cpp:33:setVideoMode()> Set videomode to 0
    [hyperiond V4L2:auto] <INFO> Signal threshold set to: {12, 12, 12}
    [hyperiond V4L2:auto] <INFO> Signal detection is now disabled
    [hyperiond V4L2:auto] <INFO> Signal detection area set to: 0.250000,0.250000 x 0.750000,0.750000
    [hyperiond DAEMON] <DEBUG> <hyperiond.cpp:437:handleSettingsUpdate()> V4L2 grabber created
    [hyperiond JSONSERVER] <DEBUG> <JsonServer.cpp:25:JsonServer()> Created instance
    [hyperiond JSONSERVER] <INFO> Started on port 19444
    [hyperiond ComponentRegister] <DEBUG> <ComponentRegister.cpp:67:componentStateChanged()> LED device: enabled
    [hyperiond LEDDEVICE] <DEBUG> <LedDeviceAdalight.cpp:52:init()> Adalight header for 160 leds: Ada 0x00 0x9f 0xca
    [hyperiond LEDDEVICE] <INFO> LedDevice 'adalight' configured.
    [hyperiond LEDDEVICE] <INFO> Opening UART: /dev/ttyUSB0
    [hyperiond ComponentRegister] <DEBUG> <ComponentRegister.cpp:67:componentStateChanged()> Smoothing: enabled
    [hyperiond FLATBUFCONNECTION] <INFO> Connecting to Hyperion: 127.0.0.1:19401
    [hyperiond FLATBUFSERVER] <INFO> Started on port 19400
    [hyperiond EFFECTENGINE] <INFO> run effect Rainbow swirl fast on channel 0
    [hyperiond HYPERION] <DEBUG> <PriorityMuxer.cpp:153:registerInput()> Register new input 'System/EFFECT' with priority 0 as inactive
    [hyperiond HYPERION] <INFO> Initial foreground effect 'Rainbow swirl fast' started
    [hyperiond HYPERION] <DEBUG> <PriorityMuxer.cpp:153:registerInput()> Register new input 'System/GRABBER' with priority 250 as inactive[hyperiond LEDDEVICE] <DEBUG> <ProviderRs232.cpp:192:tryOpen()> Setting baud rate to 500000

    [hyperiond ComponentRegister] <DEBUG> <ComponentRegister.cpp:67:componentStateChanged()> Framegrabber: enabled
    [hyperiond PROTOSERVER] <INFO> Started on port 19445
    [hyperiond BOBLIGHT] <DEBUG> <BoblightServer.cpp:28:BoblightServer()> Instance created
    [hyperiond LEDDEVICE] <DEBUG> <ProviderRs232.cpp:208:tryOpen()> Device blocked for 1500 ms
    [hyperiond WEBSERVER] <DEBUG> <WebServer.cpp:105:handleSettingsUpdate()> Set document root to: :/webconfig
    [hyperiond WEBSERVER] <DEBUG> <WebServer.cpp:105:handleSettingsUpdate()> Set document root to: :/webconfig
    [hyperiond WEBSERVER] <INFO> Started on port 8090 name 'Hyperion Webserver'
    [hyperiond HYPERION] <INFO> Hyperion instance 'First LED Hardware instance' has been started
    [hyperiond HYPERION] <DEBUG> <PriorityMuxer.cpp:233:setInputImage()> Priority 0 is now active
    [hyperiond HYPERION] <DEBUG> <PriorityMuxer.cpp:333:setCurrentTime()> Set visible priority to 0
    [hyperiond WEBSERVER] <DEBUG> <WebServer.cpp:171:handleSettingsUpdate()> Setup SSL certificate
    [hyperiond WEBSERVER] <DEBUG> <WebServer.cpp:187:handleSettingsUpdate()> Setup private SSL key
    [hyperiond WEBSERVER] <INFO> Started on port 8092 name 'Hyperion Webserver'
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Unknown pixel format: 31030284 bits per pixel
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Previous line repeats 1 times
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Unknown pixel format: 30846084 bits per pixel
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Previous line repeats 5 times
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Unknown pixel format: 31030272 bits per pixel
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Previous line repeats 1 times
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Unknown pixel format: 30846084 bits per pixel
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Previous line repeats 4 times
    [hyperiond LEDDEVICE] <DEBUG> <ProviderRs232.cpp:226:writeBytes()> 37 frames dropped
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Unknown pixel format: 30846084 bits per pixel
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Previous line repeats 2 times
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Unknown pixel format: 29555304 bits per pixel
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Previous line repeats 1 times
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Unknown pixel format: 30846084 bits per pixel
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Previous line repeats 2 times
    [hyperiond LEDDEVICE] <DEBUG> <LedDeviceAdalight.cpp:80:receivedData()> >>received 4 bytes data
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Unknown pixel format: 30846084 bits per pixel
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Previous line repeats 4 times
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Unknown pixel format: 31030320 bits per pixel
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Previous line repeats 1 times
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Unknown pixel format: 30846084 bits per pixel
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Previous line repeats 61 times
    [hyperiond HYPERION] <DEBUG> <PriorityMuxer.cpp:293:setCurrentTime()> Timeout clear for priority 0
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Unknown pixel format: 30846084 bits per pixel
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Previous line repeats 2 times
    [hyperiond HYPERION] <DEBUG> <PriorityMuxer.cpp:333:setCurrentTime()> Set visible priority to 255
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Unknown pixel format: 13199828 bits per pixel
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Previous line repeats 200 times
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Previous line repeats 142 times
    [hyperiond WEBSOCKET] <DEBUG> <WebSocketClient.cpp:30:WebSocketClient()> New connection from ::ffff:192.168.2.30
    [hyperiond WEBSOCKET] <DEBUG> <JsonAPI.cpp:107:handleInstanceSwitch()> Client '::ffff:192.168.2.30' switch to Hyperion instance 0
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Unknown pixel format: 13199828 bits per pixel
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Previous line repeats 200 times
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Previous line repeats 200 times
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Previous line repeats 29 times
    [hyperiond WEBSOCKET] <DEBUG> <WebSocketClient.cpp:204:sendClose()> send close: 1000
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Unknown pixel format: 13199828 bits per pixel
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Previous line repeats 3 times
    [hyperiond WEBSOCKET] <DEBUG> <WebSocketClient.cpp:30:WebSocketClient()> New connection from ::ffff:192.168.2.30
    [hyperiond WEBSOCKET] <DEBUG> <JsonAPI.cpp:107:handleInstanceSwitch()> Client '::ffff:192.168.2.30' switch to Hyperion instance 0
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Unknown pixel format: 13199828 bits per pixel
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Previous line repeats 1 times
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Unknown pixel format: 0 bits per pixel[hyperiond FRAMEBUFFERGRABBER] <ERROR> Previous line repeats 81 times
    [hyperiond JSONSERVER] <DEBUG> <JsonServer.cpp:102:newConnection()> New connection from: ::ffff:192.168.2.66
    [hyperiond JSONCLIENTCONNECTION] <DEBUG> <JsonAPI.cpp:107:handleInstanceSwitch()> Client '::ffff:192.168.2.30' switch to Hyperion instance 0
    [hyperiond HYPERION] <DEBUG> <PriorityMuxer.cpp:153:registerInput()> Register new input '[email protected]::ffff:192.168.2.30/COLOR' with priority 50 as inactive
    [hyperiond HYPERION] <DEBUG> <PriorityMuxer.cpp:193:setInput()> Priority 50 is now active
    [hyperiond HYPERION] <DEBUG> <PriorityMuxer.cpp:333:setCurrentTime()> Set visible priority to 50
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Unknown pixel format: 30846060 bits per pixel
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Previous line repeats 2 times
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Unknown pixel format: 30846084 bits per pixel
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Previous line repeats 10 times
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Unknown pixel format: 30846060 bits per pixel
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Previous line repeats 3 times
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Unknown pixel format: 30846084 bits per pixel
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Unknown pixel format: 30846060 bits per pixel
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Previous line repeats 3 times
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Unknown pixel format: 30846084 bits per pixel
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Unknown pixel format: 30846060 bits per pixel
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Previous line repeats 3 times
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Unknown pixel format: 30846084 bits per pixel
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Unknown pixel format: 30846060 bits per pixel
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Previous line repeats 1 times
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Unknown pixel format: 30846084 bits per pixel
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Previous line repeats 5 times
    [hyperiond HYPERION] <DEBUG> <PriorityMuxer.cpp:250:clearInput()> Removed source priority 50
    [hyperiond HYPERION] <DEBUG> <PriorityMuxer.cpp:333:setCurrentTime()> Set visible priority to 255
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Unknown pixel format: -300939392 bits per pixel
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Previous line repeats 3 times
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Unknown pixel format: 13199828 bits per pixel
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Previous line repeats 58 times
    [hyperiond WEBSOCKET] <DEBUG> <WebSocketClient.cpp:204:sendClose()> send close: 1000
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Unknown pixel format: 13199828 bits per pixel
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Previous line repeats 3 times
    [hyperiond WEBSOCKET] <DEBUG> <WebSocketClient.cpp:30:WebSocketClient()> New connection from ::ffff:192.168.2.30
    [hyperiond WEBSOCKET] <DEBUG> <JsonAPI.cpp:107:handleInstanceSwitch()> Client '::ffff:192.168.2.30' switch to Hyperion instance 0
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Unknown pixel format: 13199828 bits per pixel
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Previous line repeats 113 times
    [hyperiond JSONSERVER] <DEBUG> <JsonServer.cpp:118:closedConnection()> Connection closed
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Unknown pixel format: 13199828 bits per pixel
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Previous line repeats 200 times
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Previous line repeats 200 times
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Previous line repeats 200 times
    [hyperiond FRAMEBUFFERGRABBER] <ERROR> Previous line repeats 200 times

    Hier der Log mit Amlogic Grabber

    ##############################################
    # LibreELEC #
    # https://libreelec.tv #
    ##############################################

    LibreELEC (community): devel-20191224124640-6e9040d (AML.arm)
    LibreELEC:~ # hyperiond -d
    [hyperiond MAIN] <INFO> Set user data path to '/storage/.hyperion'
    [hyperiond DAEMON] <DEBUG> <PythonInit.cpp:20:pythonInit()> Initializing Python interpreter
    [hyperiond SettingsManager] <DEBUG> <SettingsManager.cpp:101:SettingsManager()> Settings database initialized
    [hyperiond EFFECTFILES] <INFO> 37 effects loaded from directory :/effects/
    [hyperiond EFFECTFILES] <INFO> 20 effect schemas loaded from directory :/effects/schema/
    [hyperiond EFFECTFILES] <INFO> 0 effects loaded from directory /storage/.hyperion/custom-effects
    [hyperiond SettingsManager] <DEBUG> <SettingsManager.cpp:101:SettingsManager()> Settings database initialized
    [hyperiond BLACKBORDER] <DEBUG> <BlackBorderProcessor.cpp:65:handleSettingsUpdate()> Set mode to: default
    [hyperiond ComponentRegister] <DEBUG> <ComponentRegister.cpp:67:componentStateChanged()> Blackborder detector: enabled
    [hyperiond DAEMON] <INFO> set screen capture device to 'amlogic'
    [hyperiond DAEMON] <ERROR> The AMLOGIC grabber can not be instantiated, because it has been left out from the build
    [hyperiond V4L2:auto] <DEBUG> <Grabber.cpp:33:setVideoMode()> Set videomode to 0
    [hyperiond V4L2:auto] <INFO> Signal threshold set to: {12, 12, 12}
    [hyperiond V4L2:auto] <INFO> Signal detection is now disabled
    [hyperiond V4L2:auto] <INFO> Signal detection area set to: 0.250000,0.250000 x 0.750000,0.750000
    [hyperiond DAEMON] <DEBUG> <hyperiond.cpp:437:handleSettingsUpdate()> V4L2 grabber created
    [hyperiond JSONSERVER] <DEBUG> <JsonServer.cpp:25:JsonServer()> Created instance
    [hyperiond JSONSERVER] <INFO> Started on port 19444
    [hyperiond FLATBUFSERVER] <INFO> Started on port 19400
    [hyperiond PROTOSERVER] <INFO> Started on port 19445
    [hyperiond ComponentRegister] <DEBUG> <ComponentRegister.cpp:67:componentStateChanged()> LED device: enabled
    [hyperiond LEDDEVICE] <DEBUG> <LedDeviceAdalight.cpp:52:init()> Adalight header for 160 leds: Ada 0x00 0x9f 0xca
    [hyperiond LEDDEVICE] <INFO> LedDevice 'adalight' configured.
    [hyperiond LEDDEVICE] <INFO> Opening UART: /dev/ttyUSB0
    [hyperiond ComponentRegister] <DEBUG> <ComponentRegister.cpp:67:componentStateChanged()> Smoothing: enabled
    [hyperiond FLATBUFCONNECTION] <INFO> Connecting to Hyperion: 127.0.0.1:19401
    [hyperiond EFFECTENGINE] <INFO> run effect Rainbow swirl fast on channel 0
    [hyperiond LEDDEVICE] <DEBUG> <ProviderRs232.cpp:192:tryOpen()> Setting baud rate to 500000
    [hyperiond LEDDEVICE] <DEBUG> <ProviderRs232.cpp:208:tryOpen()> Device blocked for 1500 ms
    [hyperiond WEBSERVER] <DEBUG> <WebServer.cpp:105:handleSettingsUpdate()> Set document root to: :/webconfig
    [hyperiond WEBSERVER] <DEBUG> <WebServer.cpp:105:handleSettingsUpdate()> Set document root to: :/webconfig
    [hyperiond WEBSERVER] <INFO> Started on port 8090 name 'Hyperion Webserver'
    [hyperiond HYPERION] <DEBUG> <PriorityMuxer.cpp:153:registerInput()> Register new input 'System/EFFECT' with priority 0 as inactive
    [hyperiond HYPERION] <INFO> Initial foreground effect 'Rainbow swirl fast' started
    [hyperiond HYPERION] <DEBUG> <PriorityMuxer.cpp:153:registerInput()> Register new input 'System/GRABBER' with priority 250 as inactive
    [hyperiond ComponentRegister] <DEBUG> <ComponentRegister.cpp:67:componentStateChanged()> Framegrabber: enabled
    [hyperiond BOBLIGHT] <DEBUG> <BoblightServer.cpp:28:BoblightServer()> Instance created
    [hyperiond HYPERION] <INFO> Hyperion instance 'First LED Hardware instance' has been started
    [hyperiond WEBSERVER] <DEBUG> <WebServer.cpp:171:handleSettingsUpdate()> Setup SSL certificate
    [hyperiond WEBSERVER] <DEBUG> <WebServer.cpp:187:handleSettingsUpdate()> Setup private SSL key
    [hyperiond WEBSERVER] <INFO> Started on port 8092 name 'Hyperion Webserver'
    [hyperiond HYPERION] <DEBUG> <PriorityMuxer.cpp:233:setInputImage()> Priority 0 is now active
    [hyperiond HYPERION] <DEBUG> <PriorityMuxer.cpp:333:setCurrentTime()> Set visible priority to 0
    [hyperiond LEDDEVICE] <DEBUG> <ProviderRs232.cpp:226:writeBytes()> 37 frames dropped
    [hyperiond LEDDEVICE] <DEBUG> <LedDeviceAdalight.cpp:80:receivedData()> >>received 4 bytes data
    [hyperiond HYPERION] <DEBUG> <PriorityMuxer.cpp:293:setCurrentTime()> Timeout clear for priority 0
    [hyperiond HYPERION] <DEBUG> <PriorityMuxer.cpp:333:setCurrentTime()> Set visible priority to 255

    Ich muss aber Hyperion.ng immer nach dem Neustart manuell per hyperiond oder wie jetzt mit hyperiond -d starten.
    Also nix mit automatisch.
     
    Last edited: 17 January 2020
  20. Paulchen-Panther

    Paulchen-Panther Active Member Developer

    Messages:
    476
    Hardware:
    RPi1/Zero, RPi3, 32/64bit, +Arduino
    @Portisch meinte im Linux Kernel 4.9 wurden die ganzen AMLogic sachen entfernt. Kann schon sein das LE in seiner jetzigen form keine Unterstützung für den AMLogic Grabber mit sich bringt. Ein versuch war es Wert. Ich bleibe am Ball. Wenn es was neues gibt, geb ich dir Bescheid.